Emails sit in queue folder, never sent - RESOLVED

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Emails sit in queue folder, never sent - RESOLVED

Postby max7 » 09. January 2009 20:16

Greetings,

I just installed the latest version of XAMPP, going from 1.68 to 1.70 and now suddenly, when I test PHP scripts that were sending out emails to my gmail account under 1.68, the script runs ok but the emails are never sent out. Instead, they sit in the queue folder :cry:

Below are my mail logs and an error message I received; fyi I do not see the IP address below when I run ipconfig /all.

Last night, I also found in the queue folder a file that said something like "error 249, couldn't resolve @gmail.com" I checked the php.ini and I did change the SMTP from localhost to my ISPs SMTP, which again worked before under my previous installation of XAMPP. I also put the DNS IP I found in ipconfig /all in the mecurymail Name Servers field but this did not help.

All of this is really frustrating considering my previous install of XAMPP everything worked just fine and all I had to do was change the SMTP in my php.ini to my ISPs SMTP. I don't understand why I'm having so much trouble now :? Guidance would be greatly appreciated!

T 20090108 231048 4966876a Connection from 127.0.0.1
T 20090108 231048 4966876a HELO max-023fe7af57c
T 20090108 231048 4966876a MAIL FROM:<max@max.com>
T 20090108 231048 4966876a RCPT TO:<someemail@gmail.com>
T 20090108 231048 4966876a DATA - 9 lines, 150 bytes.
T 20090108 231048 4966876a QUIT
T 20090108 231048 4966876a Connection closed with 127.0.0.1, 0 sec. elapsed.
T 20090108 232738 49668ba1 Connection from 127.0.0.1
T 20090108 232738 49668ba1 HELO max-023fe7af57c
T 20090108 232738 49668ba1 MAIL FROM:<max@max.com>
T 20090108 232738 49668ba1 RCPT TO:<someemail@gmail.com>
T 20090108 232738 49668ba1 DATA - 9 lines, 146 bytes.
T 20090108 232738 49668ba1 QUIT
T 20090108 232738 49668ba1 Connection closed with 127.0.0.1, 0 sec. elapsed.
T 20090108 235642 49669293 Connection from 127.0.0.1
T 20090108 235642 49669293 HELO max-023fe7af57c
T 20090108 235642 49669293 MAIL FROM:<max@max.com>
T 20090108 235642 49669293 RCPT TO:<someemail@gmail.com>
T 20090108 235642 49669293 DATA - 10 lines, 156 bytes.
T 20090108 235642 49669293 QUIT
T 20090108 235642 49669293 Connection closed with 127.0.0.1, 0 sec. elapsed.


To: Electronic Postmaster <Admin@localhost>
From: Electronic Postmaster <postmaster@localhost>
Date: Fri, 9 Jan 2009 07:46:05 -0800
Subject: Postmaster Notify: Delivery Failure.
MIME-Version: 1.0
Content-type: multipart/mixed; boundary=5695.1171343

This message is in MIME format. If you are seeing this text,
then your mailer does not understand this format properly.

--5695.1171343
Content-type: Text/Plain; charset=US-ASCII
Content-Disposition: Inline
Content-Description: Reason for delivery failure.

The attached message has failed delivery and has been referred
to you as postmaster. The following error report or reports
were given to explain the problem:

*** someemail@gmail.com
550-5.7.1 [98.151.37.105] The IP you're using to send mail is not authorized

--5695.1171343
Content-type: Message/RFC822

Received: from spooler by localhost (Mercury/32 v4.52); 9 Jan 2009 07:45:21 -0800
Received: from max-023fe7af57c (127.0.0.1) by localhost (Mercury/32 v4.52) ID MG000005;
9 Jan 2009 07:45:15 -0800
Date: Fri, 09 Jan 2009 07:45:15 -0800
Subject: My PHP form info
To: someemail@gmail.com
From: max@max.com
Message-ID: <1133A067BD@localhost>

max
maxy
chow chow

max@maxy.com

--5695.1171343--
Last edited by max7 on 13. January 2009 03:07, edited 1 time in total.
max7
 
Posts: 9
Joined: 09. January 2009 19:26

Re: Emails sit in queue folder, never sent

Postby Wiedmann » 09. January 2009 20:27

*** someemail@gmail.com
550-5.7.1 [98.151.37.105] The IP you're using to send mail is not authorized

GMail doesn't accept mails from your IP (dsl dial-up line).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Emails sit in queue folder, never sent

Postby max7 » 09. January 2009 20:57

But that doesn't make sense since, before I installed this latest version of XAMPP, it was accepting my emails just fine.
max7
 
Posts: 9
Joined: 09. January 2009 19:26

Re: Emails sit in queue folder, never sent

Postby max7 » 09. January 2009 21:07

What I mean by my last comment is: what could have changed within about a week to have gmail not accept my emails? I am on a cable connection as well, if that makes any difference. Perhaps this has something to do with my network connections?
max7
 
Posts: 9
Joined: 09. January 2009 19:26

Re: Emails sit in queue folder, never sent

Postby Izzy » 10. January 2009 01:28

max7 wrote:]T 20090108 231048 4966876a HELO max-023fe7af57c
It may be that you are sending the wrong HELO message.


Some links for you to look through that may help with investigating your issue.

This from http://www.au.sorbs.net/lookup.shtml if it helps.
SORBS wrote: Dynamic IP Space (LAN, Cable, DSL & Dial Ups)
Netblock: 98.144.0.0/13 (98.144.0.0-98.151.255.255)
Record Created: Fri Jan 2 00:23:09 2009 GMT
Record Updated: Fri Jan 2 00:23:09 2009 GMT
Additional Information: [#218700 - RoadRunner Supplied List (02/01/2009)] Dynamic/Generic IP/rDNS address, use your ISPs mail server or get rDNS set to indicate static assignment.
Currently active and flagged to be published in DNS
If you wish to request a delisting please do so through the Support System.

This from a Spamhaus PBL query:
http://www.spamhaus.org/pbl/query/PBL238673
Spamhaus PBL query wrote:98.144.0.0/13 is listed on the Policy Block List (PBL)
Followed by Road Runners policy and how to fix your issue perhaps


This from a Spamhaus CBL query:
http://cbl.abuseat.org/lookup.cgi?ip=98.151.37.105
Spamhaus CBL query wrote:IP Address 98.151.37.105 is currently listed in the CBL.
It was detected at 2009-01-09 16:00 GMT (+/- 30 minutes), approximately 8 hours ago.
Find out why here:
http://cbl.abuseat.org/namingproblems.html


Wiedmann wrote:GMail doesn't accept mails from your IP (dsl dial-up line).
Wiedmann pointed out the issue and your best course of action would have been to investigate further why perhaps GMail does not accept mail from your IP - in the Internet World what worked a minute ago may not work a minute later.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Emails sit in queue folder, never sent

Postby max7 » 10. January 2009 05:13

Thanks for that reply; it's interesting because it seems that I dealt with this problem a while back when I was using a different mail server. The solution to that problem was to use my ISPs SMTP server instead and that solved the problem. Of course then I was working with IIS/ASP scripts but regardless.

When I first used Mercury Mail on XAMPP, it was on vers. 1.68 and it was painfully simple to set up: I merely changed the localhost designation to my ISPs SMTP server in the php.ini, launched Mercury Mail and it worked. :D

So in the end, I wish I could understand clearly what I did on my previous configuration of XAMPP/Mecury Mail and replicate it with my current configuration. As far as I can tell, I didn't change my approach at all which makes it all the more puzzling :?

One last thought: I noticed under Configuration/MercuryE/Address Discovery & DNS, it says following under the Name Servers: field:

Enter name server IP addresses separated by commas. If you leave this field blank, MecuryE will use the name servers defined in the Windows Network control panel.


I checked my network connections and everything is set to detect automatically. Is this a possible issue and am I looking in the right places :?:

Thanks,
Max
max7
 
Posts: 9
Joined: 09. January 2009 19:26

Re: Emails sit in queue folder, never sent

Postby Izzy » 10. January 2009 05:53

NameServers are normally associated with a domain name (mydomain.com for example) at your domain name registrar (GoDaddy for example) which, as the name implies, distributes your domain name throughout the Internet.

DNS is an old fussy issue and Mercury may have it's very own DNS client.

In a post on another forum, that I include below, it was suggested to insert the IP addresses of a public DNS server in Address Discovery & DNS - the solution solved a similar issue as yours for the topic's OP and is explained quite well.
routinet wrote:I'm not at all familiar with MercuryE, but it sounds like it uses its own mini-DNS client. Normally, an internet connection obtains the primary DNS server during DHCP, the same process through which it will receive an IP. The server list is sent along with other configuration items. I'm not sure how MercuryE would decide which server to use since each connection could have different lists.

In any case, you need to put a DNS server IP in the box provided, then it should work. This does not mean put the IP of hotmail.com in there...that's not a DNS server. Neither is localhost (127.0.0.1), unless you happen to run your own domain on that same box. Contact your ISP, or google for a publicly available DNS server to use.
Accepted Solution


You may have used your ISP as an SMTP relay in the lost previous Mercury Configuration and if you are doing that again then it should work the same as nothing of any significance has been change in the new version of XAMPP relating to Mercury.

So it would seem that other factors may have changed like the issues pointed out in my above post that would need to be addressed and the DNS solution may do it.



TIP
So as not to loose any previous data like configurations etc. when updating or installing a new version simply drag your old xampp folder to another location holding down the Ctrl key, it will create a folder called Copy of xampp - this can be done even in the same root drive location like C:\ for example which would create a location C:\Copy of xampp.

Now you can safely edit over to the new version any personal configurations or at least read the old configurations.

You can find the previous Mercury configurations in the MERCURY.INI file in the Mercury folder and each configuration has it's own section - so a good undelete program may be able to undelete the folder and resurrect your old mercury.ini file (it's not in the Recycle Bin is it?)

In the [MercuryE] section of the new version MERCURY.INI file is a commented out IP #139.80.64.1 which is a name server of Mercury Mail's author, if that helps understand what you have to put in that section.
IP Look Up wrote:ns_name_01: elrond.otago.ac.nz
ns_ip4_01: 139.80.64.1
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Emails sit in queue folder, never sent

Postby max7 » 10. January 2009 08:55

You may have used your ISP as an SMTP relay in the lost previous Mercury Configuration and if you are doing that again then it should work the same as nothing of any significance has been change in the new version of XAMPP relating to Mercury.


That is exactly what I was doing which is why I am extremely perplexed and frustrated with this issue -- it should not be! :evil:

That not withstanding, I tried the suggestion in your last post and it worked . . . once. Yes, for some reason unbeknownst to me, one email was allowed through and arrived at my gmail account.

I tried it two different ways: first, I used OpenDNS and in my network settings I had it use the primary and alternative DNS addresses which should work since Mecury mail says it will look there for this information if no DNS is available in the DNS field just above it; this was when it worked for the one and only time. When I tested it for a third, fourth and fifth time and it didn't work again :roll: , I decided to put the OpenDNS addresses in the Address Discovery & DNS/DNS field as instructed. Still no luck.

Here is one thing: the cable guy came out this past Sunday to check our connections due to ongoing issues. At one point, he sat at my computer and I saw him do something with my network connections, what I don't know. It just so happens that it was after this AND after installing the new XAMPP that my trouble started. While I wonder if he didn't mess up my configuration somehow, I can't fathom what he would have done except to make sure my settings were set to automatic detection which is usually what they will do.

In any case, I have it set to use OpenDNS now and it's still not working (save for that one instance) so I'm stumped. Perhaps a reinstall of XAMPP might help? I'm getting desperate here :cry:
max7
 
Posts: 9
Joined: 09. January 2009 19:26

Re: Emails sit in queue folder, never sent

Postby Izzy » 10. January 2009 09:30

Very frustrating and incomprehensible that only one e-mail got through.
They may have a time limit between each e-mail that is sent which again is to prevent mass e-mailing - I do know that this technique is used by other free e-mail services but you should get an error message accordingly.

Any clues C:\xampp\MercuryMail\LOGS in the log files?

In Protocol modules... Select active protocol modules have you tried swapping MercuryE to MercuryC for SMTP relay client when using that protocol?

Like you, I am at a loss here now especially once it worked and then no workee - very strange, it is as if GMail has something to do with this as they do use some sophisticated blocking techniques to prevent spammers exploiting their system like SPF and reverse DNS PTR. They know that certain Cable users that use Mail servers have been responsible for so much spam emanating from their servers.

Anyhow, if you do decide to install 1.6.8 again follow my tip to just make a copy of this current xampp folder so you can actually switch between the 2 but you will not be able to run both at the same time - and change the install method by using the self extracting 7zip exe version then after extraction simply run the xampp_setup.bat file.

I really don't think that this issue you have is XAMPP version related but may have been a coincidence or some other issue that occurred in between the time the version changes occurred.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Emails sit in queue folder, never sent

Postby max7 » 10. January 2009 19:21

Some interesting developments:
1) When I use the OpenDNS DNS addresses in my network connections, the emails seem to *eventually* arrive in my gmail account e.g. the emails I sent out last night were in my Inbox this morning and yet the time stamps of their journey indicates minutes, not hours. By contrast, under my previous XAMPP installation it was basically seconds from the time I excecuted my script to the time the email would appear in my Inbox

2) The IP address that keeps appearing on the emails that are sent to gmail (98.151.37.105) seems to be a bit dodgy. I left Mecury Mail running on the XAMPP control panel while my wife was using the computer and she was blocked from viewing a page and a warning page said that the IP address we were using might be the source of malicious activity. I went to Spamhaus and here's the listing for it:

IP Address Lookup

98.151.37.105 is not listed in the SBL

98.151.37.105 is listed in the PBL, in the following records:

* PBL238673

98.151.37.105 is listed in the XBL, because it appears in:

* CBL


So if this IP is blacklisted, would this not explain why my emails either take a really long time to appear and/or they don't appear at all? More importantly however, where is this IP address coming from and how is getting associated with my Mercury mail? I do not see it when I run ipconfig /all.

In Protocol modules... Select active protocol modules have you tried swapping MercuryE to MercuryC for SMTP relay client when using that protocol?


You are going to laugh but when I do this, Mecury crashes and will not start up until I go into the mecury.ini and manually change the settings back to using MercuryE :roll: I thought that perhaps using specific DNS in my network connections caused a problem so I went back to detecting settings automatically, but no dice. Here's the error message I get:

AppName: mercury.exe AppVer: 4.5.2.0 ModName: mercuryc.dll
ModVer: 4.5.2.0 Offset: 00005042


Maybe this is a sign I should try a reinstall of XAMPP 1.70? :?

Any clues C:\xampp\MercuryMail\LOGS in the log files?


I don't see anything obviously wrong but take a look for urself:

Code: Select all
T 20090109 231529 4967d9f9 Connection from 127.0.0.1
T 20090109 231529 4967d9f9 HELO max-023fe7af57c
T 20090109 231529 4967d9f9 MAIL FROM:<postmaster@localhost>
T 20090109 231529 4967d9f9 RCPT TO:<someemail@gmail.com>
T 20090109 231530 4967d9f9 DATA - 9 lines, 160 bytes.
T 20090109 231530 4967d9f9 QUIT
T 20090109 231530 4967d9f9 Connection closed with 127.0.0.1, 1 sec. elapsed.
T 20090109 232858 4967dda9 Connection from 127.0.0.1
T 20090109 232858 4967dda9 Connection closed with 127.0.0.1, 0 sec. elapsed.
T 20090109 233008 4967ddaa Connection from 127.0.0.1
T 20090109 233008 4967ddaa HELO max-023fe7af57c
T 20090109 233008 4967ddaa MAIL FROM:<max@max.com>
T 20090109 233008 4967ddaa RCPT TO:<someemail@gmail.com>
T 20090109 233008 4967ddaa DATA - 9 lines, 153 bytes.
T 20090109 233008 4967ddaa QUIT
T 20090109 233008 4967ddaa Connection closed with 127.0.0.1, 0 sec. elapsed.
T 20090109 233344 4967de67 Connection from 127.0.0.1
T 20090109 233344 4967de67 HELO max-023fe7af57c
T 20090109 233344 4967de67 MAIL FROM:<max@max.com>
T 20090109 233344 4967de67 RCPT TO:<someemail@gmail.com>
T 20090109 233344 4967de67 DATA - 9 lines, 154 bytes.
T 20090109 233344 4967de67 QUIT
T 20090109 233344 4967de67 Connection closed with 127.0.0.1, 0 sec. elapsed.
T 20090110 004459 4967ef43 Connection from 127.0.0.1
T 20090110 004459 4967ef43 HELO max-023fe7af57c
T 20090110 004459 4967ef43 MAIL FROM:<max@max.com>
T 20090110 004459 4967ef43 RCPT TO:<someemail@gmail.com>
T 20090110 004459 4967ef43 DATA - 9 lines, 157 bytes.
T 20090110 004459 4967ef43 QUIT
T 20090110 004459 4967ef43 Connection closed with 127.0.0.1, 0 sec. elapsed.


Which way do I go from here? Perhaps back to 1.68 rather than reinstall 1.70?
Last edited by max7 on 10. January 2009 21:34, edited 1 time in total.
max7
 
Posts: 9
Joined: 09. January 2009 19:26

Re: Emails sit in queue folder, never sent

Postby max7 » 10. January 2009 21:09

It seems *perhaps* the HELO message very well may be the problem. I confirmed the IP I'm assigned is a valid one from my cable provider but nevertheless, it has still been flagged as evidence of the listing at spamhaus. I followed the CBL guidelines for testing my HELO configuration which states:

...you will get bounce message back that appears to indicate that your email to helocheck didn't work. It did. It's _supposed_ to work that way. The important piece to check is the error message you see.

Examine the error message, and you should see something like one of the following lines:

#5.1.1 SMTP; 550 Your HELO name for IP address 1.2.4.6 was "localhost.localdomain"
#5.1.1 SMTP; 550 Your HELO name for IP address 1.2.4.6 was "localhost"
#5.1.1 SMTP; 550 Your HELO name for IP address 1.2.4.6 was "smtp"
#5.1.1 SMTP; 550 Your HELO name for IP address 1.2.4.6 was "1.2.4.6"
#5.1.1 SMTP; 550 Your HELO name for IP address 1.2.4.6 was "[1.2.4.6]"
#5.1.1 SMTP; 550 Your HELO name for IP address 1.2.4.6 was "mail.example.com"

It should be the fully qualified domain name for your mail server or an IP address enclosed in square brackets.
In the above example, the first four examples are syntactically wrong by RFC2821. The last two are valid.
If it isn't like one of the last two examples, you have found the problem that needs to be fixed.


The example provided in the guidelines looks like a mail log so when I check my mail log, I see the following:

T 20090110 114739 49688985 HELO max-023fe7af57c


this HELO is simply the name of my computer and if I'm reading the CBL guidelines correctly regarding what constitutes a valid HELO (last two examples in first quote), mine would be invalid. Hence, my problem is an invalid servername resulting in an invalid HELO. CBL then states:

Consult your mail software documentation/configuration panels on how to set the "server name" to what it should be.


So assuming this is all correct, how do I set the server name correctly? Meanwhile, I will check my system for infection to be sure this is not the cause while I await some feedback.
max7
 
Posts: 9
Joined: 09. January 2009 19:26

Re: Emails sit in queue folder, never sent

Postby Izzy » 11. January 2009 00:46

At least you are much closer and FWIW I did point out the Spamhaus IP blocking links in one of my replies above - viewtopic.php?p=132579#p132579

Experiment with the Identify me as box in the MercuryE settings - possibly the HELO setting so put your IP in [98.151.37.105] brackets in the box and try that.

Try not to use localhost or 127.0.0.1 anywhere in your settings rather use a more definitive name like postamaster@localhost should be perhaps postmaster@[your domain in here or your IP perhaps] again experiment with this as some e-mail service providers baulk at localhost or 127.0.0.1 in the e-mail headers, spammers use it as they don't know how to change it perhaps and is clear indication it is coming from a home PC perhaps.

In your Mercury Core Module Configuration settings you have a timed queue processing settings and in other places there are timed settings also - experiment with these settings to see how these queue and time out issues may be configured, even though you are on cable there can still be delays on the net that cause things to time out and therefore instigate a delay and do click on the Help button for some comprehensive help with configuration settings - although, having said that, some of the help is a bit vague.

Local Domains tab can be configured here with respect to localhost not being localhost.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Emails sit in queue folder, never sent

Postby max7 » 11. January 2009 00:53

I do not pretend to understand any of what I'm dealing with however it seems the problem of being able to receive emails from my PHP scripts has been resolved.

The resolution consisted of:
  • Designating the DNS server addresses (primary and alternative)in network connections/IP properties
  • input my ISPs domain in Advanced TCP/IP settings/"DNS suffix for this connection" field.

Once I did this, the emails flowed as they should, appearing in only seconds after I executed my script.

The only question that remains is, did this resolve what I believe to be the real cause of all this upset, namely an invalid HELO? I'm not sure on this point but, in anticipation of victory, I requested that my IP be delisted from CBL. I will find out soon enough if this isn't resolved.

In the end, I still do not know how all this mess got started. Was it the cable guy messing with my Network connections? Was it simply the fact that I got lucky with XAMPP 1.68 and if so, how did that work so easily? And what about the fact that when I tried swapping MercuryE to MercuryC for SMTP relay client and Mecury mail would crash each time? Does this indicate a level of corruption on this install and would a reinstallation be the wise move?

I would love to hear some comments on these.
max7
 
Posts: 9
Joined: 09. January 2009 19:26

Re: Emails sit in queue folder, never sent

Postby Izzy » 13. January 2009 01:26

The resolution consisted of:

* Designating the DNS server addresses (primary and alternative)in network connections/IP properties
* input my ISPs domain in Advanced TCP/IP settings/"DNS suffix for this connection" field.


Once I did this, the emails flowed as they should, appearing in only seconds after I executed my script.
Thanks for posting back with the solution as it may help others with a similar issue - I am also pleased that your hard work and investigation payed off.

The only question that remains is, did this resolve what I believe to be the real cause of all this upset, namely an invalid HELO? I'm not sure on this point but, in anticipation of victory, I requested that my IP be delisted from CBL. I will find out soon enough if this isn't resolved.
Did you finally discover the answer to this?


In the end, I still do not know how all this mess got started. Was it the cable guy messing with my Network connections? Was it simply the fact that I got lucky with XAMPP 1.68 and if so, how did that work so easily? And what about the fact that when I tried swapping MercuryE to MercuryC for SMTP relay client and Mecury mail would crash each time? Does this indicate a level of corruption on this install and would a reinstallation be the wise move?
When service staff are allowed to tinker unobserved and unquestioned as to what they are or have done then anything is possible, unfortunately.

I don't think luck played a part not in the issues of PC behavior - there is always a cause and effect at play.

There is always a possibility of corruption when downloading and installing a file from the Internet but in your case, as I have pointed out before, it is highly unlikely - but if you feel that a reinstall is warranted, even just to put your mind at ease, then follow my instruction above so you can, if required, fall back to this current install, also you will be able to copy over and edit your configuration files from this current install to the new install without loosing anything.

Good luck with it.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Emails sit in queue folder, never sent - RESOLVED

Postby max7 » 13. January 2009 02:58

FYI, it did resolve the HELO/Authentication issue; I know this because I have sent a number of emails out using my scripts and our IP has not yet been blacklisted on CBL . . . yet 8)

The only reason I would do a reinstall at this point is in attempt to resolve the module swap problem I encounted where Mercury would crash upon start up . . . and I would resinstall 1.70 not 1.68.

Thanks for your hard work as well, Izzy. Greatly appreciated! :D
max7
 
Posts: 9
Joined: 09. January 2009 19:26

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests