Page 1 of 1

Weird MySQL service install issue + solution

PostPosted: 09. January 2009 00:06
by klipper
My problem + solution with new Xampp 1.7.0: (win Vista home premium)
Instead of upgrading version 1.6.8 I made a fresh install of v 1.7.0.
As usual with new install I started with installing setup_xampp.bat, started up xampp-control.exe (as administrator) and tried to install Filezilla, MySQL an Apache as a service.
In older versions this worked always perfectly, but with version 1.7.0. install of the MySQL as a service failed. So I followed up all advice I found in previous posts in this forum. Deleted the "not existing" service, deleted the old "my.ini" file from the windows directory. But installing the MySQL from the control panel failed again.
Then I tried installing the MySQLservice by running mysql_installservice.bat from the C:\Xampp\mysql directory (As administrator). I got errors about paths not found running this .bat file. I finaly runned the same mysql_installservice.bat from within a dos box started up as administrator and finaly this installed the service, and solved my problem.
But Why is this happening in the new 1.7.0 version. I assume the Controlpanel triggers the mysql_installservice.bat too. In older versions this worked always flawless?
I compared the batch files from version 1.6.8 and 1.7.0: only difference is the name of the executable bin\mysqld instead of bin\mysqld-nt !!! So what happened?

Hope this can help someone else with same trouble, and maybe someone can answer my question?