What is wrong her?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: What is wrong her?

Postby b1ng0 » 14. January 2009 00:02

no error appear! just the old one
Code: Select all
[Tue Jan 13 22:35:09 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/function.fopen, referer: http://localhost/
[Tue Jan 13 22:47:44 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/faq
b1ng0
 
Posts: 21
Joined: 08. January 2009 14:55

Re: What is wrong her?

Postby Izzy » 14. January 2009 01:00

b1ng0 wrote:no error appear! just the old one
Code: Select all
[Tue Jan 13 22:35:09 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/function.fopen, referer: http://localhost/
[Tue Jan 13 22:47:44 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/faq
This is a slightly different error message to the previous one.

Your php code may be incorrect and I am not a php guru but the message tells all, function.fopen is not a file and so does not exist.

So check that the folder faq is in the htdocs folder, as according to the error message this folder also does not exist and the file referred to does not exists and obviously function.fopen is not a file it is a function contained within the code of a .php file.

Experiment with the settings register_globals = ON (OFF by default) and safe_mode= OFF (ON by default) in xampp\apache\bin\php.ini if you find no script errors - the default settings are for security and if your php scripts work with the non-default settings then the scripts need to be updated so they work with the default security settings.

You can always paste here the relevant php code so it can be looked and possibly to highlight any errors.

This post by Wiedmann has a code snippet to add to the top of your php script on the page that won't display to perhaps give you a more detailed php error message:
viewtopic.php?f=16&t=32669&p=132057

Post back here what you see when you go to http://localhost/xampp
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: What is wrong her?

Postby b1ng0 » 14. January 2009 18:47

Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.
Error 404
localhost
01/14/09 17:42:35
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.8

but if i go to http://localhost/orginal/xampp/ i get xampp! i moved all the orginal files to map in htdocs that name orginal
b1ng0
 
Posts: 21
Joined: 08. January 2009 14:55

Re: What is wrong her?

Postby b1ng0 » 15. January 2009 00:37

Never mind! I have fix all problems ;D but now i want to get my site online! how can i do that?
b1ng0
 
Posts: 21
Joined: 08. January 2009 14:55

Re: What is wrong her?

Postby Izzy » 15. January 2009 01:27

b1ng0 wrote:Never mind! I have fix all problems ;D but now i want to get my site online! how can i do that?
This topic is now way too big and your question is now off topic.

Please start a new thread with your new question and try a forum search first.
Thanks
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 69 guests