Changed Listen Port Number

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Changed Listen Port Number

Postby rebelbrowser » 07. January 2009 01:09

Warning: expect a follow up question, or at least a thank you for fixing me.
At best, I'm a novice but capable, just ask and you shall recieve answers to any questions you might have.
Good luck with helping me.


I found the httpd.conf file and changed the listen 80 and the ServerName localhost:80 setting.
I have gone back and forth between both settings and tried every combo using port number 1111.
Despite the xampp control panel saying apache is always running on port 80 it worked normally on 1111
I have a joomla folder that works fine on 1111.

However, mybboard was placed in the default htdocs folder and worked fine until I changed to 1111.
I can access the localhost:1111/admin (for the board) but it wont keep any settings changes to the board and it keeps asking for a login after each nav. (i suspect a permissions issue)

I went into the board and changed a setting telling it what the new url is now. ie http://name.com:1111
It still doesnt work and now I can't change the board setting back to normal port 80 ie http://name.com

What went wrong, can we fix it or should I plan a new install of the whole thing from xampp to mybboard ?

I find the xampp, apache, mysql, php thing is awsome as it has done what I have failed to do time after time,
The relationships between content manager, php and mysql is still my biggest challenge.


Thank you for reading.
BTW I posted somthing simliar to this at the mybboard help forum, but so far they have nothing.
rebelbrowser
 
Posts: 11
Joined: 07. January 2009 00:17

Re: Changed Listen Port Number

Postby Sharley » 07. January 2009 01:23

Ignore the message in the XAMPP Control Panel it is hard coded and quite brain dead.

Go to what ever port you changed the settings to in the httpd.conf file and remember to save and restart Apache for those changes to be recognized.
http://localhost:1111

If that works and Joomla works then the issue is with your other script, which I know zero about and you have done the right thing and contacted that script's developer site - just have to wait I suppose, unlike these forums. ;)

http://community.mybboard.net/thread-43021.html



On Windows it is quite often path issues not permissions as permissions are mainly associated with a Linux Apache sever.

Your path would be "C:\xampp\htdocs\{your bb folder in here}" contained, as posted, inside the quote marks if you installed XAMPP to the default location.

On a Linux system it might be usr/you/public_html/yourbbdirectory so if you see any of those type paths in the configuration settings change them to the above, which hopefully might help.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Changed Listen Port Number

Postby Sharley » 07. January 2009 01:54

I edited my post after reading the forum thread I posted above and if all else fails re-install the bb script after uninstalling it which may entail also deleting the MySQL database.

BTW this post might help with listening port changes and a post by me below it will help with the my.cnf location issue:
viewtopic.php?p=130963#p130963
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Changed Listen Port Number

Postby rebelbrowser » 07. January 2009 04:59

I think I understand the path issues I suppose.

seems like apache will produce the default doc in the htdocs folder, so I left it at that when I decided to run the BB as the main content. Your calling the BB and joomla scripts, I been calling them content managers....lol

so yes it lives in the http://myname.com directory.
the bb appears when I call on it, it just doesnt look all there. And you cant log into it.
like its broken. the template is missing. I think its disconnected from itself.

When you say delete the mysql database associated with the botched bb,
I would have no idea what that looks like or where to find it.
As I browse through these folders I am amazed. :shock:
perhaps I can retreat for now and do this whole thing from the top a few times before I get comfortable with the how why and where I want it to work.
I am just glad to be a part of it, beings I finally had it handed to me on a platter.

Its alot like using a calculator or gps.... I just hope I dont get any dumber from using too much of all this wonderful end user stuff. :?

I will do a reinstall of the script.

thanks for responding an for the advise.
rebelbrowser
 
Posts: 11
Joined: 07. January 2009 00:17

Re: Changed Listen Port Number

Postby Sharley » 07. January 2009 08:34

When you say delete the mysql database associated with the botched bb, I would have no idea what that looks like or where to find it.
Use phpMyAdmin and look for the database name that your bb script created on install in the left frame menu - you should be able to recognize it.
http://localhost/phpmyadmin

To delete it click on the database but make sure you don't click on any of the other databases by mistake just your bb database.

Then find in the top menu the red Drop button.

You will be prompted if you want to destroy a database - click OK to delete your bb database.

Close the Window and your done.

The other part of learning how to install apps or scripts is to learn how to do a clean uninstall by not leaving any residue behind.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Changed Listen Port Number

Postby rebelbrowser » 09. January 2009 16:21

I should start a new thread as I have made some progress since this thread...
For one thing I have completely uninstalled and started from scratch.
I have been finding my way around the folder groups and have installed and reinstalled many times..

Between xampp and mybboard, I dont see why it should be so difficult a task to change the listen ports and or "virtual hosting" so as to accomodate iis on 80 and the WHOLE apache on a different port. I have tried everything I can find and everything I know how to do.

Since I dont know how to change window terminal services port from 80 to something else I decided it would be easiest to change the cool new free apache xampp mybboard install to the different port and run with it.

ya right ! its been over a week now and all I've done is botch the cool new apache with cool new free mybboard running on it.
the upside is I have gotten really good at reinstalling the xampp package and placing the mybboard into it.
have I said that already !
prob is I need the mybboard to work when I change apache listen port and it doesnt.
Works great if I dont change any defaults that go with xampp initial install.
Must have something to do with the php and mysql.
hmmm if only there were a walk through how to do this...'
guess I am the only one needing to make this little change happen huh...

Well, should I start a new thread !?

seems like I cant find the my.ini file...
I have to change all three folders to work with a different port number.
1. apache = conf\httpd.conf change the listen and the servername localhost:newportnumberhere
this is easy.

2. php = i got nothing yet

3. mysql = find the my.ini and start experimenting with that file...

4. mybboard = MySQL Improved Database Settings
Database Server Hostname: localhost:newportnumberhere
Database Username: newusernamehere
Database Password: newpasswordhere
Database Name: mysql seems like creating a new database doesnt work for mybboard as it needs the mysql database that was setup by default with some 20+entries already in it.... (whatever)



then change the mysql root login and password
from command console and nav to bin, type somthing -u "secretword"
then change it in the phpmyadmin\config.inc.php

Thats it, all I got for now, hope you enjoy reading all this as much as I did typing all of it.
sorry for any major typos...
feel free to ask me to specify if any of this isnt clear enough for you to help me !
rebelbrowser
 
Posts: 11
Joined: 07. January 2009 00:17

Re: Changed Listen Port Number

Postby rebelbrowser » 09. January 2009 17:30

found the my.ini in C:windows

[WinMySQLAdmin]
Server=F:/xampp/mysql/bin/mysqld-nt.exe

is all it say in there...
?
rebelbrowser
 
Posts: 11
Joined: 07. January 2009 00:17

Re: Changed Listen Port Number

Postby rebelbrowser » 09. January 2009 21:33

played with this all day...

after installing xampp

test http://sitename.com

create new folder in htdocs
paste everything into it, chnge name to xamp
move contents from xampp sub to new parent folder.

test sitename.com again.

visit http://localhost/xampp/security/xamppsecurity.php
make changes to user passwords for mysql and xampp directory

test http://sitename.com/phpmyadmin
confirm logon needed user=root password=secretword

confirm no warnings at bottom of page.

* confirm IIS port is chnged and start IIS

test both sites work at the same time.

paste mybboard into htdocs folder

visit ..\install
insert:
Database Server Hostname: localhost
Database Username: root
Database Password: secretword
Database Name: mysql

delete install folder
rebelbrowser
 
Posts: 11
Joined: 07. January 2009 00:17

Re: Changed Listen Port Number

Postby rebelbrowser » 09. January 2009 21:38

Conclusion:
After all this, I learned that my /tsweb (remote desktop) folder DOES work on a listen port other then 80.

Now, I have the xampp install running by default again, but I also learned more about security.

Thank You to all those whove inspired me,
until next time....
rebelbrowser
 
Posts: 11
Joined: 07. January 2009 00:17


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 88 guests