403 access denied - PhpMyAdmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

403 access denied - PhpMyAdmin

Postby asson » 04. January 2009 13:40

Hi,
I've been a XAMPP user for 2 years now and it has been working very good.

Yesterday when I tried to access PhpMyAdmin / http://localhost/phpmyadmin I got an 403 error for the first time, and since yesterday It has been the same.

1. I have followed these instructions, viewtopic.php?f=16&t=32503 but still no luck.
2. I don't have any .htaccess file in my root directory.
3. I haven't change anything since I have installed XAMPP, this just came up.

Any ideas on how to fix it?

Thanks in advance.
asson
 
Posts: 6
Joined: 04. January 2009 13:33

Re: 403 access denied - PhpMyAdmin

Postby Sharley » 04. January 2009 17:50

Are there any clues in the server's error log file?
xampp\apache\logs\error.log
Last edited by Sharley on 05. January 2009 02:27, edited 1 time in total.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: 403 access denied - PhpMyAdmin

Postby asson » 04. January 2009 20:27

Can this give a clue?!

Code: Select all
[Sat Jan 03 21:01:06 2009] [error] [client 193.204.161.65] (20025)The given path contained wildcard characters: access to * failed
[Sat Jan 03 21:24:58 2009] [alert] [client 212.188.33.4] C:/xampp/phpMyAdmin/libraries/.htaccess: order not allowed here
[Sat Jan 03 23:06:32 2009] [warn] (OS 64)Det angivna nätverksnamnet är inte längre tillgängligt.  : winnt_accept: Asynchronous AcceptEx failed.
[Sun Jan 04 00:13:24 2009] [warn] (OS 64)Det angivna nätverksnamnet är inte längre tillgängligt.  : winnt_accept: Asynchronous AcceptEx failed.
[Sun Jan 04 01:10:26 2009] [error] [client 66.249.73.21] File does not exist: C:/xampp/htdocs/robots.txt
[Sun Jan 04 01:16:28 2009] [warn] (OS 121)Tidsgränsen för semaforen har uppnåtts.  : winnt_accept: Asynchronous AcceptEx failed.
[Sun Jan 04 03:33:50 2009] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/phpmyadmin'
[Sun Jan 04 03:33:53 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/phpMyAdmin
[Sun Jan 04 03:34:00 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/phpMyAdmin
[Sun Jan 04 03:34:09 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/phpMyAdmin
[Sun Jan 04 03:34:16 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/phpMyAdmin
[Sun Jan 04 03:34:31 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/phpMyAdmin
[Sun Jan 04 03:34:36 2009] [error] [client 127.0.0.1] script 'C:/xampp/htdocs/index.php' not found or unable to stat
[Sun Jan 04 03:35:18 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sun Jan 04 03:35:18 2009] [notice] Child 2200: Exit event signaled. Child process is ending.
[Sun Jan 04 03:35:19 2009] [notice] Child 2200: Released the start mutex
[Sun Jan 04 03:35:20 2009] [notice] Child 2200: Waiting for 250 worker threads to exit.
[Sun Jan 04 03:35:20 2009] [notice] Child 2200: All worker threads have exited.
[Sun Jan 04 03:35:20 2009] [notice] Child 2200: Child process is exiting
[Sun Jan 04 03:35:20 2009] [notice] Parent: Child process exited successfully.
[Sun Jan 04 03:35:27 2009] [notice] Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8g mod_autoindex_color PHP/5.2.5 configured -- resuming normal operations
[Sun Jan 04 03:35:27 2009] [notice] Server built: Nov  7 2007 11:48:48
[Sun Jan 04 03:35:27 2009] [notice] Parent: Created child process 2532
[Sun Jan 04 03:35:28 2009] [notice] Child 2532: Child process is running
[Sun Jan 04 03:35:28 2009] [notice] Child 2532: Acquired the start mutex.
[Sun Jan 04 03:35:28 2009] [notice] Child 2532: Starting 250 worker threads.
[Sun Jan 04 03:35:28 2009] [notice] Child 2532: Starting thread to listen on port 443.
[Sun Jan 04 03:35:28 2009] [notice] Child 2532: Starting thread to listen on port 80.
[Sun Jan 04 03:35:28 2009] [error] [client 127.0.0.1] script 'C:/xampp/htdocs/index.php' not found or unable to stat
[Sun Jan 04 03:44:05 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/phpMyAdmin
[Sun Jan 04 03:44:49 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/phpMyAdmin


Where is the PhpMyAdmin folder located?
asson
 
Posts: 6
Joined: 04. January 2009 13:33

Re: 403 access denied - PhpMyAdmin

Postby Wiedmann » 04. January 2009 22:09

Where is the PhpMyAdmin folder located?

asson wrote:[Sun Jan 04 03:33:53 2009] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/phpMyAdmin
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: 403 access denied - PhpMyAdmin

Postby asson » 04. January 2009 22:14

Right,
But there is no folder with that name inside xampp, should it be there?
asson
 
Posts: 6
Joined: 04. January 2009 13:33

Re: 403 access denied - PhpMyAdmin

Postby Wiedmann » 04. January 2009 22:18

should it be there?

Sure. It's part of every XAMPP installation.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: 403 access denied - PhpMyAdmin

Postby asson » 04. January 2009 22:31

I installed XAMPP on a Virtual PC, copied the phpmyadmin folder from there to my own PC and it didn't solve the problem.
I downloaded latest PMA package from their own website and unpacked it under xampp/htdocs, then copied the config file from phpmyadmin that comes with xampp and put it inside htdocs/phpmyadmin (the new phpmyadmin). now it works.

Thanks for your time.
asson
 
Posts: 6
Joined: 04. January 2009 13:33

Re: 403 access denied - PhpMyAdmin

Postby w4vy » 05. January 2009 22:52

you placed the phpmyadmin folder inside the htdocs folder ?

I wouldn't do that if I was you. In the original setup it belongs in the xampp folder.

C://xampp/phpmyadmin

not

C://xampp/htdocs/phpmyadmin

Might not be bad but I just wouldn't do what you have done.
Image
User avatar
w4vy
 
Posts: 153
Joined: 04. June 2008 09:58
Location: England

Re: 403 access denied - PhpMyAdmin

Postby asson » 05. January 2009 23:24

I did that fisr time and still the same error.
My server is a private/closed one, and for me is no security risk to have it there.

Have a nice time.
asson
 
Posts: 6
Joined: 04. January 2009 13:33

Re: 403 access denied - PhpMyAdmin

Postby w4vy » 05. January 2009 23:26

I think maybe your error 403 is the same as everyone elses

theres a topic above this one with the fix have you tried it ? I know you say its all safe and closed but its still not right is it. but it's your machine. :) have a nice day


EDIT:

1) open the file "\xampp\apache\conf\extra\httpd-xampp.conf" in a text editor
2) replace "Allow from localhost" with "Allow from 127.0.0.1" (2 times)
3) save the file
4) restart Apache
Image
User avatar
w4vy
 
Posts: 153
Joined: 04. June 2008 09:58
Location: England

Re: 403 access denied - PhpMyAdmin

Postby asson » 05. January 2009 23:37

Sure, making those changes was the fist step. and as I wrote, It didn't solve my problem, I still don't know the couse of the problem :| the thing is it's fixed and I'm doing my job as usual :)
asson
 
Posts: 6
Joined: 04. January 2009 13:33

Re: 403 access denied - PhpMyAdmin

Postby w4vy » 06. January 2009 00:01

ok sorry I was thinking of another thread whilst writing what I said out.
long as your happy anyway :)
Image
User avatar
w4vy
 
Posts: 153
Joined: 04. June 2008 09:58
Location: England


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests