Page 1 of 1

xampp services fail to install [SOLVED]

PostPosted: 03. January 2009 05:09
by skeebum
I am unable to install any part of XAMPP as a service( apache, mySql, FileZilla )
I am only interested in FileZilla, since apache and mysql do not need to be installed as services to start. But attempts to install any xampp service fails.

I am using WinXP Pro, XAMPP 1.7.0, and am logged in as an admin.

I have verified that I have permission to install services using the sc.exe tool (part of NT). Plus there are other services installed as part of other programs (ATI, GoogleUpdater, etc). I would be able to install filezilla this way, if I only knew the arguments used, and I am afraid of missing something. Also, this would not help explain why it fails to work in the first place.

I have been unable to install any XAMPP related service with both 1.7.0 and 1.6.8-Lite (tested first) and additionally FileZilla's standalone installer (not downloaded as part of XAMPP.)

I have tried using the XAC to install, and the FileZilla Server.exe through command line. I was given the option to "Install Service" - yes. "Autostart Service" - yes. Never gets to to "Start Service"...

No events in System event viewer. Apache logs empty. The errors I see in command line:
- using apache_installservice.bat (OS 1726) RPC failed: failed to create winnt service profile.
once saw another error related to FilZilla and RPC calls...
EDIT: CreateService Failed: The Remote Procedure Call Failed.

What else should I check?

Re: xampp services fail to install

PostPosted: 03. January 2009 05:25
by Sharley
What method did you use to install XAMPP?

If installer version then try this from a very recent post that fixed a services issue on XP.
If as you say you have tried everything then in that case do a proper uninstall of XAMPP and make sure the services are uninstalled and the XCP is closed and all XAMPP components are stopped first.

Then try a fresh install and try a different method this time by downloading the zip version and simply extracting to the C:\ drive then run the setup_xampp.bat file.

When installed go to your XCP and click on the Svc boxes next to the components you want to start as a service then click on Start buttons.

I never use the installer version only the 7zip version and I had no problems at all with 1.7.0 on XP, works a treat following the above method.
The out come was very successful which may indicate that the installer is to blame, being a mindless MS contraption.

Don't know why XAMPP recommends to use the installer because there are many support request here related to this installer version.

If not using the installer then give a reinstall a go anyway as it often fixes gremlin issues, but follow the above instructions.

Re: xampp services fail to install [SOLVED]

PostPosted: 03. January 2009 06:12
by skeebum
It was the installer version. I just tried using the 7zip as you suggested and that fixed it. One more vote here for never using the installer :roll:

I did search the forum, google, filezilla support forums before posting here, and I did read through your recent post that you quoted, but didnt think that applied since my xampplite install (months ago, clean system) v1.6.8 was extracted from the 7zip archive, and I had the same problem of not being able to install apache or mysql services.

Just for reference, I did uninstall AdAware and DefenseWall (no these were not running when testing before, and were not even installed yet) and after a restart installed xampp from 7zip version.

Thanks Sharley!

EDIT: After a clean uninstall, I tested the installer version again, and it worked like a charm.
Also tested the FileZilla installer package, and that went smoothly as well. No problem with any service installer.

Re: xampp services fail to install [SOLVED]

PostPosted: 03. January 2009 06:46
by Sharley
Yes, a reinstall is often all that is required when these gremlin issues pop up as long as a correct uninstall is performed first and not simply a reinstall over the original install as is often the case reported in these forums - you obviously performed the reinstall procedure correctly with a resultant successful outcome.

Really the installer should do it's job first time every time then these time consuming annoyances for the XAMPP user would not prevail - but don't ask me why this is the case as I am not really into how or why these MS gremlins keep popping up, I only have to sweep up after they have visited. :)

Good luck.

Re: xampp services fail to install [SOLVED]

PostPosted: 09. January 2009 15:50
by radostsguy
Weird! I've been having problems with both the full and the light version with Apache failing to load. Just now, after a reboot, I tried again, and got the message you can see in the image. SS-module.jpg.

Oops. I see that "Img" above does not attach an image. So forget that.

It says, "cannot load module" followed by the correct path to xampp, followed by "xampp/modules/"

In httpd.conf, we find "LoadModule actions_module modules/". But the modules folder is in the apache folder, not in the xampp folder directly. Is this a bug in Setup? I guess if I change that to

LoadModule actions_module apache/modules/ , it should work. Or make a copy of the modules folder in wampp itself. By the way, is there in the modules folder.

But at least it's finding httpd.conf which it wasn't before! :D

Re: xampp services fail to install [SOLVED]

PostPosted: 09. January 2009 20:57
by radostsguy
It's me responding to myself! (Is that normal?) :?:

Anyway, copying the modules folder from apache onto the xampp folder worked! So xampp is now running! :D

Now, if I can get PHP to run too, that would be nice, since that's the whole point of the exercise! :roll: