Bad php_xdebug.dll in XAMPP 1.7??

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Bad php_xdebug.dll in XAMPP 1.7??

Postby dextercowley » 01. January 2009 00:17

Hi. I just tried installing XAMPP 1.7 on Windows Vista. I have done this before with older XAMPP versions, but was trying to document the procedure for the new version. In the past, to use XDebug, we had to download the DLL file ourselves. However, with 1.7 this file is included with XAMPP. However, I think there is might be a problem with the php_xdebug.dll included with version 1.7 of XAMPP.

After installing XAMPP, (in c:\xampp), I edited the c:\xampp\apache\bin\php.ini file to comment out the [zend] section and uncomment out the [XDebug] section. By default, this has the line
Code: Select all
zend_extension_ts="C:\xampp\php\ext\php_xdebug.dll"

When I re-start Apache with this line uncommented, Apache crashes as soon as I try to access phpinfo(). As a test, I copied a different XDebug DLL file (php_xdebug-2.0.3-5.2.5.dll) over and changed the php.ini to point to this file. With that setup, everything works! So it would appear that the problem is the php_xdebug.dll distributed with XAMPP 1.7. I have seen several other posts about Apache crashing on Vista but haven't seen a solution posted.

Does anyone have any information about this? Do people have XAMPP with XDebug working on Windows Vista with the distributed php_xdebug.dll file? Thanks. Mark
dextercowley
 
Posts: 1
Joined: 01. January 2009 00:06

Re: Bad php_xdebug.dll in XAMPP 1.7??

Postby Skippy2605 » 02. January 2009 13:48

Hello, I have exactly the same problem, couldn't use the shipped xdebug.dll at all.

I could do it with XAMPP 1.6.8, but not with 1.7.0 anymore.

Edit: I'm on Vista (x64)
Skippy2605
 
Posts: 6
Joined: 20. December 2004 14:53

Re: Bad php_xdebug.dll in XAMPP 1.7??

Postby simshaun » 07. January 2009 02:49

I had to download the latest stable from xdebug's site to get it work.

Had same problem with the dll that came with XAMPP 1.7
simshaun
 
Posts: 2
Joined: 07. January 2009 02:38


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 40 guests