instructions to fix MySQL/PHP PDO on 1.7

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: instructions to fix MySQL/PHP PDO on 1.7

Postby programmerchick » 16. December 2009 20:22

I am having this problem as well. I have an xampp lite installation. I am using wordpress and have created a new page with a new template using the admin panel. Whenever I link to that page I get the following Apache crash error: and the page doesn't display. I can also recreate the same error when I try to run the PHP debugger inside of Netbeans. I assume that this is because in both scenarios PDO gets involved. Here is the apache error log.

[Wed Dec 16 11:53:33 2009] [notice] Parent: child process exited with status 255 -- Restarting.
[Wed Dec 16 11:53:33 2009] [notice] Digest: generating secret for digest authentication ...
[Wed Dec 16 11:53:33 2009] [notice] Digest: done
[Wed Dec 16 11:53:34 2009] [notice] Apache/2.2.12 (Win32) DAV/2 mod_ssl/2.2.12 OpenSSL/0.9.8k mod_autoindex_color PHP/5.3.0 configured -- resuming normal operations
[Wed Dec 16 11:53:34 2009] [notice] Server built: Jul 22 2009 11:35:54
[Wed Dec 16 11:53:34 2009] [notice] Parent: Created child process 6544
[Wed Dec 16 11:53:35 2009] [notice] Digest: generating secret for digest authentication ...
[Wed Dec 16 11:53:35 2009] [notice] Digest: done
[Wed Dec 16 11:53:35 2009] [notice] Child 6544: Child process is running
[Wed Dec 16 11:53:35 2009] [notice] Child 6544: Acquired the start mutex.
[Wed Dec 16 11:53:35 2009] [notice] Child 6544: Starting 150 worker threads.
[Wed Dec 16 11:53:35 2009] [notice] Child 6544: Starting thread to listen on port 443.
[Wed Dec 16 11:53:35 2009] [notice] Child 6544: Starting thread to listen on port 80.
[Wed Dec 16 11:53:35 2009] [notice] Child 6544: Starting thread to listen on port 443.
[Wed Dec 16 11:53:35 2009] [notice] Child 6544: Starting thread to listen on port 80.


I have followed the advice in this thread as best I could, replacing dlls all over the place and nothing has worked. I noticed one other person metioned xampp lite and said the same thing that none of these solutions worked in that env??? What is the solution to this? My only option looming is to get rid of xampp, and re-install apache/ php/ mysql and wordpress from scratch. This is drastic action I don't want to take. Please help!!!!!
programmerchick
 
Posts: 1
Joined: 16. December 2009 20:07

Re: instructions to fix MySQL/PHP PDO on 1.7

Postby franc » 08. March 2010 00:06

Thank you.
I searched very long in all my php.ini and httpd.conf etc. thought it was once again my fault.

:)
franc
 
Posts: 7
Joined: 08. January 2007 17:28

Thanks for these instructions

Postby imarion » 16. December 2010 10:50

Thanks for these instructions. They worked fine allowing me to use php/pdo once again.
imarion
 
Posts: 1
Joined: 16. December 2010 10:37

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests