Compatibility issues on Windows

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Compatibility issues on Windows

Postby tobiasly » 29. December 2008 17:14

Hello, first off thanks for putting together such a wonderful project; I mostly do Linux development but needed an Apache setup on Windows for local testing and this package worked (mostly) great. I first tried "WampServer" but it had (IMO) a less intuitive UI and odd issues such as MySQL PHP client library which didn't match the version of MySQL it shipped with!

Anyway, I did run into a couple issues that I wanted to point out:

  • I must also run IIS on this box on Port 80, so I changed httpd.conf to "Listen 8080" instead. However it seems XAMPP doesn't read httpd.conf and instead always tries to open just "http://localhost". Also I got an error message during initial install because of this. It would be nice if XAMPP asked me to confirm which port to use during installation, and also whether I wanted SSL, to avoid this initial failure.

  • I don't need SSL (and also port 443 is not available) so I commented out the "LoadModule ssl_module". However later in the config file there is an "Include conf/extra/httpd-ssl.conf" which adds "Listen 443", "VirtualHost _default_:443" etc. Neither of these are wrapped in an "<IfModule ssl_module>" so even if SSL is disabled it would try to bind port 443 and load the SSL specific settings. I think the "Include" in the main httpd.conf should be wrapped in "<IfModule ssl_module>" to avoid this.

  • The MySQL config file is named "my.cnf" instead of "my.ini". However on Windows the ".cnf" file is by default reserved for dial-up modem speed-dial settings (at least on XP) and even if Explorer is set to show extensions the .cnf extension will be hidden, and it will not have a right-click menu available (I have "Edit with Notepad++" in my right-click menu so this is a problem). It's easy enough to change that behavior if you know what you're doing but it may be confusing for others, so I think using "my.ini" instead would be better.
Again, thanks for the great work and these issues are very minor (esp. since I'm rather familiar with these services) but it may be confusing for new users.
tobiasly
 
Posts: 1
Joined: 29. December 2008 16:54

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests