Perl not working on my Zampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: Perl not working on my Zampp

Postby marksu » 30. December 2008 16:43

Thank you for your reply.

PPM.bat gives following error when trying to start.

Win22API::Registry object version 0.22 does not match bootstrap paramether 0.23 at
c:/xampp/perl/lib/DynaLoader.pm line 253.
Compilation failed in require at c:/xampp/perl/lib/win32/tieregistry.pm line 26.

Begin failed -- compilaqtion aborted at c:/xampp/perl/lib/win32/tieregistry.pm line 26.
Compilation failed in require at ppm.bat line 15.
Begin failed -- compilaqtion aborted at ppm.bat line 15.

Any ideas?
marksu
marksu
 
Posts: 20
Joined: 27. December 2008 19:12

Re: Perl not working on my Zampp

Postby Sharley » 30. December 2008 16:48

As suggested, try reinstalling - overwrite the files when asked or simply delete the perl folder and start again with a fresh Perl Addon install.

What version Perl Addon did you download?

What OS are you using?
Are you logged in as administrator in this OS?

I have tried to replicate your errors but without any success.

If we can't get the addon to work, but for the life of me I don't understand why, then we can take another tack.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Perl not working on my Zampp

Postby marksu » 30. December 2008 17:45

Thank you for your wery nice comments.
I will try your succestions.
I installed pear version 5.8.7. It should work on my Xampp version according to read me file.

System: XP
User: admin

Marksu
marksu
 
Posts: 20
Joined: 27. December 2008 19:12

Re: Perl not working on my Zampp

Postby Sharley » 30. December 2008 18:38

marksu wrote:I installed pear version 5.8.7. It should work on my Xampp version according to read me file.
I think you meant perl not pear. ;)

oops!
XAMPP 1.6.6a = Apache 2.2.8
You should be downloading and installing the xampp-win32-perl-addon-5.8.8-2.2.8.zip not the 5.7 version.
From the readme:
Add-on Perl 5.8.8 Apache 2.2.8
For XAMPP with Apache 2.2.8 (XAMPP 1.6.x)


To fix, (uninstall) delete the perl folder and the 2 perl related files in the xampp\apache\conf\extra folder then install afresh with the version mentioned above by extracting the files from the zip file to xampp\perl, follow the install instructions and see how that version performs.

marksu wrote:System: XP
User: admin
That looks fine.

In your xampp\apache\conf\extra folder you should have 2 perl related files - perl.conf and startup.pl - check they are there after installing the addon and check the line in the httpd.conf file is not commented out (it should not have a # at the start of the line that gives the include path to the perl.conf file) - see my other post how the line should look.


*** Please let the forum know if the above finally solves your perl issue. ***
Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Perl not working on my Zampp

Postby marksu » 01. January 2009 20:55

I removed the perl folder and the other 2 files.
I had trouble deleting the per file cause some files where in use even after closing Apache and mySql.
I had to use freeware app CopyLock.exe which can delete folder even if files in use.

Then I copied the xampp-win32-perl-addon-5.8.8-2.2.8 files.
I run setup_xampp.bat
I run setup_xampp.bat second time and selecter perl module install.


Error is:
Errno architecture (MSWin32-x86-multi-thread-4.0) does not match executable architecture (MSWin32-x86-multi-thread-5.00) at C:/xampp/perl/site/lib/Errno.pm line 11.


Does the errror above implicate some version problem?

Compilation failed in require at C:/xampp/perl/lib/IO/Socket.pm line 17.

BEGIN failed--compilation aborted at C:/xampp/perl/lib/IO/Socket.pm line 17.
Compilation failed in require at server.pl line 12.

BEGIN failed--compilation aborted at server.pl line 12.



I also checked the PPM.bat. I run the refresh function to get all available packets and selected view all packages.
Last edited by marksu on 01. January 2009 22:35, edited 3 times in total.
marksu
 
Posts: 20
Joined: 27. December 2008 19:12

Re: Perl not working on my Zampp

Postby marksu » 01. January 2009 21:07

I also run the verify packets in PPM and got many error like "missing" or "wrong mode 666 expected 444"?
Should I just reinstall all the existing packet in PPM or is there some other problem here?
marksu
 
Posts: 20
Joined: 27. December 2008 19:12

Re: Perl not working on my Zampp

Postby marksu » 01. January 2009 22:58

I I trying other aproach now.
Instead of using the perl zip version I though to use the installer version.
I get error: Cannot found pache http 2.2.8 for mod_perl (Recommended)! Continue?

I think Imight have deleted that file when removing the old perfiles before reinstall?

What is that file and can it be copied from somewhere?

EDIT:
Well the only similar such files can be found 2 times "mod_perl.so", once mod_perl2.pm, mod_perl2 folder.
I did ansvare continue on start of the install but same error apper.
marksu
 
Posts: 20
Joined: 27. December 2008 19:12

Re: Perl not working on my Zampp

Postby marksu » 01. January 2009 23:19

I used the ppm to reinstall the errno package now I get same error when running my script except that first error line changed to :

Errno architecture (MSWin32-x86-multi-thread-5.0) does not match executable architecture (MSWin32-x86-multi-thread-5.00) at C:/xampp/perl/site/lib/Errno.pm line 11.

Line 11 says :

"$Config{'archname'}-$Config{'osvers'}" eq
"MSWin32-x86-multi-thread-5.0" or
die "Errno architecture (MSWin32-x86-multi-thread-5.0) does not match executable architecture ($Config{'archname'}-$Config{'osvers'})";
marksu
 
Posts: 20
Joined: 27. December 2008 19:12

Re: Perl not working on my Zampp

Postby marksu » 01. January 2009 23:38

Well I added a zero number to the code.

"$Config{'archname'}-$Config{'osvers'}" eq
"MSWin32-x86-multi-thread-5.00" or
die "Errno architecture (MSWin32-x86-multi-thread-5.0) does not match executable architecture ($Config{'archname'}-$Config{'osvers'})";

Well strange thing that I have to edit the file though.
I wonder what problems system might have?
marksu
 
Posts: 20
Joined: 27. December 2008 19:12

Re: Perl not working on my Zampp

Postby Sharley » 02. January 2009 00:29

Go back to the zip version and start afresh by following my above post.
(The msi installer version assumes too much and is like a net nanny that likes to think it knows everything when in fact it is has no brain at all and worse it will send a user round the bend - take control yourself as the outcome will be much more satisfying, much like using the command line).


After extracting the zip file and before running the setup_xampp.bat file go in to C:/xampp/perl/site/lib and rename the file Errno.pm to Errno.bak or delete the file.
(this fix is from the ActivePerl community forums and was posted on our forums here previously).

Forum Search (your best friend) for errno - click here

Now run the setup bat file but don't select to use mod_perl and lets see if that lets you move forward.

You don't need mod_perl unless your scripts specifically require it which would be highly unlikely and if by some odd chance you do require it then it is a simple case of running the setup bat file again and selecting it, in fact if I recall correctly there was a past version where mod_perl did not work anyway which was corrected in a subsequent version - but lets get this show on the road minus the perl_mod. :)


BTW Marksu, very good summary in the htaccess topic but you have 1. CREATING and 2. CREATING with the same .htpasswd name??? ;)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests