Xampp 1.7 security 403 error on vista

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: Xampp 1.7 security 403 error on vista

Postby JonB » 21. July 2010 15:24

My server is running and IIS is enabled

WHY?

IIS is a webserver, so is Apache - hopefully they are installed on different ports?

BTW, It would probably be useful to know what version of Windows you are using.

Why don't you copy the actual 403 error you are getting into your reply? It probably has some useful info.

Good Luck
8)

OSF
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Xampp 1.7 security 403 error on vista

Postby Nathan2508 » 25. July 2010 00:20

Sorry I don't know why I said 403 error. Basically what I'm getting is "Oops! Google Chrome could not connect to localhost." I don't have IIS running, but do I need to completely disable that service altogether? Upon further investigation I've found that I can't even ping localhost or 127.0.0.1. I can't think of any recent major changes I've made to this computer. I'm using Vista Home Premium SP1.
Nathan2508
 
Posts: 5
Joined: 12. July 2010 21:40

Re: Xampp 1.7 security 403 error on vista

Postby JonB » 25. July 2010 21:18

did you do/check this:

(from Page 1 in this topic)

On Vista there is often an issue with localhost because of an IPv6 entry in the Windows HOSTS file that may be blocking your access to localhost.

Check in C:\Windows\system32\drivers\etc\HOSTS file for the IPv6 setting (open and edit the HOSTS file by dragging it into a text editor).

Find this IPv6 line:
::1 localhost

Comment it out so it looks like this:
# ::1 localhost

Make sure the first uncommented line is:
127.0.0.1 localhost

Save the file, restart Apache and then try to access your localhost again.
Also clear your browser's cache from time to time because when working at localhost level the cache can be a real pain in the head.


:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Xampp 1.7 security 403 error on vista

Postby Nathan2508 » 26. July 2010 02:40

Yes, my HOSTS file was already correct.
Nathan2508
 
Posts: 5
Joined: 12. July 2010 21:40

Re: Xampp 1.7 security 403 error on vista

Postby JonB » 26. July 2010 22:44

Is it only Google, or can you connect with IE or FireFox?

I'm mot sure if the port check works right with Vista, but you should try it to see if Port 80 is open.

What is going on in the XAMPP Control Panel? can you start Apache? if not, do you get error messages?

:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Xampp 1.7 security 403 error on vista

Postby Nathan2508 » 02. August 2010 02:52

I can't connect with any browser. Apache starts with no error messages. I can't figure out about port 80. When I go into the windows firewall exceptions and check apache http it automatically unchecks itself once I go back. When I turn the firewall off completely it still doesn't work.
Nathan2508
 
Posts: 5
Joined: 12. July 2010 21:40

Re: Xampp 1.7 security 403 error on vista

Postby sweetride_band » 29. August 2011 16:44

I got the same error, and found ultimately it was an error in my php code (missing escape quote in php_self). It's just a very misleading error. Especially for php_self.
sweetride_band
 
Posts: 1
Joined: 29. August 2011 16:34

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 36 guests