Configuring Security

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Configuring Security

Postby kbachelder » 19. December 2008 20:10

Hi everyone,

I installed xampp on a Windows 2003 Server that already had IIS running and being used. So I had to add an IP address (192.168.0.129) to use just for the Apache site I needed. My problem is that I can't get to the security page to enable better security settings since 'localhost' doesn't bring up the Apache page. When I try to go to /localhost/security/xamppsecurity.php I get a page that says "forbidden for client 192.168.0.129".

Is there an easy way to get at the security settings in this setup?


Thanks for the help,

Kevin
kbachelder
 
Posts: 3
Joined: 19. December 2008 20:03

Re: Configuring Security

Postby Sharley » 19. December 2008 22:25

kbachelder wrote:...So I had to add an IP address (192.168.0.129) to use just for the Apache site I needed...
How did you do that exactly?
Last edited by Sharley on 19. December 2008 23:08, edited 1 time in total.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Configuring Security

Postby Wiedmann » 19. December 2008 22:52

When I try to go to /localhost/security/xamppsecurity.php I get a page that says "forbidden for client 192.168.0.129".
Is there an easy way to get at the security settings in this setup?

In \xampp\security\htdocs\xamppsecurity.php you can change line 5 to:
Code: Select all
   $host = "192.168.0.129";
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Configuring Security

Postby kbachelder » 22. December 2008 20:39

Sharley wrote:
kbachelder wrote:...So I had to add an IP address (192.168.0.129) to use just for the Apache site I needed...
How did you do that exactly?


I used the information from this post...

How To: Run Apache HTTP Server and IIS on Windows Server 2003
http://www.strangework.com/2008/06/11/h ... rver-2003/


Kevin
kbachelder
 
Posts: 3
Joined: 19. December 2008 20:03

Re: Configuring Security

Postby kbachelder » 22. December 2008 20:40

Wiedmann wrote:
When I try to go to /localhost/security/xamppsecurity.php I get a page that says "forbidden for client 192.168.0.129".
Is there an easy way to get at the security settings in this setup?

In \xampp\security\htdocs\xamppsecurity.php you can change line 5 to:
Code: Select all
   $host = "192.168.0.129";



That worked great!

Thanks very much,

Kevin
kbachelder
 
Posts: 3
Joined: 19. December 2008 20:03


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests