cmd.exe "access is denied"

Problems with the Windows version of XAMPP, questions, comments, and anything related.

cmd.exe "access is denied"

Postby lycander » 15. December 2008 04:21

Thanks ahead of time for helping out.

I'm running windows vista-32.

I downloaded xampp lite, unzipped to desktop, and then double-clicked on setup_xampp.bat. The dos window popped up as it should (with the header C:\windows\system32\cmd.exe) and the following message:

Access is denied.
Press any key to continue.

Here's what I've tried so far:
I've run the program setup_xampp.bat in administrator mode
I've turned off all firewall, etc.


Also, I've used xampp in the past before on the same system with no problems.
Any thoughts?
Thanks a ton for your time :)
lycander
 
Posts: 4
Joined: 15. December 2008 04:15

Re: cmd.exe "access is denied"

Postby Sharley » 15. December 2008 04:27

Here's some help I posted before but it seems the forum search facility has lost all the old posts since it was upgraded.
Anyhow see if there is anything in it that helps you.

Also right click on the bat file and select to run as administrator might do the trick.
A few tips worth noting for Vista Command prompt users especially elevating the command console with administrator privileges:


Right-click on any folder on your Windows Vista machine while holding down the shift key.
You'll see an extra context-sensitive menu item there: Open Command Prompt here.
Just click on this menu and a command window will open with the current working directory set to the folder's actual location.

In the past there was a Windows XP powertoy that did this; now it's built into the operating system (albeit hidden away to protect the unwary from themselves).
What's really cool about this is that if the target folder is a network location, Windows Vista silently maps a network drive to that location before opening the folder (so that your command prompt has a valid path containing a drive letter) and then deletes the network drive once the command prompt is closed.

----

User Account Control is an important part of the security protection that Windows Vista offers.
For any user with administrative credentials, you can always execute a process with full admin rights by right-clicking on the executable or shortcut and choosing "Run as Administrator".


I regularly want to open an admin-level command prompt, and it's a distraction to have to move my hands off the keyboard to go through the elevation contortions.
So I was delighted to find a little keyboard shortcut for launching an elevated process.
Simply press Ctrl+Shift+Enter from the search bar on the start menu with a selected application, and that triggers elevation.

For example, to launch an elevated command prompt, simply press the Win key; type cmd; press Ctrl+Shift+Enter; and then hit Alt+C to confirm the elevation prompt.
Six keystrokes to an elevated command prompt!

Once I've got an elevated command prompt, I always like to execute color 4f as my first input so that this console window is visually differentiated from other non-elevated windows.


Windows Vista Secrets and more can be found here:
http://blogs.msdn.com/tims/default.aspx
You may have to Search the Archives to find them all.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: cmd.exe "access is denied"

Postby lycander » 15. December 2008 04:53

Thanks for the quick response Sharley.

I mentioned earlier that I had tried to run with admin rights (by right-clicking, etc.), so unfortunately your tips weren't quite what I was looking for (but I learned a couple short cuts from it :D ) but I did forget to mention that running the program with admin rights provides a different error:

the header is "c:\windows\system32\cmd.exe" and the message:

Sorry ... cannot find php cli!
Must abort these process!
Press any key to continue . . .

I definitely should have mentioned that right away. Any ideas?
lycander
 
Posts: 4
Joined: 15. December 2008 04:15

Re: cmd.exe "access is denied"

Postby Sharley » 15. December 2008 05:39

Can you go to http://localhost and in the left menu look for and click on phpinfo().

Find the line Loaded Configuration File which should be C:\xampp\apache\bin\php.ini
Read your own path if different to xampp\apache\bin\php.ini

If not that path paste the path you see here.

Sorry ... cannot find php cli!
Have you had or still have another instance of PHP on your PC?

Check your System variables for a PHPRC entry and remove it.
Windows Control Panel>System>Advanced>Environment variables and in the various paths look for an entry for php and remove it/them by editing the lines.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: cmd.exe "access is denied"

Postby lycander » 15. December 2008 23:35

Thanks again, Sharley.

in my apache/bin/php.ini file, there is no line "Loaded Configuration file." Maybe this isn't present in XAMPP lite?

Also, I checked my environment variables, and I did not find an instance of any php running, definitely not PHPRC.

Thanks again for the quick help :)
lycander
 
Posts: 4
Joined: 15. December 2008 04:15

Re: cmd.exe "access is denied"

Postby Sharley » 15. December 2008 23:39

Sharley wrote:Can you go to http://localhost and in the left menu look for and click on phpinfo().
Thats where to look for the Loaded Configuration File entry.

Can you even start Apache?

Make sure IIS (Windows Internet Information Server) is disabled using the Windows Control Panel.

After rebooting your PC and before starting any XAMPP components run xampp-portcheck.exe to make sure all ports are free that XAMPP requires exclusively.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: cmd.exe "access is denied"

Postby lycander » 16. December 2008 00:02

Can you go to http://localhost and in the left menu look for and click on phpinfo().


http://localhost comes up as a page load error.

Can you even start Apache?

Without localhost coming up, I can't tell whether or not apache is running.

Make sure IIS (Windows Internet Information Server) is disabled using the Windows Control Panel.

I know how to turn off independent IIS services in administrative tools, but I don't know who to disable IIS altogether.

After rebooting your PC and before starting any XAMPP components run xampp-portcheck.exe to make sure all ports are free that XAMPP requires exclusively.


I've made sure the ports are all free. That doesn't seem to be an issue.
lycander
 
Posts: 4
Joined: 15. December 2008 04:15

Re: cmd.exe "access is denied"

Postby Sharley » 16. December 2008 00:06

If http://localhost does not show the XAMPP Welcome page then it would seem Apache has not started - have you tried to start it using the XAMPP Control Panel?

First try using the apache_start.bat file as it will give error messages if it can't start.

Try http://127.0.0.1 instead of using http://localhost and see if that loads the page.

What is the page load error message when trying to go to http://localhost ?

As has often been the case with these mystery issues a complete uninstall of XAMPP - that is, stop all XAMPP components and any running as a service then delete the xampp folder - this has often been the only successful fix.

Then download a fresh copy of XAMPP and install again - don't try and install over an existing xampp installation.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests