MySql not starting

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySql not starting

Postby splot-bob » 14. December 2008 15:52

Hi,
I've been using xampp for a few years now without any problems but I just had to change the drive it was running on.
I have done this:
Uninstalled xampp from C:/ drive
Renamed the apachefriends folder on C:/ drive
Installed xampp on D:/ drive specifying D:/apachefriends as the install dir in the setup program for the latest edition.

MySqld won't start either as a service or via the command line, I've checked using the SCM button on the CP and the path to the executable is listed as:
Code: Select all
C:\apachefriends\xampp\mysql\bin\mysqld-nt --defaults-file=C:\apachefriends\xampp\mysql\bin\my.cnf mysql


It's obviously not starting because the path is incorrect, it should start with D:/

I've tried editing C:/Windows/my.ini :
Code: Select all
# Example MySQL config file for small systems.
#
# This is for a system with little memory (<= 64M) where MySQL is only used
# from time to time and it's important that the mysqld daemon
# doesn't use much resources.
#
# You can copy this file to
# /xampp/mysql/bin/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /xampp/mysql/data) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
# password       = your_password
port            = 3306
socket          = "d:/apachefriends/xampp/mysql/mysql.sock"

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port= 3306
socket= "d:/apachefriends/xampp/mysql/mysql.sock"
basedir="d:/apachefriends/xampp/mysql"
tmpdir="d:/apachefriends/xampp/tmp"
datadir="d:/apachefriends/xampp/mysql/data"
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M



# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#
# commented in by lampp security
#skip-networking

# Replication Master Server (default)
# binary logging is required for replication
# log-bin deactivated by default since XAMPP 1.4.11
#log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id   = 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
#    the syntax is:
#
#    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
#    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
#    where you replace <host>, <user>, <password> by quoted strings and
#    <port> by the master's port number (3306 by default).
#
#    Example:
#
#    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
#    MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
#    start replication for the first time (even unsuccessfully, for example
#    if you mistyped the password in master-password and the slave fails to
#    connect), the slave will create a master.info file, and any later
#    change in this file to the variables' values below will be ignored and
#    overridden by the content of the master.info file, unless you shutdown
#    the slave server, delete master.info and restart the slaver server.
#    For that reason, you may want to leave the lines below untouched
#    (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id       = 2
#
# The replication master for this slave - required
#master-host     =   <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user     =   <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password =   <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port     =  <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin


# Point the following paths to different dedicated disks
#tmpdir = "/xampp/tmp"
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# Comment the following if you are using InnoDB tables
#skip-innodb
innodb_data_home_dir = "d:/apachefriends/xampp/mysql/"
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = "d:/apachefriends/xampp/mysql/"
innodb_log_arch_dir = "d:/apachefriends/xampp/mysql/"
## You can set .._buffer_pool_size up to 50 - 80 %
## of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
## Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout
[WinMySQLAdmin]
Server=D:/apachefriends/xampp/mysql/bin/mysqld-nt.exe


But to no avail, Apache & FileZilla are both running happily as services.
Where else should I edit?

Thanks in advance,
Bob
splot-bob
 
Posts: 5
Joined: 14. December 2008 15:34

Re: MySql not starting

Postby Wiedmann » 14. December 2008 16:58

Code: Select all
C:\apachefriends\xampp\mysql\bin\mysqld-nt --defaults-file=C:\apachefriends\xampp\mysql\bin\my.cnf mysql

It's obviously not starting because the path is incorrect, it should start with D:/

Delete the service with "sc delete MySQL" and reinstall it with the batchfile.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: MySql not starting

Postby splot-bob » 15. December 2008 02:49

Hi,
Deleted using "sc delete MySQL" rebooted, installed via the batch file mysql_installservice.bat, rebooted.
MySQL is now showing as a service in the Xampp control Panel but is not starting with Apache, if started manually it briefly runs (a second or so) then stops, yet still shows as running in the SCM.

Thanks in advance,
Bob
splot-bob
 
Posts: 5
Joined: 14. December 2008 15:34

Re: MySql not starting

Postby Sharley » 15. December 2008 03:03

Hello Bob, do you have a traffic light icon in your system tray?

If so right click on it and select Win NT then select Shut down this tool then Yes.

Now check your CP again and un-tick the Svc box answer Yes and then you should be able to start MySQL.

If you have the traffic lights it means you have the WinMySQLAdmin starting when you reboot.

Go to your startup folder and remove the link.
C:\Documents and Settings\[logon name]\Start Menu\Programs\Startup
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: MySql not starting

Postby splot-bob » 15. December 2008 03:36

Hi Sharley,
No to the traffic lights, I don't load the Xampp control panel as a service either.

Cheers,
Bob
splot-bob
 
Posts: 5
Joined: 14. December 2008 15:34

Re: MySql not starting

Postby Sharley » 15. December 2008 03:53

Thats good to hear Bob.

Try and un-tick the Svc box next to MySQL and see what happens - this has nothing to do with running the XCP as a service - if you don't need the XAMPP components running as a service then un-tick all the Svc boxes until all the troubleshooting is over and XAMPP opens in the Welcome page from http://localhost.

After all is working fine that way, then if you require Apache etc. to be on all the time and every time you reboot then, one at a time, tick the Svc box next to the components in the XCP.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: MySql not starting

Postby splot-bob » 15. December 2008 04:54

Hi Sharley,
Unticked the "Service" box in XCP for both Apache and MySQL ... rebooted.
Apache will start and run manually via the XCP no problems, MySql still shows as "started" when I start it manually and shows as a service in SCM but does not show as running in Task Manager.
I can view the Xampp splash page and when going to "Status" get this, even after purportedly successfully starting MySQL:
Component Status Hint
MySQL database DEACTIVATED
PHP ACTIVATED
HTTPS (SSL) ACTIVATED
Common Gateway Interface (CGI) ACTIVATED
Server Side Includes (SSI) ACTIVATED
SMTP Service DEACTIVATED
FTP Service DEACTIVATED

Cheers,
Bob
splot-bob
 
Posts: 5
Joined: 14. December 2008 15:34

Re: MySql not starting

Postby Sharley » 15. December 2008 05:33

Unticked the "Service" box in XCP for both Apache and MySQL ... rebooted.

Are you un-ticking the boxes in the Service Settings window or the Svc boxes under the Modules window (first window) of the XCP?
No need to reboot the PC.

Running the sc delete mysql again will remove the service from the SCM as mentioned above but don't run the bat file to start the service again or we will be going round in circles and don't reboot.

Just go to your XCP and make sure the "Svc" box is not ticked then Start MySQL.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: MySql not starting

Postby splot-bob » 15. December 2008 06:08

Hi Sharley,
Are you un-ticking the boxes in the Service Settings window or the Svc boxes under the Modules window (first window) of the XCP?
No need to reboot the PC.

Modules window
All is well now:
I uninstalled Xampp
Re-installed Xampp but this time did not let the install set up Apache or MySQL as services
After the install MySQL would start correctly via the Modules window, then set Apache as a service in the Modules window, rebooted to check that it started correctly, checked that MySQL would start correctly manually and then set it as a service and rebooted to check that it started correctly and it did.

Thank you for your help! Even though I have been using Xampp for about 5 years it has always been one of those "never need to touch" background programs that over time has become indispensable to me.

Cheers,
Bob
splot-bob
 
Posts: 5
Joined: 14. December 2008 15:34

Re: MySql not starting

Postby Sharley » 15. December 2008 06:10

Well done Bob and that would have been a last resort suggestion to reinstall, as it has been known to fix some of these mysterious seemingly unfixable issues.
Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 41 guests