#1046 - No database selected

Problems with the Windows version of XAMPP, questions, comments, and anything related.

#1046 - No database selected

Postby redbourn » 13. December 2008 08:28

Hi,

You didn't think you'd get rid of me so easily did you :-) ?

I just tried to import what I believe to be a valid .gz file. (I also have an .sql version available)

I selected it from the drop down box but after I hit the 'go' I got - #1046 - No database selected

What I'd like to do is to overwrite my existing database with the new one.

thanks,

Mike
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: #1046 - No database selected

Postby Sharley » 13. December 2008 09:27

Hello again,

Please try and be more specific about the processes you went through as it helps understand what you have done already - thanks.

When exporting from your old database just export all the tables and data to an sql file.
Then import that sql file into your new database.

Try this:
1. Go to phpMyAdmin.
2. Select the existing database from the list in the left column (create the database if you have not done so already).
3. Go to Import in the top menu.
4. Browse to the preferred sql version file to import (try the gz file again but an sql file always seems to work without issue for me).
5. Un-check Partial import if your file is relatively small (try unchecked first then use it if needed).
6. Select SQL compatibility mode (very important - if your sql import file was created from a MySQL 4 database then select that, if the version is the same as you are importing into, version 5, then select NONE).
7. Click Go.

This method should overwrite your old data with new data from the import sql file..

Is that roughly what you have done?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: #1046 - No database selected

Postby redbourn » 13. December 2008 22:53

Sorry for not being more specific.

It was partly because I'm not yet familar enough with the program to know what is important and what isn't and I also try not to waffle when I post :wink:

>5. Un-check Partial import if your file is relatively small (try unchecked first then use it if needed).
>6. Select SQL compatibility mode (very important - if your sql import file was created from a MySQL 4 database then select that, if the version is the same as you are importing into, version 5, then select NONE).

After carrying the above I was able to import the database!

I still have a problem with it though - code 500 - and I think that it's because I have to change the URL from the online one to 'localhost'.

One of the messages I got when trying to log into different pages was db_create.php: Missing parameter: new_db (FAQ 2.8 )

I poked around in the database but haven't yet found out where to change the URL.

When I uploaded to the server a few days ago I had to change the database from local to the URL

thanks for being there,

Mike

Sharley wrote:Hello again,

Please try and be more specific about the processes you went through as it helps understand what you have done already - thanks.

When exporting from your old database just export all the tables and data to an sql file.
Then import that sql file into your new database.

Try this:
1. Go to phpMyAdmin.
2. Select the existing database from the list in the left column (create the database if you have not done so already).
3. Go to Import in the top menu.
4. Browse to the preferred sql version file to import (try the gz file again but an sql file always seems to work without issue for me).
5. Un-check Partial import if your file is relatively small (try unchecked first then use it if needed).
6. Select SQL compatibility mode (very important - if your sql import file was created from a MySQL 4 database then select that, if the version is the same as you are importing into, version 5, then select NONE).
7. Click Go.

This method should overwrite your old data with new data from the import sql file..

Is that roughly what you have done?
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: #1046 - No database selected

Postby Wiedmann » 13. December 2008 23:07

I still have a problem with it though - code 500

Read Apaches' "error.log".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: #1046 - No database selected

Postby redbourn » 14. December 2008 07:19

Wiedmann wrote:
I still have a problem with it though - code 500

Read Apaches' "error.log".


Yep, I need to give you more info If I expect you to help me!
I'm not in the habit of checking error logs but I'll learn.

thanks,

Mike

[Sat Dec 13 23:33:53 2008] [warn] pid file C:/xampplite/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Dec 13 23:33:59 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Sat Dec 13 23:33:59 2008] [notice] Server built: Jun 14 2008 19:02:12
[Sat Dec 13 23:33:59 2008] [notice] Parent: Created child process 3764
[Sat Dec 13 23:34:01 2008] [notice] Child 3764: Child process is running
[Sat Dec 13 23:34:01 2008] [notice] Child 3764: Acquired the start mutex.
[Sat Dec 13 23:34:01 2008] [notice] Child 3764: Starting 250 worker threads.
[Sat Dec 13 23:34:01 2008] [notice] Child 3764: Starting thread to listen on port 443.
[Sat Dec 13 23:34:01 2008] [notice] Child 3764: Starting thread to listen on port 80.
[Sat Dec 13 23:48:34 2008] [error] [client 127.0.0.1] File does not exist: C:/xampplite/htdocs/htdocs
[Sun Dec 14 08:08:50 2008] [warn] pid file C:/xampplite/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: #1046 - No database selected

Postby Sharley » 14. December 2008 08:41

redbourn wrote:I'm not in the habit of checking error logs...
Whenever you receive a server 500 error, check the error log file first as this is the only way you will know what is wrong - else you can only guess, and my guess is if you have installed WordPress there may be a .htaccess file in the WordPress installation directory that may have an issue with mod_rewrite but I am at a loss to know why you are not getting an error.log file entry for this "code 500".

Can you paste or copy the wording here of this mystical "code 500" in all it's glory please?
Please tell us in detail what you were doing to get this "code 500" - it's not waffle. ;)


Now, in your error.log paste, there is no server 500 error only a file not found 404 error.
File does not exist: C:/xampplite/htdocs/htdocs


The 2 pid file [warning]s are the result of starting and stopping Apache using the XCP and can be ignored - you can test that info by starting and stopping Apache with the bat files etc., not the XCP, and you will see that there will be no pid file [warning] message entered in the log file.

All the other entries are normal server operational [notices].

Mike, you have to be our eyes and relay in great detail what you see and do so we have a chance at troubleshooting your issues without trying to guess all the time - let us decide what is relevant, important or waffling because, as you know already, a great deal of wasted time can be saved.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: #1046 - No database selected

Postby redbourn » 14. December 2008 14:55

Sharley wrote:
redbourn wrote:I'm not in the habit of checking error logs...
Whenever you receive a server 500 error, check the error log file first as this is the only way you will know what is wrong - else you can only guess, and my guess is if you have installed WordPress there may be a .htaccess file in the WordPress installation directory that may have an issue with mod_rewrite but I am at a loss to know why you are not getting an error.log file entry for this "code 500".

Can you paste or copy the wording here of this mystical "code 500" in all it's glory please?
Please tell us in detail what you were doing to get this "code 500" - it's not waffle. ;)


Now, in your error.log paste, there is no server 500 error only a file not found 404 error.
File does not exist: C:/xampplite/htdocs/htdocs


The 2 pid file [warning]s are the result of starting and stopping Apache using the XCP and can be ignored - you can test that info by starting and stopping Apache with the bat files etc., not the XCP, and you will see that there will be no pid file [warning] message entered in the log file.

All the other entries are normal server operational [notices].

Mike, you have to be our eyes and relay in great detail what you see and do so we have a chance at troubleshooting your issues without trying to guess all the time - let us decide what is relevant, important or waffling because, as you know already, a great deal of wasted time can be saved.


XAMPP was working fine and I installed Wordpress locally and could access it locally.

The problem only started when I exported the online database and imported it locally.

I also copied via FTP all the word press files from the server to my local version.

-----------

I start the XAMPP control panel and start both Apache and Mysql and both show 'running' on a green background.

If I enter http://localhost/wordpress/wp-admin/install I get the following very quickly ..

Object not found!
The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404
localhost
12/14/08 15:29:58
Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6

----------

But if I simply enter http://localhost/ after about 30 seconds I get ..

Internet Explorer cannot display the webpage

Most likely causes:
You are not connected to the Internet.
The website is encountering problems.
There might be a typing error in the address.

What you can try:
Diagnose Connection Problems

More information

----------

If I enter http://localhost/wp-login.php

After about 45 seconds I do get a log in page but if I enter a username and password I get ..

Internet Explorer cannot display the webpage

Most likely causes:
You are not connected to the Internet.
The website is encountering problems.
There might be a typing error in the address.

What you can try:
Diagnose Connection Problems

More information

This problem can be caused by a variety of issues, including:

Internet connectivity has been lost.
The website is temporarily unavailable.
The Domain Name Server (DNS) is not reachable.
The Domain Name Server (DNS) does not have a listing for the website's domain.
If this is an HTTPS (secure) address, click Tools, click Internet Options, click Advanced, and check to be sure the SSL and TLS protocols are enabled under the security section.

For offline users

You can still view subscribed feeds and some recently viewed webpages.
To view subscribed feeds

Click the Favorites Center button , click Feeds, and then click the feed you want to view.

To view recently visited webpages (might not work on all pages)

Click Tools , and then click Work Offline.
Click the Favorites Center button , click History, and then click the page you want to view.


---------------------

Didn't see a 500 error - did my morning coffee cause me to hallucinate?

--------------

BTW - should I have Internet Information Services installed? I think it was blocking Apache after I first booted up my pc today.

Thanks for hanging in there,

Mike

P.S. Is it better to top or bottom post?

[Sun Dec 14 15:26:50 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Sun Dec 14 15:26:50 2008] [notice] Server built: Jun 14 2008 19:02:12
[Sun Dec 14 15:26:50 2008] [notice] Parent: Created child process 3568
[Sun Dec 14 15:26:52 2008] [notice] Child 3568: Child process is running
[Sun Dec 14 15:26:52 2008] [notice] Child 3568: Acquired the start mutex.
[Sun Dec 14 15:26:52 2008] [notice] Child 3568: Starting 250 worker threads.
[Sun Dec 14 15:26:52 2008] [notice] Child 3568: Starting thread to listen on port 443.
[Sun Dec 14 15:26:52 2008] [notice] Child 3568: Starting thread to listen on port 80.
[Sun Dec 14 15:29:58 2008] [error] [client 127.0.0.1] File does not exist: C:/xampplite/htdocs/wordpress
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: #1046 - No database selected

Postby Sharley » 14. December 2008 23:18

Mike, As you say no 500 error in that lot and thanks for the details, most helpful.

Mike wrote:...I also copied via FTP all the word press files from the server to my local version...
From what I am seeing and from what you said about downloading WordPress files from your hosting service It would appear that within WordPress you need to change a few path settings to reflect it's new location - but because you can't access admin to change these paths life gets somewhat more tedious. ;)

You have a multitude of conflicting issues that are in total preventing you from proceeding.

Mike wrote:If I enter http://localhost/wp-login.php
That should be http://localhost/wordpress/wp-login.php - but try http://127.0.0.1/wordpress/wp-login.php - see HOSTS file info below.

If you can login as admin go to Options>General and change the Wordpress address (URI) and Blog address (URI) to reflect your location in XAMPP
http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

Mike wrote:If I enter http://localhost/wordpress/wp-admin/install I get the following very quickly ..
In your path tree on your hosted server my guess is you will not have the wordpress folder as normally you would install to the web root of your server and all the config paths in WordPress use relative paths ie. /wp-admin/install.php

So you can't use this path in XAMPP to go to /wp-admin/install.php which equates to http://localhost/wp-admin/install.php which does not exists (404 error) - web root (or ServerRoot) is htdocs folder which is / in XAMPP and you have /wordpress/ as your root for WP.

The WP chain of command goes like this:
install.php requires wp-config.php which requires wp-settings.php which contains all the relative path information.
So when you go to http://localhost/wordpress/wp-admin/install.php (also note the install.php in the address not just simply install) it tries to find and load the above files but because /wordpress/ is not in the relative path it fails with a 404 not found error in your browser.

Sounds complex because it is when you try and mirror an installation on a hosted Linux Apache server with one in a Windows Apache server.

The much simpler way and in your case the preferred method is to download and install a fresh copy of WordPress in XAMPP duly configured with the correct paths using the admin install procedure.

You can then eliminate the wordpress folder by installing directly into the htdocs folder first deleting or renaming the existing index.php index.html files - you would access the XAMPP Welcome page then by typing http://localhost/xampp/

This would then closely resemble the path structure of your hosted WP instance and access would then be http://localhost/wp-admin/install.php <-- minus the wordpress folder which we eliminated using the direct to htdocs installation method.

After you have this fresh install of WP up and running, clean database included, then you can import your sql tables and data from your hosted server to your XAMPP installation - this is all you need do to mirror your hosted WP after you customize the interface to match your hosted look and feel as WP is admin panel/database driven after that.

I think doing it this way with a clean WP installation and database that fits in with the XAMPP path structure will be quicker, eliminate your errors and your frustrations with trying to get a downloaded mirror working from 2 different server configurations.

Good luck and let us know if this approach works for you, with a link to your hosted WP would be nice. :)

---------------------------

The http://localhost issue may be slightly different.
Check that you do not have Work Offline ticked in your browser - if not, then try the following.


Try using the local loopback IP address http://127.0.0.1 and see if you get to the XAMPP Welcome page.

If you do then you will have to drag this file into your text editor (note TEXT editor):
C:\WINDOWS\system32\drivers\etc\HOSTS <-- note no file extension
and see if you have this IPv6 line:
::1 localhost
If so then comment out the line so it looks like this:
# ::1 localhost <- commented out

Make sure that this line is first in the HOSTS file:
127.0.0.0 localhost

Save the file and try http://localhost again.

---------------------------

Disable IIS in the Windows Control Panel because you obviously are not using it - it will interfere with the ports that XAMPP requires exclusively if running.

---------------------------

Your posting method looks fine to me and the extra detailed info is excellent. ;)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: #1046 - No database selected

Postby redbourn » 15. December 2008 06:49

Sharley wrote:
Try using the local loopback IP address http://127.0.0.1 and see if you get to the XAMPP Welcome page.

If you do then you will have to drag this file into your text editor (note TEXT editor):
C:\WINDOWS\system32\drivers\etc\HOSTS <-- note no file extension
and see if you have this IPv6 line:
::1 localhost
If so then comment out the line so it looks like this:
# ::1 localhost <- commented out

Make sure that this line is first in the HOSTS file:
127.0.0.0 localhost

Save the file and try http://localhost again.

---------------------------

Disable IIS in the Windows Control Panel because you obviously are not using it - it will interfere with the ports that XAMPP requires exclusively if running.

---------------------------

Your posting method looks fine to me and the extra detailed info is excellent. ;)


Hi,

After booting up this morning IIS was stopping XAMPP connecting so I removed it and now I get the 'running' on green backgrounds on both Apache and Mysql again.

When I enter http://127.0.0.1 (work offline is not selected) I get

The website cannot display the page
HTTP 500
Most likely causes:
The website is under maintenance.
The website has a programming error.

What you can try:
Refresh the page.

Go back to the previous page.

More information

This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.

For more information about HTTP errors, see Help.

And the same window with http://localhost/

http://localhost/wordpress/wp-admin/install first gives this ..

Object not found!
The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404
localhost
12/15/08 07:14:39
Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6

and after around 30 seconds changes to my website's log-page but after I enter the log-in details it gives the http 500 page again.

http://localhost/admin.php - gives a page of hieroglyphics.

Clicking 'admin' in the control panel gives me an http 500 with http://pay-off-debts.org/ in the address bar.

I didn't know another way to get to the welcome page.

I am happy to try going back a few steps as you descibe, "The much simpler way and in your case the preferred method is to download and install a fresh copy of WordPress in XAMPP duly configured with the correct paths using the admin install procedure".

I will check back to see if you want to try anything else and if not I will reinstall WordPress etc.

You're the boss .. and thank you,

Mike
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: #1046 - No database selected

Postby redbourn » 15. December 2008 06:56

Just to say that I checked my host file and it looks like this .

# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost

I can get into the 'welcome page' by using http://localhost/xampp/ as you mentioned above.

Mike
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: #1046 - No database selected

Postby Sharley » 15. December 2008 07:00

This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.
Remember this Mike?
Visit the server error.log file for server error 500 details.

HOSTS file looks good.

Tell me the file names that are in the htdocs folder (not the folders just the files).

In a clean XAMPP htdocs folder, apart from the graphic files, which you also have no need to list, I only see:
favicon.ico
index.html
index.php

Contents of index.php which redirects you to the http://localhost/xampp Welcome Page
Code: Select all
<?php
   if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
      $uri = 'https://';
   } else {
      $uri = 'http://';
   }
   $uri .= $_SERVER['HTTP_HOST'];
   header('Location: '.$uri.'/xampp/');
   exit;
?>
Something is wrong with the XAMPP installation :-(

Contents of index.html which just tells you It works!
Code: Select all
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
   "http://www.w3.org/TR/html4/loose.dtd">
<html>
   <head>
      <title></title>
   </head>
   <body>
      <h1>It works!</h1>
   </body>
</html>
So when I type http://localhost I should get the index.php file served.
Same as http://localhost/index.php
Both will send me to the Welcome page with http://localhost/xampp/ in the browser's address bar.

Or http://localhost/index.html will serve the index.html file above.


Now if we're getting this 500 server error it means that in that folder there is possibly a .htaccess file and possibly other superfluous files from when you download via ftp your WP files - but it's only a guess.

Rest assured Bob we will have a successful outcome very soon. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: #1046 - No database selected

Postby redbourn » 15. December 2008 09:01

Hi,

List of files in XAMPP htdocs

110dbmanager.php
admin.php

anyname.php

apache_pb2.gif
apache_pb2.png

apache_pb2_ani.gif
apache_pb.gif

apache_pb.png
cms_style.css

favicon.ico
freefromdebt_wp.gz

index.html
index.php

index_1228151693.htm

license.txt
readme.html

template_unnamed.html
template_vermilion.html

wp-app.php
wp-atom.php

wp-blog-header.php
wp-comments-post.php

wp-commentsrss2.php
wp-config.php

wp-config-sample.php

wp-cron.php
wp-feed.php

wp-links-opml.php
wp-load.php

wp-login.php
wp-mail.php

wp-pass.php
wp-rdf.php

wp-register.php
wp-rss2.php

wp-rss.php

wp-settings.php
wp-trackback.php

xmlrpc.php

Contents of my index.php

<?php
/**
* Front to the WordPress application. This file doesn't do anything, but loads
* wp-blog-header.php which does and tells WordPress to load the theme.
*
* @package WordPress
*/

/**
* Tells WordPress to load the WordPress theme and output it.
*
* @var bool
*/
define('WP_USE_THEMES', true);

/** Loads the WordPress Environment and Template */
require('./wp-blog-header.php');
?>

and contents of my index folders

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title></title>
</head>
<body>
<h1>It works!</h1>
</body>
</html>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

<head>
<title>110MB Free Web Hosting | Account Created</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<meta name="keywords" content="free web hosting, free php hosting" />
<meta name="description" content="When All Other Free Hosts Disappoint You -- Visit This One!" />
</head>

<body leftmargin="0" topmargin="0" marginwidth="0" marginheight="0" rightmargin="0" bottommargin="0">

<iframe align="center" width="100%" frameborder=0 bordercolor=0 height="1000" src="http://www.110mb.com/members-default-index-page.htm">The page you're accessing is not loading. Press Ctrl+F5 to refresh.</iframe>


<!-- NOTE TO NEW MEMBERS: Please delete this page, and create your own index.htm -->
</body>
</html>

At a guess (but I'm only an egg) I'd say that my index.php got overwritten,

Mike
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: #1046 - No database selected

Postby Sharley » 15. December 2008 09:12

Looks like an overwrite occurred and those other WP files are giving you issues when you try running WP.

Thats why a clean WP install will be a great advantage to eliminate any errors and confusion caused by the download and subsequent file overwrites, which includes, it appears, some files from your hosting provider that are absolutely error fodder on your XAMPP installation.

Just to test that we have found the cause of the http://localhost errors simply copy and paste the index.php code in my previous post into the index.php file, overwriting all the content, then save the file - you can make a backup copy of the WP index.php file if you wish before overwriting with the above code.

Then go to http://localhost and see if it takes you to the XAMPP Welcome page instead of the mystical error messages.

If all is now fine we/you are ready to proceed with the WP install.

I would remove all those files and folders that you downloaded from your hosting server and remove the wordpress folder before attempting to install WP again.

I believe there should be no need to delete the database if you are sure it is only the mirror of your hosted database - just provide WP with the credentials when installing WP again.


I think you now have a handle on what to do and I hope this time it all goes error free for you.

Good luck with it and I will still be here if you need a crutch. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: #1046 - No database selected

Postby redbourn » 15. December 2008 13:26

Thanks Sharley,

After trying various things and getting differnt errors I deleted both the XAMPP and the Wordress folders on my C:/ drive

I have reinstalled them and can now load a WordPress file locally which is where I was a few days ago except that I do have a WP database of my online site stored on my PC.

I believe I can install the database locally but will then need to download via ftp certain files from my 110mb host such as templates and plugins.

Make any necessary corrections and then reverse the procedure when I upload, but I obviously have no idea which ones :?

You are very kindly offering XAMPP support and may not want to enter into the above and if not I will ask the 100mb forum. They were helpful but not entirely sure of the procedure and suggested that I try back here.

Sadly,I dread the idea of going to the WordPress forum!

I belong to at least a dozen forums that are IT, cooking, photograpy, politics, guitar, dreamweaver, photoshop etc related and they are all very kind and helpful as is this group.

The WordPress forum is by far the most unpleasant and unhelpful (of course some people do their best to help) forum that I have encounted and others have told me the same.

Most people get no replies and many get replies such as, "if you don't know how to do it then get professional help - and a link".

I recently emailed WordPress about this.

If you do want to do this then maybe make a 'sticky' which will benefit many others and not just me.

Or else change the subject of this post.

Mike
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: #1046 - No database selected

Postby Sharley » 15. December 2008 22:30

Sorry Mike, I can help no more with WordPress issues as it is off topic and beyond the scope of these XAMPP forums - but I see you are doing quite well on other more WordPress specific forums, but like here you need to be more specific and detailed with your inquiries.

BTW, your domain(s) at 110 are still showing database connections errors, are you able to connect to the database you created in XAMPP?

Any issues with your XAMPP installation and components including database connection issues please feel free to start a new thread.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 24 guests