warning - directory mismatch

Problems with the Windows version of XAMPP, questions, comments, and anything related.

warning - directory mismatch

Postby redbourn » 11. December 2008 08:32

Hi,

I installed the light version into my root C: yesterday and I am able to start both apache and mysql but I do get a message - warning directory mismatch.

If I stop Skype then all necessary ports are available.

Earlier today after typing in http://localhost/ I got the page which allowed me to select my language; chose English and closed the page.

Now when I type http://localhost/ in my browser I get a 500 error.

So two things,

Any ideas on the above problem?

And, I will need to start a WordPress database but I believe I need to get into http://localhost/ in order to set it up. If that's not right then please let me know.

Any help would be appreciated,

Mike
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: warning - directory mismatch

Postby Wiedmann » 11. December 2008 08:43

Now when I type http://localhost/ in my browser I get a 500 error.

Read Apaches' "error.log".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: warning - directory mismatch

Postby Sharley » 11. December 2008 08:49

For *** Warning: Directory mismatch *** see here:
http://community.apachefriends.org/f/viewtopic.php?p=108259#p108259
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: warning - directory mismatch

Postby redbourn » 11. December 2008 09:15

thank you both for that!

And what fast replies!

OK - I made the registry change and it fixed the 'mismatch' problem!

I'm still getting the 500 error though when I enter either http://127.0.0.1 or http://localhost in IE

In Chrome and Firefox I get 'Error establishing a database connection'.



Mike
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: warning - directory mismatch

Postby Sharley » 11. December 2008 09:22

As pointed out the .\xampp\apache\logs\error.log file holds the server error 500 clues...
...and you won't be able to proceed until you fix the cause of the server error.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: warning - directory mismatch

Postby redbourn » 11. December 2008 09:41

Sharley wrote:As pointed out the .\xampp\apache\logs\error.log file holds the server error 500 clues...
...and you won't be able to proceed until you fix the cause of the server error.


Thanks Sharley. I am reasonably computer literate but not a professional; not a programmer and weak on server side technology.

So please bear with me :wink:

[Thu Dec 11 08:49:55 2008] [error] [client 127.0.0.1] File does not exist: C:/xampplite/htdocs/myhome
[Thu Dec 11 08:51:45 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Thu Dec 11 08:51:45 2008] [notice] Server built: Jun 14 2008 19:02:12
[Thu Dec 11 08:51:45 2008] [notice] Parent: Created child process 3844
Apache server shutdown initiated...
Child 3844: Child process is running
[Thu Dec 11 08:51:47 2008] [notice] Child 3844: Acquired the start mutex.
[Thu Dec 11 08:51:47 2008] [notice] Child 3844: Starting 250 worker threads.
[Thu Dec 11 08:51:47 2008] [notice] Child 3844: Starting thread to listen on port 443.
[Thu Dec 11 08:51:47 2008] [notice] Child 3844: Starting thread to listen on port 80.
[Thu Dec 11 08:53:23 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Dec 11 08:53:23 2008] [notice] Child 3844: Exit event signaled. Child process is ending.
[Thu Dec 11 08:53:24 2008] [notice] Child 3844: Released the start mutex
[Thu Dec 11 08:53:25 2008] [notice] Child 3844: All worker threads have exited.
[Thu Dec 11 08:53:25 2008] [notice] Child 3844: Child process is exiting
[Thu Dec 11 08:53:26 2008] [notice] Parent: Child process exited successfully.
[Thu Dec 11 08:53:48 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Thu Dec 11 08:53:48 2008] [notice] Server built: Jun 14 2008 19:02:12
[Thu Dec 11 08:53:48 2008] [notice] Parent: Created child process 2388
Apache server shutdown initiated...
Child 2388: Child process is running
[Thu Dec 11 08:53:50 2008] [notice] Child 2388: Acquired the start mutex.
[Thu Dec 11 08:53:50 2008] [notice] Child 2388: Starting 250 worker threads.
[Thu Dec 11 08:53:50 2008] [notice] Child 2388: Starting thread to listen on port 443.
[Thu Dec 11 08:53:50 2008] [notice] Child 2388: Starting thread to listen on port 80.
[Thu Dec 11 08:54:01 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Dec 11 08:54:01 2008] [notice] Child 2388: Exit event signaled. Child process is ending.
[Thu Dec 11 08:54:02 2008] [notice] Child 2388: Released the start mutex
[Thu Dec 11 08:54:03 2008] [notice] Child 2388: All worker threads have exited.
[Thu Dec 11 08:54:03 2008] [notice] Child 2388: Child process is exiting
[Thu Dec 11 08:54:03 2008] [notice] Parent: Child process exited successfully.
[Thu Dec 11 08:54:32 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Thu Dec 11 08:54:32 2008] [notice] Server built: Jun 14 2008 19:02:12
[Thu Dec 11 08:54:32 2008] [notice] Parent: Created child process 648
[Thu Dec 11 08:54:33 2008] [notice] Child 648: Child process is running
[Thu Dec 11 08:54:33 2008] [notice] Child 648: Acquired the start mutex.
[Thu Dec 11 08:54:33 2008] [notice] Child 648: Starting 250 worker threads.
[Thu Dec 11 08:54:33 2008] [notice] Child 648: Starting thread to listen on port 80.
[Thu Dec 11 08:54:33 2008] [notice] Child 648: Starting thread to listen on port 443.
[Thu Dec 11 08:55:59 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Dec 11 08:55:59 2008] [notice] Child 648: Exit event signaled. Child process is ending.
[Thu Dec 11 08:56:00 2008] [notice] Child 648: Released the start mutex
[Thu Dec 11 08:56:01 2008] [notice] Child 648: All worker threads have exited.
[Thu Dec 11 08:56:01 2008] [notice] Child 648: Child process is exiting
[Thu Dec 11 08:56:01 2008] [notice] Parent: Child process exited successfully.
[Thu Dec 11 08:56:22 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Thu Dec 11 08:56:22 2008] [notice] Server built: Jun 14 2008 19:02:12
[Thu Dec 11 08:56:22 2008] [notice] Parent: Created child process 4800
[Thu Dec 11 08:56:24 2008] [notice] Child 4800: Child process is running
[Thu Dec 11 08:56:24 2008] [notice] Child 4800: Acquired the start mutex.
[Thu Dec 11 08:56:24 2008] [notice] Child 4800: Starting 250 worker threads.
[Thu Dec 11 08:56:24 2008] [notice] Child 4800: Starting thread to listen on port 443.
[Thu Dec 11 08:56:24 2008] [notice] Child 4800: Starting thread to listen on port 80.
[Thu Dec 11 08:57:16 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Dec 11 08:57:16 2008] [notice] Child 4800: Exit event signaled. Child process is ending.
[Thu Dec 11 08:57:17 2008] [notice] Child 4800: Released the start mutex
[Thu Dec 11 08:57:18 2008] [notice] Child 4800: All worker threads have exited.
[Thu Dec 11 08:57:18 2008] [notice] Child 4800: Child process is exiting
[Thu Dec 11 08:57:18 2008] [notice] Parent: Child process exited successfully.
[Thu Dec 11 08:57:27 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Thu Dec 11 08:57:27 2008] [notice] Server built: Jun 14 2008 19:02:12
[Thu Dec 11 08:57:27 2008] [notice] Parent: Created child process 1076
[Thu Dec 11 08:57:28 2008] [notice] Child 1076: Child process is running
[Thu Dec 11 08:57:28 2008] [notice] Child 1076: Acquired the start mutex.
[Thu Dec 11 08:57:28 2008] [notice] Child 1076: Starting 250 worker threads.
[Thu Dec 11 08:57:28 2008] [notice] Child 1076: Starting thread to listen on port 443.
[Thu Dec 11 08:57:28 2008] [notice] Child 1076: Starting thread to listen on port 80.
[Thu Dec 11 08:57:41 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Dec 11 08:57:41 2008] [notice] Child 1076: Exit event signaled. Child process is ending.
[Thu Dec 11 08:57:42 2008] [notice] Child 1076: Released the start mutex
[Thu Dec 11 08:57:43 2008] [notice] Child 1076: All worker threads have exited.
[Thu Dec 11 08:57:43 2008] [notice] Child 1076: Child process is exiting
[Thu Dec 11 08:57:43 2008] [notice] Parent: Child process exited successfully.
[Thu Dec 11 09:12:04 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Thu Dec 11 09:12:04 2008] [notice] Server built: Jun 14 2008 19:02:12
[Thu Dec 11 09:12:04 2008] [notice] Parent: Created child process 1340
[Thu Dec 11 09:12:05 2008] [notice] Child 1340: Child process is running
[Thu Dec 11 09:12:05 2008] [notice] Child 1340: Acquired the start mutex.
[Thu Dec 11 09:12:05 2008] [notice] Child 1340: Starting 250 worker threads.
[Thu Dec 11 09:12:05 2008] [notice] Child 1340: Starting thread to listen on port 443.
[Thu Dec 11 09:12:05 2008] [notice] Child 1340: Starting thread to listen on port 80.
[Thu Dec 11 09:42:29 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Dec 11 09:42:29 2008] [notice] Child 1340: Exit event signaled. Child process is ending.
[Thu Dec 11 09:42:30 2008] [notice] Child 1340: Released the start mutex
[Thu Dec 11 09:42:31 2008] [notice] Child 1340: All worker threads have exited.
[Thu Dec 11 09:42:31 2008] [notice] Child 1340: Child process is exiting
[Thu Dec 11 09:42:31 2008] [notice] Parent: Child process exited successfully.
[Thu Dec 11 10:03:35 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Thu Dec 11 10:03:35 2008] [notice] Server built: Jun 14 2008 19:02:12
[Thu Dec 11 10:03:35 2008] [notice] Parent: Created child process 4140
[Thu Dec 11 10:03:36 2008] [notice] Child 4140: Child process is running
[Thu Dec 11 10:03:36 2008] [notice] Child 4140: Acquired the start mutex.
[Thu Dec 11 10:03:36 2008] [notice] Child 4140: Starting 250 worker threads.
[Thu Dec 11 10:03:36 2008] [notice] Child 4140: Starting thread to listen on port 443.
[Thu Dec 11 10:03:36 2008] [notice] Child 4140: Starting thread to listen on port 80.
[Thu Dec 11 10:07:42 2008] [error] [client 127.0.0.1] script 'C:/xampplite/htdocs/test.php' not found or unable to stat

Any ideas?

Mike
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: warning - directory mismatch

Postby Sharley » 11. December 2008 09:53

Not a problemo Mike, I will bear with you. ;)

All the [notices] are normal and are generated usually on shut down and start up of the server.

However the 2 [errors] are not normal.

[Thu Dec 11 08:49:55 2008] [error] [client 127.0.0.1] File does not exist: C:/xampplite/htdocs/myhome

[Thu Dec 11 10:07:42 2008] [error] [client 127.0.0.1] script 'C:/xampplite/htdocs/test.php' not found or unable to stat


So you need to sort those 2 errors out which would seem to be self explanatory.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: warning - directory mismatch

Postby Wiedmann » 11. December 2008 09:57

However the 2 [errors] are not normal.

These are only 404 errors and can be "normal", if
a) the directory "myhome" does not exist
b) the file test.php does not exist

But I don't see any error 500 in this log? ...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: warning - directory mismatch

Postby redbourn » 11. December 2008 10:36

just rebooted whilst I took a shower which normally fixes 95% of the problems - both mine and the computers :-)

Some observations which may be helpful ..

When I opened the control panel for the first time after rebooting, mysql was already running.

Clicked on Apache and it started with no errors showing.

Clicked on Apache admin and IE opened with a http 500 error :-(

When I click on MySql admin the page opens but quickly closes.

When I click on the traffic light in the tray the my sql manager opens up and stays open :-)

It has a message in myodc - driver 3.51 not found ?!

'Start check' - ini file - yes and server path key OK

Will do a little work now. Earn a crust as we English say.

Will check back later,

Mike

BTW - htdocs exists because WordPress is in it.

----

PHP/5.2.6 configured -- resuming normal operations
[Thu Dec 11 11:24:43 2008] [notice] Server built: Jun 14 2008 19:02:12
[Thu Dec 11 11:24:43 2008] [notice] Parent: Created child process 2596
[Thu Dec 11 11:24:45 2008] [notice] Child 2596: Child process is running
[Thu Dec 11 11:24:45 2008] [notice] Child 2596: Acquired the start mutex.
[Thu Dec 11 11:24:45 2008] [notice] Child 2596: Starting 250 worker threads.
[Thu Dec 11 11:24:45 2008] [notice] Child 2596: Starting thread to listen on port 443.
[Thu Dec 11 11:24:45 2008] [notice] Child 2596: Starting thread to listen on port 80.
[Thu Dec 11 11:28:04 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Dec 11 11:28:04 2008] [notice] Child 2596: Exit event signaled. Child process is ending.
[Thu Dec 11 11:28:05 2008] [notice] Child 2596: Released the start mutex
[Thu Dec 11 11:28:06 2008] [notice] Child 2596: All worker threads have exited.
[Thu Dec 11 11:28:06 2008] [notice] Child 2596: Child process is exiting
[Thu Dec 11 11:28:06 2008] [notice] Parent: Child process exited successfully.
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: warning - directory mismatch

Postby Sharley » 11. December 2008 12:48

No error in your log file is normal.
redbourn wrote:When I opened the control panel for the first time after rebooting, mysql was already running.
The Svc box is checked in the XAMPP Control Panel?
Un-check the Svc box to unload MySQL running as a service.

redbourn wrote:Clicked on Apache admin and IE opened with a http 500 error
Clear your browser's cache. Your browser's cache can be a real problem working at localhost level - clear it often when developing your web sites.

redbourn wrote:When I click on MySql admin the page opens but quickly closes.

When I click on the traffic light in the tray the my sql manager opens up and stays open

It has a message in myodc - driver 3.51 not found ?!

'Start check' - ini file - yes and server path key OK
Don't use the MySQL Admin... in the XCP it is deprecated - use phpMyAdmin instead.

When you see the Traffic Light icon right click on it and select Win NT then select Shut down this tool, select Yes when prompted.

Your error.log file looks fine now and error free, which leads me to assume the web browser is giving you old cached pages and so clearing out your cache should fix that 500 error issue.

After clearing your cache try http://localhost again.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: warning - directory mismatch

Postby redbourn » 11. December 2008 14:26

Sharley,

Turning off servics was good to know.

I cleared the caches in IE, FF and Chrome but still get "Error establishing a database connection' in the latter two and 500 in the former.

Which Windows XP version should I dowload that will write to the registry?

I made the suggested changes and they got rid of the error but perhaps more entries need to be made?

Thanks of hanging on in there! We (all of us friends) will get it solved,

Mike

P.S. Beautiful and uplifting 15 minute prize winning movie (not one of mine ;-) ) http://www.flixxy.com/validation-short-film.htm?a=0
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: warning - directory mismatch

Postby redbourn » 11. December 2008 22:11

Well XAMPP is working now and I can only say that this is the difference ..

ZIP 50 MB ZIP archive
MD5 checksum: f1447262b589ffaf790225376fd5ff0e
EXE (7-zip) 18 MB Selfextracting ZIP archive
MD5 checksum: 038a657b7feae01aba1abdb82e01ece2

I originally used the EXE (7-zip) version which didn't work.

Then I used the 50 MB zip version and it worked immediately.

Why is the zip version three times as big as the exe version?

Why did it work immediately?

Mike
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: warning - directory mismatch

Postby Sharley » 11. December 2008 23:41

redbourn wrote:Why is the zip version three times as big as the exe version?
The compression algorithm used by 7zip will compress files much more than most other archivers - see their web site http://www.7zip.org.

I use the 7zip versions all the time and never had any issues, may be the difference is I have installed the 7zip program from the above site and usually use the program to check the integrity of the archive and then use the 7zip program to unpack it first, again to check it's integrity which only takes an extra moment to make sure all is well - but perhaps this may not have helped in your case.

redbourn wrote:Why did it work immediately?
Your guess - could have been a corrupt download or a multitude of issues associated with compressed archives.

However, I am pleased for you that XAMPP is now up and running - let the show begin. :)

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: warning - directory mismatch

Postby redbourn » 12. December 2008 09:17

thanks.

WordPress is now working locally and I'm now learning how to keep the local and remote versions in sync.

Not too difficult I think with the database being the only exception as the 'address' has to be changed each time.

Mike
User avatar
redbourn
 
Posts: 18
Joined: 11. December 2008 08:21
Location: tel aviv - teaching english

Re: warning - directory mismatch

Postby Sharley » 13. December 2008 02:38

Just to add more info about a possible cause of your not been able to have a successful 7zip installation and a helpful hint for others reading this thread wanting to use the much smaller archive 7zip file - this from the XAMPP beta page:
Windows users: To extract 7z files, you need 7-Zip installed (follow this link to get it).
Even though the tip refers to a 7z file, I believe that this would appear also to be the reason, as I stated in an above post, why I had no issues with the 7zip self-extracting XAMPP versions during installation and subsequent upgrades of XAMPP.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests