Big Problem Plz Heeeelp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Big Problem Plz Heeeelp

Postby Pe3zay » 10. December 2008 22:09

Hi!
I'm new here and i have a big problem, I'm have xampp and everything workd great until now
I try to connect to phpmyadmin and i got a error message

cannot load MySQL extension, please check PHP Configuration

How do i fix this? please someone help me i'm not good in this :cry:
Pe3zay
 
Posts: 8
Joined: 10. December 2008 22:03

Re: Big Problem Plz Heeeelp

Postby Wiedmann » 10. December 2008 22:22

How do i fix this?

XAMPP is using a wrong (old?) "php.ini".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Big Problem Plz Heeeelp

Postby Pe3zay » 10. December 2008 22:25

Wiedmann wrote:
How do i fix this?

XAMPP is using a wrong (old?) "php.ini".


Okej can i download a new php.ini?
Pe3zay
 
Posts: 8
Joined: 10. December 2008 22:03

Re: Big Problem Plz Heeeelp

Postby glitzi85 » 10. December 2008 22:28

No, you do not have an old php.ini, your PHP uses an wrong version of php.ini on your Computer. That normally happens if people install PHP by thereself and thereafter XAMPP. Then the PHP from XAMPP is using the php.ini from the old PHP installation. Search for php.inis outside your XAMPP-Directory and delete them!

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Big Problem Plz Heeeelp

Postby Pe3zay » 10. December 2008 22:50

glitzi85 wrote:No, you do not have an old php.ini, your PHP uses an wrong version of php.ini on your Computer. That normally happens if people install PHP by thereself and thereafter XAMPP. Then the PHP from XAMPP is using the php.ini from the old PHP installation. Search for php.inis outside your XAMPP-Directory and delete them!

glitzi



okej I have search for php.ini on C: cus my xamp is installd in D:
but search give no results.
all my website have been working for 1 year now whit no problems
but now i only got blan websites and when i try to connect to phpmyadmin
i got that error message.
I haven't updatede xampp so i have a old version cus i don't understand the guide for updateing your xampp.
Pe3zay
 
Posts: 8
Joined: 10. December 2008 22:03

Re: Big Problem Plz Heeeelp

Postby Wiedmann » 10. December 2008 23:04

okej I have search for php.ini on C: cus my xamp is installd in D:
but search give no results.

What's the value of "loaded configuration file" in phpinfo()?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Big Problem Plz Heeeelp

Postby Pe3zay » 10. December 2008 23:14

Wiedmann wrote:
okej I have search for php.ini on C: cus my xamp is installd in D:
but search give no results.

What's the value of "loaded configuration file" in phpinfo()?


D:\xampp\php\php4\php.ini
Pe3zay
 
Posts: 8
Joined: 10. December 2008 22:03

Re: Big Problem Plz Heeeelp

Postby Wiedmann » 10. December 2008 23:19

D:\xampp\php\php4\php.ini

That's the wrong file. Have you test this in the shell or with the browser?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Big Problem Plz Heeeelp

Postby Pe3zay » 10. December 2008 23:27

Wiedmann wrote:
D:\xampp\php\php4\php.ini

That's the wrong file. Have you test this in the shell or with the browser?


i logd in to my http://localhost/xampp/ and there i found phpinfo()
and search for the "Loaded Configuration File"
and there it say D:\xampp\php\php4\php.ini
do you want me to copy all the text i have when i put D:\xampp\php\php4\php.ini in my browser?
and remember i have a old version of xampp
the version is 1.6.2 :oops:

sorry for my english i'm from sweden
Pe3zay
 
Posts: 8
Joined: 10. December 2008 22:03

Re: Big Problem Plz Heeeelp

Postby Wiedmann » 10. December 2008 23:36

Which PHP version are you using? (look in phpinfo())
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Big Problem Plz Heeeelp

Postby Pe3zay » 10. December 2008 23:39

Wiedmann wrote:Which PHP version are you using? (look in phpinfo())



PHP Version 5.2.2
Pe3zay
 
Posts: 8
Joined: 10. December 2008 22:03

Re: Big Problem Plz Heeeelp

Postby Wiedmann » 10. December 2008 23:43

Is the directive "PHPIniDir" in any of Apaches' config files?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Big Problem Plz Heeeelp

Postby Pe3zay » 10. December 2008 23:50

Wiedmann wrote:Is the directive "PHPIniDir" in any of Apaches' config files?


I lookt in D:\xampp\apache\conf and there i find this file httpd CONF
and search for PHPIniDir but whit no luck
Pe3zay
 
Posts: 8
Joined: 10. December 2008 22:03

Re: Big Problem Plz Heeeelp

Postby Wiedmann » 11. December 2008 00:01

I lookt in D:\xampp\apache\conf

You must search in all *.conf files in this directory and subdirectory.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Big Problem Plz Heeeelp

Postby Pe3zay » 11. December 2008 00:14

Wiedmann wrote:
I lookt in D:\xampp\apache\conf

You must search in all *.conf files in this directory and subdirectory.



I have search for PHPIniDir in all directorys in D:\xampp\apache
but nothing there :(
Pe3zay
 
Posts: 8
Joined: 10. December 2008 22:03

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests