HELP PLEASE. First time running XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

HELP PLEASE. First time running XAMPP

Postby bee-cc » 09. December 2008 00:40

Hello everyone

I need some guidance please. I am setting up a small intranet using XAMPP and the Drupal CMS...
So far I've installed XAMPP on the internal server, which worked fine. I can access the control panel of XAMPP but next I want to launch phpMyAdmin... so I type http://localhost into my web browser to get to phpMyAdmin but it comes up with:

"Internet Explorer cannot display the webpage"

I'm guessing this is because the xampp installation is on a different box (the server and not my local PC). Does anyone know how I can fix this, or how to launch phpMyAdmin another way?

All help is appreciated, thanks in advance :)

BCC
bee-cc
 
Posts: 4
Joined: 09. December 2008 00:23

Re: HELP PLEASE. First time running XAMPP

Postby glitzi85 » 09. December 2008 02:03

localhost is the address of the local machine, the computer you are sitting at the moment (always!).

You must either type http://ip.of.the.server or http://name-of-the-server.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: HELP PLEASE. First time running XAMPP

Postby bee-cc » 09. December 2008 03:00

ok now that you mention that glitzi, it makes perfect sense :)
So instead of locahost, I'm entering the server name but it brings up the LOTUS landing page and not XAMPP. If I go to server/xampp it just opens the folder in windows explorer

what should I do next mate ?
thanks for your help!!!
bee-cc
 
Posts: 4
Joined: 09. December 2008 00:23

Re: HELP PLEASE. First time running XAMPP

Postby glitzi85 » 09. December 2008 11:28

OK, that's strange. It is impossible to start Apache if there is already a webserver listening on Port 80. So you should get an error message when you try to start Apache from XAMPP.

The easiest way would be to change the Apache Port. To do this, you must edit this file: xampp\apache\conf\httpd.conf and change this line:

Code: Select all
Listen 80


to for example this one:

Code: Select all
Listen 8080


Then start your Apache and run call it in this way: http://server-name:8080

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: HELP PLEASE. First time running XAMPP

Postby bee-cc » 10. December 2008 00:05

Glitzi, you are a legend!
Thanks for giving me specific help on this issue, I think your instructions will help me with what I need.

Thanks thanks thanks :)
bee-cc
 
Posts: 4
Joined: 09. December 2008 00:23


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 31 guests