NEED SOME HELP! PLEASE CHECK THIS OUT.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

NEED SOME HELP! PLEASE CHECK THIS OUT.

Postby ohtonnyy » 06. December 2008 10:19

ive had xampp installed for about a month. currently running through a router with everything setup right and forwarded. Also using freedns.afraid.org for my DNS.

currently using Name based host.. so the only thing in my httpd.conf file is the normal stuff plus a few tweaked things. but no virtualhost.

ive been trying to set it up to be accessed externally, and i havent been able to do it successfully, but just a minute ago i found a post and im not sure if this is going to work. but i configured the files and now i need to know if anybody can access it. and if not then ill post my httpd-vhosts.conf file and my Windows host file.
(btw, AFTER SETTING UP THE FILES THE WAY THE PERSON SAID TOO, I CAN NOW ACCESS MY SITES via: EXTERNAL IP, INTERNAL IP, AND THE DOMAINS.

external ip = 75.176.185.133

domains setup in vhost file =

http://tonygodwin.co.cc
http://babyinc.co.cc
http://msscripts.co.cc
http://tonysportal.co.cc


i can access my sites internally with the domains, but im not sure if they can be accessed externally.
ohtonnyy
 
Posts: 2
Joined: 06. December 2008 10:07

Re: NEED SOME HELP! PLEASE CHECK THIS OUT.

Postby ohtonnyy » 06. December 2008 10:34

i have everything working now! that must have done the trick, or maybe it was working before.

i had to keep asking ppl on AIM (aol instant messanger) to check to see if the sites were working, and everytime, id get a NO answer, and just now it hit me... maybe AIM was using the PORT 80 that im hosting the sites on... and what do you know... i sign out of AIM and get on aim through meebo.com and ask somebody again... and BOOM it works... im not sure if it was the configuration that fixed it or that it was working all along and i thought it wasnt because i was on AIM when i asked ppl to check.

but if anybody else cant get it working please let me know.. i will happily post my Windows host, httpd-vhost.conf, and httpd.conf files.
ohtonnyy
 
Posts: 2
Joined: 06. December 2008 10:07

Re: NEED SOME HELP! PLEASE CHECK THIS OUT.

Postby Sharley » 06. December 2008 11:08

I can access all 4 domains and the IP - but you will have to use the link below to test if they are all being served by XAMPP.

If you want to test yourself without asking others, go here
http://centralops.net/co/DomainDossier.aspx
and enter a domain name or IP then tick the boxes you want to check - Service scan will test your server.

Click on the CentralOps.Net logo to go to other useful utilities.

BTW all caps in a post means you are shouting and it is not good to shout in a forum. ;)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 77 guests