path problem in xampp 1.6.8

Problems with the Windows version of XAMPP, questions, comments, and anything related.

path problem in xampp 1.6.8

Postby highjo » 02. December 2008 10:23

hi every body!After installing xampp 1.6.8 on drive c i added the environment variables path c:/xampp/php;c:/xampp/mysql/bin;.i tested by typing php anywhere whithout bieng in c:/xampp/php and it work.I'll like to install packages using pear.But typing pear config-show even in c:/xampp/php end up with the same message pear is not recognized as internal or external command, operable program or batch files.So i'll like to ask if there is something i'not doing well?whatever be the case something is not right.if anybody has an idea i'll be more than gratefull.thanks
highjo
 
Posts: 16
Joined: 31. March 2008 21:09

Postby Sharley » 02. December 2008 10:57

Works on my installation.

I opened a command console window in:
C:\xampp\php
Then typed: pear config-show
Code: Select all
C:\xampp\php>pear config-show
CONFIGURATION (CHANNEL PEAR.PHP.NET):
=====================================
Auto-discover new Channels     auto_discover    <not set>
Default Channel                default_channel  pear.php.net
HTTP Proxy Server Address      http_proxy       <not set>
PEAR server [DEPRECATED]       master_server    pear.php.net
Default Channel Mirror         preferred_mirror pear.php.net
Remote Configuration File      remote_config    <not set>
PEAR executables directory     bin_dir          \xampp\php
PEAR documentation directory   doc_dir          \xampp\php\pear\docs
PHP extension directory        ext_dir          \xampp\php\ext
PEAR directory                 php_dir          \xampp\php\pear
PEAR Installer cache directory cache_dir        \xampp\tmp
PEAR configuration file        cfg_dir          C:\php5\pear\cfg
directory
PEAR data directory            data_dir         \xampp\php\pear\data
PEAR Installer download        download_dir     C:\DOCUME~1\IZZYAN~1\LOCALS~1\Temp\pear\download
directory
PHP CLI/CGI binary             php_bin          \xampp\php\php.exe
php.ini location               php_ini          <not set>
PEAR Installer temp directory  temp_dir         C:\DOCUME~1\IZZYAN~1\LOCALS~1\Temp\pear\temp
PEAR test directory            test_dir         \xampp\php\pear\tests
PEAR www files directory       www_dir          C:\php5\pear\www
Cache TimeToLive               cache_ttl        3600
Preferred Package State        preferred_state  stable
Unix file mask                 umask            0
Debug Log Level                verbose          1
PEAR password (for             password         <not set>
maintainers)
Signature Handling Program     sig_bin          c:\gnupg\gpg.exe
Signature Key Directory        sig_keydir       \xampp\php\pearkeys
Signature Key Id               sig_keyid        <not set>
Package Signature Type         sig_type         gpg
PEAR username (for             username         <not set>
maintainers)
User Configuration File        Filename         \xampp\php\pear.ini
System Configuration File      Filename         \xampp\php\pearsys.ini

So I don't know what you have done wrong to get your error - perhaps you should revert any changes you made to the defaults then try again.

Also, what OS are you using?

I have just gone to start>Run...
and typed in the text box
pear config-show
and received the same response as in the code box above.

I have C:\xampp\php in my System variables Path but not in my User variables PATH.
Did you reboot your system after editing the path?

So you may have done something wrong somewhere that only you can know.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby highjo » 02. December 2008 13:43

thanks dude for replying.I did have my path in system path.Things you said make me thing that something is wrong with my installation so i removed it and installed the xampp 1.6.8 zip version.Still the same problem.restarted the machine though.so i removed that one too and reinstalled 1.6.3a.and it works without me restarting the machine or re-add the path.Is there things like that wrong in the new release or it's just something with my windows xp sp2 machine?But thanks a lot.gud day
highjo
 
Posts: 16
Joined: 31. March 2008 21:09

Postby Wiedmann » 02. December 2008 14:09

Is there things like that wrong in the new release

The file "pear.bat" is missing in the current XAMPP 1.6.8. Sorry.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby highjo » 02. December 2008 14:27

thanks wiedmann.i 've figure out that things like that might be the cause of my nightmares.So what is the solution on that.what is provided to work around it?thanks
highjo
 
Posts: 16
Joined: 31. March 2008 21:09

Postby Wiedmann » 02. December 2008 15:07

So what is the solution on that.what is provided to work around it?

Use the "pear.bat" from an older XAMPP and adjust the paths in that file.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby highjo » 02. December 2008 19:50

hi wiedmann.I added that and while upgrading pear i'm having this error :"C:\xampp\php>pear update-channels

Warning: require_once(PEAR/Frontend.php): failed to open stream: No such file or directory
in pearcmd.php on line 53

Warning: require_once(PEAR/Frontend.php): failed to open stream: No such file or directory
in C:\xampp\php\PEAR\pearcmd.php on line 53

Fatal error: require_once(): Failed opening required 'PEAR/Frontend.php' (include_path='C:
\xampp\php\pear') in C:\xampp\php\PEAR\pearcmd.php on line 53"
i checked the file pearcmd.php and there is files like :
"require_once 'PEAR.php';
require_once 'PEAR/Frontend.php';
require_once 'PEAR/Config.php';
require_once 'PEAR/Command.php';
require_once 'Console/Getopt.php';
"

files like frontend.php , command.php ,Getopt.php are missing.Its getting complicated right here.
highjo
 
Posts: 16
Joined: 31. March 2008 21:09

Postby Wiedmann » 02. December 2008 20:06

require_once 'PEAR.php';
require_once 'PEAR/Frontend.php';
require_once 'PEAR/Config.php';
require_once 'PEAR/Command.php';
require_once 'Console/Getopt.php';

Hm, I have all these files in my 1.6.8 installation.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby highjo » 03. December 2008 10:32

well i just removed what i have already and extracted the 1.6.8 zip again on the drive C: and execute the setup_xampp.later copy the pear.bat into the php folder and type pear config-show and now it's other kind of issue it displays this
C:\>pear config-show

Warning: require_once(PEAR.php): failed to open stream: No such file or directory in Confi
g.php on line 27

Warning: require_once(PEAR.php): failed to open stream: No such file or directory in C:\xa
mpp\php\PEAR\PEAR\Config.php on line 27

Fatal error: require_once(): Failed opening required 'PEAR.php' (include_path='D:\release168\testsC:\xampp\php\pear') in C:\xampp\php\PEAR\PEAR\Config.php on line 27

C:\>

inside config.php
require_once 'PEAR.php';
require_once 'PEAR/Registry.php';
require_once 'PEAR/Installer/Role.php';
require_once 'System.php';
require_once 'PEAR/Remote.php';

something is interesting here and i have questions. where is the include_path set? and why it referencing a non existing path?nothing is on drive D with the name release168.How to solve this one.Are we sure that copy the pear.bat from other realease to this one isn't messing with something.Can you check with yours and tell me if pear functions works finr there ?And please can anyone provide a fix for this.Thanks
highjo
 
Posts: 16
Joined: 31. March 2008 21:09

Postby Wiedmann » 03. December 2008 10:44

copy the pear.bat into the php folder

Wiedmann wrote:and adjust the paths in that file.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby highjo » 03. December 2008 11:15

copy the pear.bat into the php folder


that is done already that's why i can even run pear in command prompt.
and adjust the paths in that file.


well this is a bit confusing for me. what i've done so far is to reference the file
C:\xampp\php\PEAR\PEAR.php in the C:\xampp\php\PEAR\PEAR\Config.php
by changing require_once 'PEAR.php'; to require_once './PEAR.php'; but not working.Is that you are talking about? or do something with the include_path? if is the case can you please tell me where? :oops:
highjo
 
Posts: 16
Joined: 31. March 2008 21:09

Postby Wiedmann » 03. December 2008 11:48

and adjust the paths in that file.

well this is a bit confusing for me.

Open the file "pear.bat" in a texteditor and correct the paths in this file.

(You must also correct the paths in the file pearcmd.php, line 32+33)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: path problem in xampp 1.6.8

Postby highjo » 03. December 2008 16:38

thanks a lot its done.And i appreciate the patience with which you too me through this.I 've learnt a lot.
highjo
 
Posts: 16
Joined: 31. March 2008 21:09


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 83 guests