Apache running but not responding

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache running but not responding

Postby thejim » 29. November 2008 03:05

Let me paint the picture...

Win XP Pro - already have IIS installed (I am going to have to run both on the production server I'm trying to emulate.) Jumped through all the hoops for the port fight... IIS stayed on port 80 and 443 - moved Apache to 8080 and 4430 (followed instructions in thread: http://community.apachefriends.org/f/viewtopic.php?t=10364). Control panel says both Apache and MySQL start and run. Sweet!

(Though the control panel still reports port 80??? Wha? Please tell me it's hardcoded in the control panel - or is this part of my problem??)

I am not able to get it to respond at ALL to http://localhost:8080/index.html (I'm working from the base install of xampp.)

Thinking it wasn't really starting. I stopped the IIS to free up port 80 - and moved Apache to 80. I restart Apache - and I'm able to see that Apache gets a lock on port 80 via the port check tool - so I do have confirmation the Apache server is coming online.

But even with Apache set to port 80 - I'm not able to get any response from http://localhost/index.html

It shouldn't be a firewall issue - when IIS runs - I'm able to get ASP pages to serve from port 80.

Any ideas out in the cloud at all? Man am I humble on this one. I will listen to ALL advice!
thejim
 
Posts: 7
Joined: 29. November 2008 02:39

Re: Apache running but not responding

Postby Sharley » 29. November 2008 04:23

thejim wrote:(Though the control panel still reports port 80??? Wha? Please tell me it's hardcoded in the control panel - or is this part of my problem??)
It's hard coded please ignore.
thejim wrote:...I am not able to get it to respond at ALL to http://localhost:8080/index.html...

Try simply http://localhost:8080/ and see if you get to the XAMPP Welcome page - the actual URI is http://localhost:8080/index.php not index.html unless you have added your own index.html file.

Just to add - Listen *:8080 (using the wild card) has often been known to help with connections to the server.

This line if you have it should also be changed:
ServerName localhost:80
to
ServerName localhost:8080
Save the conf file and restart apache after making any edits.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache running but not responding

Postby thejim » 29. November 2008 04:37

Sharley wrote:Try simply http://localhost:8080/ and see if you get to the XAMPP Welcome page - the actual URI is http://localhost:8080/index.php not index.html unless you have added your own index.html file.


I did try this - and I'm afraid no go.

Here is the latest entry into the error.log file:
Code: Select all
[Fri Nov 28 20:27:58 2008] [warn] pid file C:/Jim/CofCS/NewCofCS/PHPWebsite/xampp/xampplite/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Fri Nov 28 20:28:02 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Fri Nov 28 20:28:02 2008] [notice] Server built: Jun 14 2008 19:02:12
[Fri Nov 28 20:28:02 2008] [notice] Parent: Created child process 8444
[Fri Nov 28 20:28:06 2008] [notice] Child 8444: Child process is running
[Fri Nov 28 20:28:06 2008] [notice] Child 8444: Acquired the start mutex.
[Fri Nov 28 20:28:06 2008] [notice] Child 8444: Starting 250 worker threads.
[Fri Nov 28 20:28:06 2008] [notice] Child 8444: Starting thread to listen on port 4430.
[Fri Nov 28 20:28:06 2008] [notice] Child 8444: Starting thread to listen on port 8080.


So it is starting and it is on port 8080. But still no response when I try and go to the localhost on that port.

Any other places to look for error information?

The file called "access.log" is empty - should this be showing me attempting to hit it?

Thank you for the encouragement of a reply! :)
thejim
 
Posts: 7
Joined: 29. November 2008 02:39

Postby Sharley » 29. November 2008 04:42

C:/Jim/CofCS/NewCofCS/PHPWebsite/xampp/

Because of this path did you run setup_xampp.bat file after installing XAMPP so that all the correct paths will be set? - readme_en.txt

The normal install path is C:\xampp

Unclean shutdown of previous Apache run - is normal after shutting down from the XAMPP Control Panel.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby thejim » 29. November 2008 04:57

Because of this path did you run setup_xampp.bat file after installing XAMPP so that all the correct paths will be set? - readme_en.txt


Yep, that is how I installed it initially. But out of paranoia - I've run it again. When I run it now it just says "There is nothing to do."

If I wanted to move these folders to be that default install location C:\xampp - do I need to uninstall anything? I didn't use the installer but just the setup_xampp.bat file. From what I've read I should just be able to move the files. Correct?

At this point maybe I need to try it with the installer? What do you think?

Ugh.
thejim
 
Posts: 7
Joined: 29. November 2008 02:39

Postby Sharley » 29. November 2008 05:09

Perhaps an uninstall which entails stopping all the XAMPP components including those running as a service if you have any and close the Control Panel.

Then you can simply remove the xampp folder completely.

You choice to use the installer or a zip archive.

My preference is to use the 7zip archive as I have bandwidth limitations and also I prefer to have control of the location etc that XAMPP is installed to.

First though you might like to check this in the httpd.conf file:

DocumentRoot "C:/xampp/htdocs" is the normal setting.

Yours may be:
DocumentRoot "C:/Jim/CofCS/NewCofCS/PHPWebsite/xampp/htdocs"

and this:
<Directory "C:/xampp/htdocs">
yours
<Directory "C:/Jim/CofCS/NewCofCS/PHPWebsite/xampp/htdocs">

Also stop Apache using your Control Panel then try and start Apache using the apache_start.bat file as this often give you error messages, if there are any, when trying to start Apache.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby thejim » 29. November 2008 05:10

Ok, so I:
-Copied the xampplite folder into c:\xampp (removing the "lite" part)
-Stopped IIS
-Verified port 80 is free with the port checker
-Changed apache back to port 80 (from port 8080)
-Started apache
-Verified port 80 is TAKEN by Apache
-Attempted to open http://localhost/ -nothing
-Attempted to open http://localhost/index.php - nothing

So I am pondering running the install package - but I don't expect any better results.

Are there any other debugging log files I can look to?
thejim
 
Posts: 7
Joined: 29. November 2008 02:39

Postby Sharley » 29. November 2008 05:15

You don't seem to be having much luck, Jim.

See my post above as it may be more prudent to install XAMPP again but to use the full version not the Lite version so you can then have the benefit of all the included XAMPP components.

No more debugging files that I am aware of but do try the apache_start.bat file.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby thejim » 29. November 2008 05:26

Sharley wrote:DocumentRoot "C:/xampp/htdocs" is the normal setting.

Yours may be:
DocumentRoot "C:/Jim/CofCS/NewCofCS/PHPWebsite/xampp/htdocs"


Oh, good catch - I did have the old locations. But I'm afraid it still didn't work.

I'm going to try the installer.... ugh. I will post again after I try...
thejim
 
Posts: 7
Joined: 29. November 2008 02:39

Didn't work...

Postby thejim » 29. November 2008 05:58

No Joy.

I completely deleted the xampp folder and installed via the installer. But still no luck.

The port checker does say that Apache has hold of port 80 and 443 now - IIS has long been turned off.

But localhost and 127.0.0.1 don't respond with any information. The error.log file does show it started up.

I stopped apache and changed the listen from :80 to:
*:80
and 0.0.0.0:80
Neither worked.

I shouldn't need to reboot should I? I guess that's the last item on the list to try unless someone's got a better idea?
thejim
 
Posts: 7
Joined: 29. November 2008 02:39

Postby Sharley » 29. November 2008 06:05

This is strange indeed.

There is no need to reboot because no entries in the registry are added.

Check in:
C:\WINDOWS\system32\drivers\etc\HOSTS file by dragging it into your text editor and make sure the first uncommented line is:
127.0.0.1 localhost
If not add the line and save the file and try again.

Also a little tip is to empty your browser's cache from time to time when working at localhost level.

You don't have a virus scanner running or a firewall perhaps? - disable both temporarily if running.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby thejim » 29. November 2008 18:25

Sharley wrote:This is strange indeed.


Sometimes it's fun to be strange. Not now. But sometimes. :?

Sharley wrote:There is no need to reboot because no entries in the registry are added.


I had the same thought - but still rebooted. No joy.

Sharley wrote:Check in:
C:\WINDOWS\system32\drivers\etc\HOSTS file by dragging it into your text editor and make sure the first uncommented line is:
127.0.0.1 localhost
If not add the line and save the file and try again.


This was already there, so I didn't mess with anything.

Sharley wrote:Also a little tip is to empty your browser's cache from time to time when working at localhost level.


Done. I'm afraid no change.

Sharley wrote:You don't have a virus scanner running or a firewall perhaps? - disable both temporarily if running.


It pretty much has to be this doesn't it? The server starts up, but the access log isn't even showing me attempt to connect. Something is interviening. They have put us all in a group where our equipment is managed the same as the peons - meaning forced firewall and antivirus that we can't disable. So at this point I'm thinking of starting up a VM where I can control the settings. Or faster would be my wife's laptop. Which is pretty funny to me if I end up having to develop anything there.

I am still willing to try any other ideas.

Sharley, you've got my massive appreciation for trying to get me further along. From one human to another, I appreciate the efforts.
thejim
 
Posts: 7
Joined: 29. November 2008 02:39

Postby Sharley » 29. November 2008 21:36

Jim, just a long shot but in your browser there is usually a network setting configuration that has a proxy bypass for localhost and it's IP address 127.0.0.1

In Firefox under Tools>Options...>Advanced>Network>Connection Settings...
In the box No Proxy for: type in localhost, 127.0.0.1

In IE (I have an old version) under Connections>LAN Settings>Proxy server there is a box to tick to Bypass proxy server for local addresses.

Not sure in other browsers but they all will have a similar setting and if your browser is auto configured for your network this may be a solution.

Also worth checking is a setting under the File menu of your browser to Work Offline - make sure that this setting is disabled.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache running but not responding

Postby shahbaz » 25. April 2011 12:59

Sherly ,

i have the same problem , and done everyting written in the above posts ,

Please Help me ... i am so much irritated :(
shahbaz
 
Posts: 4
Joined: 25. April 2011 12:57

Re: Apache running but not responding

Postby woogerboy21 » 28. April 2011 21:06

I just downloaded the newest version of xampp and am having issue's with apache listening on any address other than localhost. I have configured the listen to :81, 0.0.0.0:81 with no luck. Apache starts and if I goto 127.0.0.1:81 or localhost:81 the site comes up but if I goto the <ip>:81 i get nothing. Is something going on with this most recent release of xampp? Im going to try an older version to see if its experiencing the same issues.
woogerboy21
 
Posts: 1
Joined: 28. April 2011 21:01


Return to XAMPP for Windows

Who is online

Users browsing this forum: JJ_Tagy and 65 guests