Page 1 of 1

Localhost issue

PostPosted: 27. November 2008 21:25
by Zenko
So I've been using xampp for quite a while now I am running vista and everything has been working fine until now.

My http://localhost has been working perfect until recently...

None of my browsers will connect to my localhost except Opera. I tried with FireFox 3, ie7, Safari 3.2.x and google chrome.

These are the things I have done to my PC that might give you an idea and possible help find a solution.

-I ran winASO registery optimizer to clean my registerys
-Unistalled kaspersky and installed NOD32 anti-virus

My problem is that I can't access my localhost (http://localhost) and I have turn on all servers even reseted as well. But like I said only Opera let's me view http://localhost

Anyone have some ideas how I can fix this?

thanks in advance.

PostPosted: 27. November 2008 21:40
by Wiedmann
My problem is that I can't access my localhost (http://localhost)

error message?

PostPosted: 27. November 2008 21:46
by Zenko
I search around google and someone mention to type:
I did and is now showing my localhost...

Here are the errors I get when I try accessing http://localhost

Google chrome:
This webpage is not available.

The webpage at http://localhost/ might be temporarily down or it may have moved permanently to a new web address.

More information on this error
Below is the original error message

Error 2 (net::ERR_FAILED): Unknown error.

Connection Interrupted

The connection to the server was reset while the page was loading.

The network link was interrupted while negotiating a connection. Please try again.

Safari can’t open the page “http://localhost/”. The error was: “unknown error” (kCFErrorDomainWinSock:10054) Please choose Report Bugs to Apple from the Help menu, note the error number, and describe what you did before you saw this message.

PostPosted: 27. November 2008 22:09
by Wiedmann
Open your HOSTS file, and remove the line with "::1".

PostPosted: 28. November 2008 01:08
by Zenko

I edited my hosts file (windows vista):

removed the line "::1" and worked!

Thanks a lot for the help.

Wiedmann can you explain to me why this fix it? I always like to know the 'whys' and 'hows' just for refference.

Thanks bud!

PostPosted: 28. November 2008 10:55
by glitzi85
::1 is localhost on IPv6. So if you type localhost in your Browser (or then Vista tries to reach the IPv6 IP, Apache is only listening on IPv4 IPs.

If you want more Information about IPv6:


PostPosted: 28. November 2008 13:41
by Zenko
Great! Thanks :)