Awstats not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Awstats not working

Postby sdk1985 » 24. November 2008 21:45

I tried to install awstats following this tutorial

http://community.apachefriends.org/f/viewtopic.php?p=39563

When doing this+the stuff in the comments I am able to fire up awstats and generate some stuff (3300 things he sees).

However after that I cannot view the output.

It was suggested to go to http://YOURSERVER/cgi-bin/awstats/awstats.pl
but that one shows nothing, after a few seconds I get cannot display page from my browser.

settings:
latest Xampp
extended perl installed (from the xampp site)
mydomain.com is through virtual host on c:/xampp/htdocs/website2
The CGI-BIn is in it's original c:/xamp/cgi-bin/awstats/

How to solve?

Thanks in advance!
sdk1985
 
Posts: 3
Joined: 24. November 2008 21:36

Re: Awstats not working

Postby Sharley » 24. November 2008 23:20

The 'tutorial' you are following was created in 2004 and some things may have changed since then but I have not examined it in detail (time constraints).

It is really not the job of this forum to troubleshoot a third party script's configurations only to troubleshoot any server issues you may have.

sdk1985 wrote:extended perl installed (from the xampp site)
See this thread and if you downloaded the *.pl2 addon version then follow the advice and install the latest full version Perl addon from the SourceForge link and follow the installation instructions with regards to running the setup_xampp.bat file twice - you can install over the version you have already installed by overwriting all files.
http://community.apachefriends.org/f/viewtopic.php?t=32051

sdk1985 wrote:mydomain.com is through virtual host on c:/xampp/htdocs/website2
The CGI-BIn is in it's original c:/xamp/cgi-bin/awstats/
You can use a cgi-bin in your website2 folder by adding this line after the </Directory>line in your vhost container.
Code: Select all
ScriptAlias /cgi-bin/ "C:/xampp/htdocs/website2/cgi-bin/"

You can run a script outside the alias cgi-bin in your website2 folder, so that cgi scripts will run anywhere in the website2 folder by adding Options ExecCGI inside the <Directory> directive, for example a line similar to this:
Code: Select all
Options Indexes +FollowSymLinks Includes ExecCGI

Also you may wish to make this edit in your httpd.conf file:
Find this line:
AddHandler cgi-script .cgi
edit so it looks like this:
AddHandler cgi-script .cgi .pl
Always save the conf files after editing then restart Apache.

Check the server's error.log file, about the date and time you have issues, for any clues why you are not able to see cgi pages:
C:\xampp\apache\logs\error.log
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby sdk1985 » 25. November 2008 01:37

thanks a lot! I will try to implement your suggestions.

:D:D.
sdk1985
 
Posts: 3
Joined: 24. November 2008 21:36

Postby sdk1985 » 25. November 2008 01:54

Ok I tried it

I did use Perl 5.10.0-2.2.9-pl2, but since i'm using win2k3 rc2 I chose the installer. Does that have to run twice also? (the generation though the commandline went OK, no errors there).

I updated vhost to
<VirtualHost *:80>
ServerAdmin xxx@xx.xx
DocumentRoot c:/xampp/htdocs/website2/
ServerName xxx.mine.nu
ErrorLog logs/pcinfo-error_log
CustomLog logs/pcinfo_log common
ScriptAlias /cgi-bin/ "C:/xampp/htdocs/website2/cgi-bin/"
</VirtualHost>

Do I need to create a CGI folder in the website2 or does this just link the cgi bin to the one that came with xampp?

I also altered the Addhandler to also have .pl

I did not see CGI related erros in the error.log.

it's still not working atm. No response when I go to the awstats.pl. I do get a response when I go to a .txt file in the cgi-bin/awstats it says, internal error 500.
sdk1985
 
Posts: 3
Joined: 24. November 2008 21:36


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests