error FF

Problems with the Windows version of XAMPP, questions, comments, and anything related.

error FF

Postby maryum » 21. November 2008 08:32

hi

i m receiving error FF in MercuryC SMTP client(relay version)

using smtp.gmail.com as host.

i have increased the TCP/IP timeout to 600 but still receive the same error, also enabled session logging, session log file displays the following error

03:51:23.765: --- Thu Nov 20 03:51:23 2008 ---
03:51:23.796: Connect to 'smtp.gmail.com', timeout 600.
03:51:25.078: 2: Bad address "smtp.gmail.com"

can anyone help me in solving this problem

thnx
maryum
 
Posts: 4
Joined: 19. November 2008 10:25

Postby Sharley » 21. November 2008 22:33

I can't add much more than the replies you are receiving from here:
http://community.pmail.com/forums/13434/ShowThread.aspx

Although I am not sure if GMail will accept email from localhost, but it's only a guess, as some spammers use localhost and it's one method of preventing spam if localhost is blocked. Most email clients don't use localhost - try using your computer's IP or domain name instead of localhost.

Can you collect your mail using Mercury Mail?

Possible help here and here

Please post back here if you find a solution that it may help other forum members with a similar issue - thanks and good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Solution of the prob

Postby maryum » 22. November 2008 08:44

thnx sherly for ur concern

here is the complete method if anyone want to send mail to a real address can chk this
it works fine

i m working in mercury/32, v4.52

i have used SMTP services of gmail for sending mail

just keep in mind a couple of things
*there is not any firewall that is blocking ur access to ports
*in command prompt ping smtp.google.com to chek if ur internet connection is fine
*in mercury/32 postmaster exists as a localuser, if not create that user, by default it is created

start services of mercury in Xampp control pannel an click admin

1-disable follwoing in mercury protocole module
i) mercurryB http Webserver
ii) mercury IMAP4rev serve
and enable mercuryC SMTP relay client
stop mercury services and start again

2- In mercury core module
general tab change the following
internet name for this system->localhost
uncheck all the checkboxws below accept "send copies off all the error to

postmaster"

in local domian tab
add new domain with
localhost or server->localhost
internet name->localhost

3- in mercuryS SMTP Server
general tab
announce myself as ->MABZI(any name of ur choice)
IP interface to use->127.0.0.1
connection control tab
click add restriction
ip range from->127.0.0.1
allow connections and ok
in check boxes below
uncheck all accept Authenticated SMTP connections may relay mail and ok

4-in mercuryP POP3 Server
general tab
ip interface to use -> 127.0.0.1
listen on TCP port -> 110
connection control tab
click add restriction
ip range from->127.0.0.1
allow connections and ok
5-MercuryC SMTP client

i m using gmail SMTP to send mail it works fine

smart host name->smtp.gmail.com
connection port/type->(465)(SSL encryption using direct connection)
login username and password -> (ur email address of gmail an its pasword

write the comlete address as abc@gmail.com)
session logging enabled

6- there are some changes we have to make in php.ini this file will be in

..\xampp\apache\bin\php.ini
here update the following information
SMTP = localhost
smtp_port = 25
sendmail_from = postmaster@localhost

7- now to send mail in mercury/32 window click file->send a mail message and send mail to

any email address for any error chk session log file

hope it will help
maryum
 
Posts: 4
Joined: 19. November 2008 10:25

Postby Sharley » 22. November 2008 09:49

Thanks merryone, ;) I am sure that your post will help someone who is struggling with MercuryMail.

I will save a link to your thread and let others know if the question is asked in the future - well done and thanks again for posting back.



BTW, for others who have similar issues with original post error message Error FF - Bad address "smtp.gmail.com" it would appear that a firewall could contribute to this issue by blocking access ports between MercuryC and the relay host - see PMail Forum link in my first reply above.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: error FF

Postby madbohem » 28. February 2009 22:48

Thanks.

Seriously.
madbohem
 
Posts: 1
Joined: 28. February 2009 22:45


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests