Trouble with Perl addon

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Trouble with Perl addon

Postby tryin_to_learn » 05. November 2008 19:47

I tried adding the Perl component to my existing XAMPP (v 1.6.2, I think). Couldn't get it to work, so I uninstalled my existing version of XAMPP and installed the latest version. I'm still not getting Perl to work - for example, entering

http://localhost/perl/perlinfo.pl

throws a 404 message. (This is the same thing that had happened before.)

Also, when I was installing the new version of XAMPP, I got quite a few error messages (maybe 5 - 10). I copied some of them:

Error opening file for writing:
xampp\mysql\bin\mysqld.exe

Then the same message for these two files plus a handful of others that I didn't copy:

xampp\mysql\bin\columns_priv.MYD
xampp\mysql\bin\columns_priv.MYI

I just hit "Ignore" on all of these error messages and continued with the installation.

I also got the message that it couldn't install MySQL as a service because Port 3306 was already in use.

So questions are:

1. Do I need to be concerned about those files that were skipped or is the only problem that I have to start MySQL manually since the the service failed to install?

2. If I need to be concerned, how do I fix it?

3. Why am I having trouble getting Perl to run?

Btw, I'm pretty inexperienced with all of this so simple explanations will be much appreciated. :)
tryin_to_learn
 
Posts: 54
Joined: 18. January 2007 16:04

Postby Wiedmann » 05. November 2008 22:35

1. Do I need to be concerned about those files that were skipped or is the only problem that I have to start MySQL manually since the the service failed to install?

You can't replace files from a runing MySQL server (because they are in use). Also you can't start a running MySQL server a second time.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tryin_to_learn » 06. November 2008 00:01

Wiedmann wrote:You can't replace files from a runing MySQL server (because they are in use). Also you can't start a running MySQL server a second time.


It seems to be working OK. In the console, MySQL is listed as running - just not as a service. So - ok, right?
tryin_to_learn
 
Posts: 54
Joined: 18. January 2007 16:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests