Cannot login to locahost when not connected to internet

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cannot login to locahost when not connected to internet

Postby Chuck1971 » 30. October 2008 15:51

I am using Windows XP Professional SP2 and I connected XAMPP and configured it and set up my website without any problems, however when I disconnect my computer from the internet, I can no longer access my site using localhost or through the ip address. I get an error saying that the page cannot be found, but when I plug back in the ol' internet cable, everything works fine. Does anyone have any idea why it is doing this and how I can remedy the situation so I can work on my site offline?

Please advise, I am in dire need of some help here. So far I absolutely love XAMPP. This is the only major issue I've had thus far.

Thanks in advance so much for all the help!

Sincerely-
Charles Carter
Chuck1971
 
Posts: 5
Joined: 30. October 2008 15:44

Postby spencerp » 05. November 2008 04:23

Hey Chuck, I'm having the exact same problem as you are. I'm not sure what's going on either, Xampp used to work fine for me. It only works when I'm connected to the internet, but once I'm logged offline it don't work.

Also, there always seems to be a cache sticking issue or something. Every time I refresh the page, the same stuff still shows up for what I'm working on. I'm not sure why that is either. I have Firefox 3 going in case someone needs to know this. Any help or suggestions please?
spencerp
 
Posts: 7
Joined: 05. November 2008 04:20

Postby Chuck1971 » 05. November 2008 04:56

I solved the issue by setting up a proxy server.

On Firefox you can go into Tools, click on Options and go to the Network tab. There you will see "Connections", click the "Settings" button beside it and click "Automatic Proxy Configuration URL". In the field, put "http://localhost/". That should allow you to work offline in xampp on Firefox.

On IE, go to Tools, Internet Options, and click Connections tab. Click "LAN Settings" button and check the "Proxy Server" check box. Leave the "Bypass..." check box unchecked, and put "127.0.0.1;localhost" in the Address field and set the Port to "80". Check and uncheck the "Proxy Server" check box when you need to work online or want to work on the site offline using IE.

Just a warning, make sure you code is TIGHT. Unix is so much more forgiving than Windows in regard to php code. Ensure every variable is defined. One undefined variable can wreak havoc in Windows whereas it will work fine in Unix. For example, $error or $action variables do not necessarily have to be defined in Unix when you INSERT an entry into the database for it to work flawlessly, but leaving them undefined can crash a page in Windows. Why? No clue.

Good luck, hope this works for you. If you have any more questions, let me know! :)
Chuck1971
 
Posts: 5
Joined: 30. October 2008 15:44

Postby thirdeie » 06. November 2008 10:46

It doesnt work for me. I'm having this problem on my HP notebook, but i didnt had it on desktop. Can this be a problem?
thirdeie
 
Posts: 14
Joined: 06. November 2008 10:27

Postby thirdeie » 06. November 2008 11:17

It connects through ip adress, but doesnt work with 127.0.0.1 or localhost, although I did the setting for each browser. :?:
thirdeie
 
Posts: 14
Joined: 06. November 2008 10:27

Postby Sharley » 06. November 2008 11:24

You can only use http://127.0.0.1 and http://localhost on the machine that XAMPP is installed on.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby thirdeie » 06. November 2008 12:31

Sharley wrote:You can only use http://127.0.0.1 and http://localhost on the machine that XAMPP is installed on.


Wow.Didnt know that. Of course i used http://127.0.0.1 or http://localhost, but it doesnt work, it works with http://198.12.1.82 (my ip, an example). But i want to acces it offline.
thirdeie
 
Posts: 14
Joined: 06. November 2008 10:27

Postby Sharley » 06. November 2008 13:25

Maybe your router is not configured as you would like.

This thread has a picture of a Belkin router configuration that might give some clues.
http://community.apachefriends.org/f/viewtopic.php?t=31773

Here is a link to a port forwarding site that has most routers and how to configure them.
http://portforward.com/

A link to a piece of freeware that purports to help configure routers.
http://www.pcwintech.com/node/8
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby thirdeie » 06. November 2008 14:46

Sharley wrote:Maybe your router is not configured as you would like.

This thread has a picture of a Belkin router configuration that might give some clues.
http://community.apachefriends.org/f/viewtopic.php?t=31773

Here is a link to a port forwarding site that has most routers and how to configure them.
http://portforward.com/

A link to a piece of freeware that purports to help configure routers.
http://www.pcwintech.com/node/8


is not about that. ive worked on desktop and i had no problems with xamp. i just want to use it offline with localhost or 127.0.0.1. im sure there is a blocked port or something like that. wait 4 a reply. 10x
thirdeie
 
Posts: 14
Joined: 06. November 2008 10:27

Postby Chuck1971 » 06. November 2008 15:16

Hmmmmmm......I had no such issue as http://localhost/ or http://127.0.0.1 is the default configuration of xampp and it worked fine for me once I set up a proxy server.

This is going to sound stupid, but go to the XAMPP Control Panel and ensure everything is running. Stupid question #2, how many and what operating systems are you running on your laptop, and if it is the Pro Version of Windows, is IIS enabled? One last thing, where is the xampp folder located?
Chuck1971
 
Posts: 5
Joined: 30. October 2008 15:44

Postby thirdeie » 06. November 2008 15:40

Chuck1971 wrote:Hmmmmmm......I had no such issue as http://localhost/ or http://127.0.0.1 is the default configuration of xampp and it worked fine for me once I set up a proxy server.

This is going to sound stupid, but go to the XAMPP Control Panel and ensure everything is running. Stupid question #2, how many and what operating systems are you running on your laptop, and if it is the Pro Version of Windows, is IIS enabled? One last thing, where is the xampp folder located?


So:
1.same windows on desktop and laptop, but on laptop doesnt work
2.same install on desktop and laptop, but laptop doesnt work

except throug ip
I dont know if i had modify something about this in windows but i dont want to format it
Is there a bios setup for this?

I have an HP 530
thirdeie
 
Posts: 14
Joined: 06. November 2008 10:27

Postby Chuck1971 » 06. November 2008 16:03

Not that I am aware of. The only thing I can think of, if it works on one but no the other is:

1-Cross Check all settings on computers and in xampp
2-uninstall and reinstall and start from Ground 0 and see if there was something corrupted in the download or unpackaging
Chuck1971
 
Posts: 5
Joined: 30. October 2008 15:44


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests