Problem with DBD::mysql

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with DBD::mysql

Postby algemy » 29. October 2008 18:19

Hi!

I have such code:

...
use DBI;

$data_source="dbi:mysql:mine_db";
$dbh = DBI->connect($data_source,"root","") or die "Can't connect to $data_source $DBI::errstr";
$dbh->disconnect();

When I launch such code in browser, the window appears with such message: "Apache HTTP Server has encountered a problem and needs to close. We are sorry for the inconvenience. ..."

The message in apache\logs\error file is:

[Wed Oct 29 19:06:40 2008] [notice] Parent: child process exited with status 3221225477 -- Restarting.
[Wed Oct 29 19:07:02 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations
[Wed Oct 29 19:07:02 2008] [notice] Server built: Jun 14 2008 19:02:12
[Wed Oct 29 19:07:02 2008] [notice] Parent: Created child process 1368
[Wed Oct 29 19:07:07 2008] [notice] Child 1368: Child process is running
[Wed Oct 29 19:07:07 2008] [notice] Child 1368: Acquired the start mutex.
[Wed Oct 29 19:07:07 2008] [notice] Child 1368: Starting 250 worker threads.
[Wed Oct 29 19:07:07 2008] [notice] Child 1368: Starting thread to listen on port 80.
[Wed Oct 29 19:07:07 2008] [notice] Child 1368: Starting thread to listen on port 443.

This code doesn't work with XAMPP 1.6.7 and XAMPP 1.6.8, but it worked with XAMPP 1.6.6 and everything was OK there.

And if I write just

use DBD::mysql;

I'll got the same errors. I guess there ir something with this mysql driver.

Can someone suppose what could be the problem here?
algemy
 
Posts: 2
Joined: 29. October 2008 17:57

Postby algemy » 31. October 2008 17:15

I'd tried the same code on the other computer with xampp 1.6.7. installed on and got such error message:

install_driver(mysql) failed: Attempt to reload DBD/mysql.pm aborted. Compilation failed in require at (eval 49) line 3. at (eval 47) line 12

Could Perl 5.10.x be the reason?
algemy
 
Posts: 2
Joined: 29. October 2008 17:57


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 79 guests