Unable to Access Webserver

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Unable to Access Webserver

Postby Keyoo » 27. October 2008 05:11

Hello,

I'm having some issues with my web server. I have XAMPP installed, and it seems to be running fine.


My issue comes that I can not connect to my server from an external IP without using a proxy site(Such as http://fire-proxy.com/). It gives a "This page cannot be displayed." error. However, whenever I try to to connect to it through a proxy site I'm able to connect with no issues at all.

I am able to connect to it from within my network using its internal IP just fine, just can't connect to it externally for some reason.

Any suggestions?

The site is keyoo.fw.nu/forum
Keyoo
 
Posts: 2
Joined: 27. October 2008 05:06

Postby Sharley » 27. October 2008 05:24

keyoo.fw.nu/forum - works fine and loads as intended from where I sit.

keyoo.fw.nu/ - requires an index file (index.html or index.php) in the site's root folder to prevent directory snooping.

Why you are unable to connect from your own PC I have no knowledge of. Perhaps a firewall or a router configuration issue???
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby Keyoo » 27. October 2008 05:34

I've run XAMPP a couple other times at different times. And from that I've found out, for whatever reason, my router won't let me connect to another computer on my network using my IP.

In order to test if things are working well for other people I have relied on a couple of friends to tell me if things are working for them.

Both of them are not able to connect to it. Is this more likely a problem on their end then, instead of my own?

Thanks for the help.
Keyoo
 
Posts: 2
Joined: 27. October 2008 05:06

Postby Sharley » 27. October 2008 05:45

In light of I can connect from the Internet then one would have to assume the issue is on your friend's end or may still be partly on your end - browser cache perhaps needs emptying or an issue with ComCast Cable perhaps!!! just read some Google responses to ComCast blocks port 80.

Perhaps a firewall or a router configuration issue or perhaps even your Windows HOSTS file settings on your network PCs need to be checked and configured correctly. ???

You should do a Google for your router port forwarding configuration settings...
http://portforward.com/ has many router config settings.
...and try and get that to work at least.

Just found this freeware helper from pcWinTech which might be worth checking out...
Simple Port Forwarding was designed to make forwarding ports on your router as easy as a few clicks.

The program works by automating the process for you. So whether you don't understand how to forward ports, or you're simply looking for an easier way of doing things then this program is for you.
...Simple Port Forwarding v.2.0.3

You should be able to connect to your server from your own PC using a URI in your browser because your request goes first to your ISP for a DNS lookup of the domain's IP address then back into your PC, presumably through your router.

You can connect to http://localhost I assume?

Did you setup a virtualhost in the .\xampp\apache\conf\extra\httpd-vhosts.conf file?


keyoo.fw.nu = 75.73.200.238

Your Blog and Gallery are both unavailable from the Internet even though they are both in the same site root folder.

keyoo.fw.nu/blog = 192.168.0.6
keyoo.fw.nu/gallery = 192.168.0.6

So looks like a config issue somewhere on your PC and I suspect the Windows HOSTS file on all your PCs on your network, your router and/or your server/vhosts conf file.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests