Unable to access http://localhost/ address

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Unable to access http://localhost/ address

Postby sukatoa » 20. October 2008 03:15

I have already installed XAmpp successfully(without conflicts) in my machine yesterday, get stucked on how to figure this out....

The browser will only wait for the response on the local server, ( no response received )

I have already uninstall my anti-virus, disabled the firewall and my apache tomcat server.

I have read about the WWW Server ( IIS ), followed there instructions, but all of them failed to realize me....

I've attempted to modify the httpd.conf and all 80 replaced to 8080(preferrably listen) and in extra/httpd-xampp.conf, in extra/httpd-ssl.conf ( all 443 changed to 4499 ) nothing's changed... ( accessing http://localhost:8080/ still no response ) from other article

i haved checked the ports availability through the given batch file xampp-portcheck, apache.exe listens in port 80.

attempting to locate the URL http://localhost/ , the browser only wait for a response to the server, ( 0 progress ), and base on my observation, the server never respond....

@ modifying its ports, same result, no response, trying to access unknown url like http://localhost:82/ it directly response that unable to connect into the remote server,

my initial conclusion would be, the installation is successful, but the server never response, ( Im not sure of this )

Anybody experiencing this kind of problem?
How can i fix this?

Any reply would be appreciated,
sukatoa
 
Posts: 4
Joined: 20. October 2008 03:01

Postby Sharley » 20. October 2008 03:33

Try use the IP address instead of the localhost address:
http://127.0.0.1:[port number here if you set other than 80 in the httpd.conf file]

If that works then there is an IPv6 setting in the Windows HOSTS file that would need commenting out if you want the localhost address to work.

C:\Windows\system32\drivers\etc\HOSTS - drag this file into a text editor and add # to the start of the line that has the IPv6 entry:
::1 localhost
to
# ::1 localhost

Save the HOSTS file, with no extension (just as is), and try again to use URI http://localhost

If that fix works then you may want to revert your changes to the conf files back to their original settings from the backup you made before editing (or from memory if no backup created).

Entry at the top of the list of entries in the HOSTS file and above the IPv6 entry should be:
127.0.0.1 localhost
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby sukatoa » 20. October 2008 03:47

I still can't access using http://127.0.0.1/

I reinstall the XAMPP just now, successfully installed( no conflicts ), i execute them in xampp-control ( unchecked SVC checkbox for apache and mysql ).....

nothing changed, just like yesterday...

Here's the HOSTS file content

# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

127.0.0.1 localhost


Still can't access,
What should i do to this?
sukatoa
 
Posts: 4
Joined: 20. October 2008 03:01

Postby Sharley » 20. October 2008 03:55

Try this:

Go to start>Run...>Type sc delete apache 2.2
Click OK

Now try access localhost again.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby sukatoa » 20. October 2008 04:00

Same result, the browser still waiting for an unknown server, ( 0 progress ) "sc delete apache 2.2" @ run

After that event, i have stop the apache and mysql using xampp-control, accessing http://localhost/, then response "Could not connect to remote server" quickly...

What's the next step?
sukatoa
 
Posts: 4
Joined: 20. October 2008 03:01

Postby Sharley » 20. October 2008 04:09

Have you tried to empty your browser's cache in case it is trying to load an old page?

Check these settings in the httpd.conf file:
Listen *:80
ServerName localhost:80


Add this entry down at the bottom of the httpd.conf file:
Win32DisableAcceptEx

Make sure you save the httpd.conf file after editing then restart the Apache server for any changes to be recognised.

This from running my xampp-portcheck.exe - does yours look similar?

RESULT
------

Service Port Status
==============================================================================
Apache (HTTP) 80 C:\xampp\apache\bin\apache.exe
Apache (WebDAV) 81 free
Apache (HTTPS) 443 C:\xampp\apache\bin\apache.exe

MySQL 3306 C:\xampp\mysql\bin\mysqld.exe

FileZilla (FTP) 21 free
FileZilla (Admin) 14147 free

Mercury (SMTP) 25 free
Mercury (POP3) 110 free
Mercury (IMAP) 143 free

Press <Return> to continue.




Try and paste the error log entry at about the time you try and access the server:
.\xampp\apache\logs\error.log
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Postby sukatoa » 20. October 2008 04:50

HOLY SHIT.....

your a GENIUS sharley...... :)

from your advice, changing listen 80 to listen *:80 @ httpd.conf, i can now access the index.html,

here's the error.log file

[Mon Oct 20 10:38:21 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Mon Oct 20 10:38:21 2008] [notice] Server built: Jun 14 2008 19:02:12
[Mon Oct 20 10:38:21 2008] [notice] Parent: Created child process 1820
[Mon Oct 20 10:38:23 2008] [notice] Child 1820: Child process is running
[Mon Oct 20 10:38:23 2008] [notice] Child 1820: Acquired the start mutex.
[Mon Oct 20 10:38:23 2008] [notice] Child 1820: Starting 250 worker threads.
[Mon Oct 20 10:38:23 2008] [notice] Child 1820: Starting thread to listen on port 443.
[Mon Oct 20 10:38:23 2008] [notice] Child 1820: Starting thread to listen on port 80.
[Mon Oct 20 10:40:04 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Mon Oct 20 10:40:04 2008] [notice] Server built: Jun 14 2008 19:02:12
[Mon Oct 20 10:40:04 2008] [notice] Parent: Created child process 488
[Mon Oct 20 10:40:06 2008] [notice] Child 488: Child process is running
[Mon Oct 20 10:40:06 2008] [notice] Child 488: Acquired the start mutex.
[Mon Oct 20 10:40:06 2008] [notice] Child 488: Starting 250 worker threads.
[Mon Oct 20 10:40:07 2008] [notice] Child 488: Starting thread to listen on port 443.
[Mon Oct 20 10:40:07 2008] [notice] Child 488: Starting thread to listen on port 80.
[Mon Oct 20 11:04:23 2008] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Mon Oct 20 11:04:25 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Mon Oct 20 11:04:25 2008] [notice] Server built: Jun 14 2008 19:02:12
[Mon Oct 20 11:04:25 2008] [notice] Parent: Created child process 2904
[Mon Oct 20 11:04:28 2008] [notice] Child 2904: Child process is running
[Mon Oct 20 11:04:28 2008] [notice] Child 2904: Acquired the start mutex.
[Mon Oct 20 11:04:28 2008] [notice] Child 2904: Starting 250 worker threads.
[Mon Oct 20 11:04:29 2008] [notice] Child 2904: Starting thread to listen on port 443.
[Mon Oct 20 11:04:29 2008] [notice] Child 2904: Starting thread to listen on port 80.
[Mon Oct 20 11:44:59 2008] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Mon Oct 20 11:45:02 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8i mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Mon Oct 20 11:45:02 2008] [notice] Server built: Jun 14 2008 19:02:12
[Mon Oct 20 11:45:02 2008] [notice] Parent: Created child process 3620
[Mon Oct 20 11:45:02 2008] [notice] Disabled use of AcceptEx() WinSock2 API
[Mon Oct 20 11:45:05 2008] [notice] Child 3620: Child process is running
[Mon Oct 20 11:45:05 2008] [notice] Child 3620: Acquired the start mutex.
[Mon Oct 20 11:45:05 2008] [notice] Child 3620: Starting 250 worker threads.
[Mon Oct 20 11:45:05 2008] [notice] Child 3620: Listening on port 443.
[Mon Oct 20 11:45:05 2008] [notice] Child 3620: Listening on port 80.
[Mon Oct 20 11:46:10 2008] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/index


@ your prediction "RESULT", not just similar, it is absolute.....

THANK YOU VERY MUCH sharley,
sukatoa
sukatoa
 
Posts: 4
Joined: 20. October 2008 03:01

Postby w4vy » 20. October 2008 08:44

lol
Image
User avatar
w4vy
 
Posts: 153
Joined: 04. June 2008 09:58
Location: England


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests