Needs help with XAMPP and PHP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Needs help with XAMPP and PHP

Postby HomestarStunner » 11. October 2008 21:30

Hey everyone,
Here's the problem: I get a 404 Not Found error when I try to access files within the htdocs folder in my C drive.

When I type http://localhost/ in the address bar, a page that says "It works!" shows up. I tried to access http://localhost/xampp but the browser gives me a 404.

I made a new folder within the htdocs called test. I then made a simple php file that had phpinfo(); and that's it. But I got a 404.

The XAMPP control panel says that apache, mysql and filezilla are running.

My XAMPP version is 1.6.8

Can somebody shed some light for me? Thanks

EDIT: I just opened up my task manager and it looks like I'm running 2 httpd.exe files. Which that's the file to run the apache server. I think my targeting is either wrong or maybe I needed to edit a config file that I didn't realize I needed to but I'm not sure.
HomestarStunner
 
Posts: 2
Joined: 11. October 2008 21:17

Postby HomestarStunner » 12. October 2008 00:02

So I fixed it. The solution? Not being an idiot. I completely forgot that I had installed a previous Apache server at least a year ago. So when I tried edit the index.html file in the xampp folder, it was displaying the other index.html file that says "It works!".

Anyway, hope that helps someone out.
HomestarStunner
 
Posts: 2
Joined: 11. October 2008 21:17


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests