1.6.8 upgrade installs older version of phpMyAdmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

1.6.8 upgrade installs older version of phpMyAdmin

Postby MacMike » 03. October 2008 22:28

I just downloaded the 7-zip file and after applying it phpMyAdmin reported being version 2.11.9.1 instead of 2.11.9.2
MacMike
 
Posts: 3
Joined: 03. October 2008 22:24

Re: 1.6.8 upgrade installs older version of phpMyAdmin

Postby Sharley » 03. October 2008 22:56

MacMike wrote:I just downloaded the 7-zip file and after applying it phpMyAdmin reported being version 2.11.9.1 instead of 2.11.9.2

More than likely the reason for this is when the developers of XAMPP commenced compiling 1.6.8 the phpMyAdmin version was 2.11.9.1 as they usually include all the latest and greatest available at this time.

Therefore if 2.11.9.2 was released after they had commenced compiling 1.6.8 then that version of phpMyAdmin would not be included.

From commencement of a new version of XAMPP through rigid testing to the final release the period can be several weeks and so there may well be newer versions of the included components released and will, as a consequence, be included in the next version's final release.

If you want the latest and greatest phpMyAdmin version then I believe if you download and install it manually in the same location in the XAMPP tree all should be rosy for you or wait for the next release of XAMPP.

Good luck
Sharl
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: 1.6.8 upgrade installs older version of phpMyAdmin

Postby MacMike » 05. October 2008 02:35

Sharley wrote:More than likely the reason for this is when the developers of XAMPP commenced compiling 1.6.8 the phpMyAdmin version was 2.11.9.1 as they usually include all the latest and greatest available at this time.


But the download page states that it will install 2.11.9.2

http://www.apachefriends.org/en/xampp-windows.html#641

MacMike
MacMike
 
Posts: 3
Joined: 03. October 2008 22:24

Postby Sharley » 05. October 2008 08:48

...and all that glitters is not gold.

From the Change Log:
http://www.apachefriends.org/winxampp/xampp-changes.txt

25. Sept 2008 XAMPP 1.6.8
- Upgrade OpenSSL 0.9.8i
- Upgrade phpMyAdmin 2.11.9.2

15. Sept 2008 XAMPP 1.6.8 beta2
- Upgrade phpMyAdmin 2.11.9.1
- Upgrade phpMyAdmin 2.11.9


I just downloaded the 7Zip upgrade file and installed the contents which included version 2.11.9.2 of phpMyAdmin - perhaps your download version still has the older phpMyAdmin version included in which case you should try and contact a developer to let them know.

Contact XAMPP details here http://www.apachefriends.org/en/contact.html (use any of the methods other than the forum - perhaps email Oswald or use the IRC channel) and pass on your findings, it is rare a developer reads and takes any actions from posts in this English forum.

If it is any consolation, I have known this lax checking of the download archives to happen on very few rare occasions over the years - but once the problem is recognised it usually fixed in quick time.

There is also a bug reporting site here:
http://bugs.xampp.org/my_view_page.php

Good luck,
Sharl
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests