CONFIGURING APACHE TO SEND MAIL

Problems with the Windows version of XAMPP, questions, comments, and anything related.

GREAT!

Postby VEINTYUNICO » 29. September 2008 17:47

OK! IT'S FINALLY WORKING! THANKS A LOT MAN! REALLY.

NOW I GOT TO FIGURE WHERE I CONFIGURE "FROM:..." THO SOW MY EMAIL ADRESS.

BUT IT'S OK MAN. THANKS REALLY!
VEINTYUNICO
 
Posts: 28
Joined: 27. September 2008 11:57

Postby VEINTYUNICO » 29. September 2008 17:58

Where I configure my recipient's adress?
That's the error that i receive in error.log

ok. Thanks
VEINTYUNICO
 
Posts: 28
Joined: 27. September 2008 11:57

Re: CONFIGURING APACHE TO SEND MAIL

Postby yitwail » 17. December 2008 09:44

Wiedmann, thanks for great info; helped to get my config working. only difficulty was, i have 3 copies of php.ini laying around, and the third one i changed is the one that was being used. :oops:
yitwail
 
Posts: 3
Joined: 15. December 2008 19:44

Re: CONFIGURING APACHE TO SEND MAIL

Postby Sharley » 17. December 2008 09:55

yitwail wrote:Wiedmann, thanks for great info; helped to get my config working. only difficulty was, i have 3 copies of php.ini laying around, and the third one i changed is the one that was being used...
To find out which php.ini file is being used go to http://localhost and in the left menu of the Welcome page click on phpinfo() then look for this line which will give the answer:
Loaded Configuration File

It would normally be C:\xampp\apache\bin\php.ini
The above path depends on your XAMPP installation.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: CONFIGURING APACHE TO SEND MAIL

Postby yitwail » 17. December 2008 20:19

Sharley wrote:To find out which php.ini file is being used go to http://localhost and in the left menu of the Welcome page click on phpinfo() then look for this line which will give the answer:
Loaded Configuration File

It would normally be C:\xampp\apache\bin\php.ini
The above path depends on your XAMPP installation.

that's how i found the one i needed to change, which was C:\php\php.ini in my case. i suspect i have 2 php installations, because i installed php prior to installing xampp, but at this point nothing's broke so i'm not fixing to fix it anytime soon (unless i find out this is a big no-no)
yitwail
 
Posts: 3
Joined: 15. December 2008 19:44

Re: CONFIGURING APACHE TO SEND MAIL

Postby madmax765 » 28. December 2008 03:33

i had same trouble, i had mine set at smtp_port=465 too, And it would not work, canged it to 25, And it dose. Why i don't know, Cause my email acount setting it set for port 465

Now i can get mails by my web site contack page, but still cant seem to get my phpbb 3 forum to send emails, I know in it "E-mail function name:
The e-mail function used to send mails through PHP. "
And its set to mail

I konw i had to change this in php.ini file
sendmail_path = "C:\Xampp\sendmail\sendmail.exe -t"
User avatar
madmax765
 
Posts: 11
Joined: 29. February 2008 21:02
Location: U.S.

Re: CONFIGURING APACHE TO SEND MAIL

Postby Sharley » 28. December 2008 03:44

Did you configure the C:\Xampp\sendmail\sendmail.ini file after uncommenting that line in the php.ini file?

Does Xampp start with an upper case letter?

Remember that all things XAMPP are case sensitive

Do you have to tell your forum mail script to use sendmail perhaps?

This post may have some useful info too:
http://community.apachefriends.org/f/viewtopic.php?p=102182#p102182

BTW you should only use one method not both - if you use sendmail then comment out the smtp part in the php.ini file and vise versa.

More here:
http://www.dokuwiki.org/tips:mailconfig

And here:
Configuring PHP under Windows to use Gmail or External SMTP Server [SSL]
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests