CONFIGURING APACHE TO SEND MAIL

Problems with the Windows version of XAMPP, questions, comments, and anything related.

CONFIGURING APACHE TO SEND MAIL

Postby VEINTYUNICO » 27. September 2008 12:10

Hello! I just set the file "php.ini" from the folder "C:\XAMPP\APACHE\BIN" with the following configuration:

[mail function]
; For Win32 only.
SMTP = (my smtp server)
smtp_port = 25

; For Win32 only.
sendmail_from = (my email adress)

But, when a try to send an email from a page with "mail()", i dont get any error, so i figure that everything its ok. But i dont get any email!!! Help!?
VEINTYUNICO
 
Posts: 28
Joined: 27. September 2008 11:57

Postby Wiedmann » 27. September 2008 12:11

Does your SMTP server work without authentification?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby VEINTYUNICO » 27. September 2008 14:37

YES IT NEED AN AUTHENTICATION. HOW I CONFIGURE IT?


THNKS MAN.
VEINTYUNICO
 
Posts: 28
Joined: 27. September 2008 11:57

Postby Wiedmann » 28. September 2008 10:21

Configure PHP to use "sendmail" (in php.ini) and configure sendmail (in sendmail.ini)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

OK!

Postby VEINTYUNICO » 28. September 2008 16:28

It works, but now when i run the web page, i get this message

Warning: mail() [function.mail]: SMTP server response: 550 5.7.1 Hello [190.16.14.22], Policy rejection on the target address: <elunico_jose@hotmail.com>

The email adress it's Ok, the smtp direction and the authetincation also.
What can it be!?
VEINTYUNICO
 
Posts: 28
Joined: 27. September 2008 11:57

Postby Wiedmann » 28. September 2008 16:34

Warning: mail() [function.mail]: SMTP server response:

PHP is not using sendmail.

the smtp direction and the authetincation also.

:?:
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby VEINTYUNICO » 28. September 2008 16:46

Oh man, you probably hate me at this point. Now i get this error:

Failed to connect to mailserver at "smtp.mail.yahoo.com.ar" port 465, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set().
VEINTYUNICO
 
Posts: 28
Joined: 27. September 2008 11:57

Postby Wiedmann » 28. September 2008 16:51

Failed to connect to mailserver at "smtp.mail.yahoo.com.ar" port 465,

That's the same: PHP is not using sendmail.

Maybe you should explain, what you have changed in "php.ini" and "sendmail.ini".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

What I change in php.ini and sendmail.ini

Postby VEINTYUNICO » 29. September 2008 00:46

I CHANGE THIS LINE IN PHP.INI
[mail function]
; For Win32 only.
SMTP=smtp.mail.yahoo.com.ar
smtp_port=465

; For Win32 only.
sendmail_from = jicarpanzano@yahoo.com.ar

AND THIS LINE IN SENDMAIL.INI

smtp_server=smtp.mail.yahoo.com.ar

; smtp port (normally 25)

smtp_port=465

----- -----

; if your smtp server requires authentication, modify the following two lines

auth_username="my username"
auth_password="my password"

do i have to copy sendmail.exe and sendmail.ini to another directory!?
VEINTYUNICO
 
Posts: 28
Joined: 27. September 2008 11:57

Postby Wiedmann » 29. September 2008 06:43

I CHANGE THIS LINE IN PHP.INI

You have to change this line:
Code: Select all
;sendmail_path = "C:\xampp\sendmail\sendmail.exe -t"

to:
Code: Select all
sendmail_path = "C:\xampp\sendmail\sendmail.exe -t"


AND THIS LINE IN SENDMAIL.INI

Most times it's a good idea to use this line too:
Code: Select all
force_sender=jicarpanzano@yahoo.com.ar
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

OK!

Postby VEINTYUNICO » 29. September 2008 10:21

Ok I changed it and i dont get any error. Seems to be working
But, also aint receiving any mail.

Thank you
VEINTYUNICO
 
Posts: 28
Joined: 27. September 2008 11:57

Postby Wiedmann » 29. September 2008 10:47

i dont get any error. Seems to be working
But, also aint receiving any mail.

In "sendmail.ini" you can also enable a debug and error log.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

OK!

Postby VEINTYUNICO » 29. September 2008 17:02

This is what I get in "sendmail/error.log"

08/09/29 12:59:49 : Socket Error # 10054<EOL>Connection reset by peer.
VEINTYUNICO
 
Posts: 28
Joined: 27. September 2008 11:57

Postby Wiedmann » 29. September 2008 17:13

This is what I get in "sendmail/error.log"

That's the complete error/debug.log?

Code: Select all
smtp_port=465

You are sure with this port?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby VEINTYUNICO » 29. September 2008 17:36

That's the port that yahoo give me.
Maybe If i try with 25...

Thanks man.
VEINTYUNICO
 
Posts: 28
Joined: 27. September 2008 11:57

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 22 guests