Help Understanding the XAMPP Controlk Panel

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Help Understanding the XAMPP Controlk Panel

Postby esimuro » 26. September 2008 01:51

I just loaded XAMPP to run Apache MySql PHP and Perl on a windows Vista sp1 system. After much trial and error I finally got Apache to run and the control panel shows it as running. MySql however is another story, if I look at the control panel it claims that MySql is not running but when I run the mysql_start.bat it appears that it ios running. I get the follow in the cmd window:

Diese Eingabeforderung nicht waehrend des Running beenden
Please dont close Window while MySQL is running MySQL is trying to start
Please wait ...
MySQL is starting with mysql\bin\my.cnf (console)
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
080925 15:56:15 InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
080925 15:56:15 InnoDB: Started; log sequence number 0 43655
080925 15:56:17 [Note] mysql\bin\mysqld: ready for connections.
Version: '5.0.51b-community' socket: '' port: 3306 MySQL Community Edition (G PL)

Running phpMyAdmin and I find that it believes that MySql is running, what am I missing here to get the control panel to reflect what the bat file and phpmyadmin are telling me?
Posts: 4
Joined: 25. September 2008 14:08

Postby esimuro » 26. September 2008 02:12

Well it appears that the problem was Vista security bitting me in the butt by failing without giving an errors, It appears that in the install xampp attempted to copy mysqld-nt to the root directory, this failed because you need supervisor privileges to write to the root directory but it never produced an error message or at least one that purclatted to the user interface. Once I copied the file from \xampp\mysql\bin to the root directory everything started working.
Posts: 4
Joined: 25. September 2008 14:08

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 70 guests