Xampp control panel

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp control panel

Postby jrws » 23. September 2008 08:51

Hey guys,
This is the problem, I can no longer for some reason use the Xampp control panel. It gives the error message:
ERROR: Apache service not started[-1]

And the same for mysql. And sometimes when I start it manually it doesn't work... So uh yeah, ports are clear, SP2 WinXP... Thats all the info you need I guess if not just ask, and I will try to provide.
jrws
 
Posts: 5
Joined: 23. September 2008 08:48

Postby Wiedmann » 23. September 2008 09:13

ERROR: Apache service not started[-1]

Look into the Windows event log (System/Applications) for a detailed error message.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jrws » 24. September 2008 07:46

I have and I cannot really find any good details all it says is the IIS sever didn't start, what does that mean? Isn't that a Microsoft product?

When trying to start xmapp without the control panel with the start button heres the error message:
Could not open required defaults file: msql\bin\my.cnf
Fatal error in defaults handling. Program Aborted
jrws
 
Posts: 5
Joined: 23. September 2008 08:48

Postby Wiedmann » 24. September 2008 07:54

Could not open required defaults file: msql\bin\my.cnf

Really "msql" or "mysql"?

(Does this file exists?)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jrws » 25. September 2008 23:38

Apart from the spelling error, yes the mysql file exists.
jrws
 
Posts: 5
Joined: 23. September 2008 08:48

Postby Wiedmann » 26. September 2008 08:17

When trying to start xmapp without the control panel with the start button

Which start button do you mean ("mysql_start.bat")?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby rmadur » 09. October 2008 21:20

ERROR: Apache service not started[-1]


I am having the very same problem and untill now I didn't find no explanation for it.
rmadur
 
Posts: 2
Joined: 09. October 2008 21:11

Postby glitzi85 » 09. October 2008 21:26

@rmadur: Start xampp-portcheck.exe in the XAMPP-Directory

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby rmadur » 09. October 2008 22:41

glitzi85 wrote:@rmadur: Start xampp-portcheck.exe in the XAMPP-Directoryglitzi


Thank you but my particular problem was that the service Apache2.2 was set with a wrong path to apache.exe from a previous "Lite" installation. I got the tip here: http://www.astahost.com/apache-server-xampp-t16833.html

I ran: services.msc
Double-clicked on Apache2.2
The wrog path was there, just laughing at me :-)

To edit the Apache2.2 service:
http://www.ehow.com/how_2142503_edit-wi ... vices.html

To delete Apache2.2 service (in order to uninstall XAMPP and reinstall it):
Run: sc delete Apache2.2
Or follow the steps at: http://www.cryer.co.uk/brian/windows/howto_nt_das.htm

That's what worked for me.
Over?
rmadur
 
Posts: 2
Joined: 09. October 2008 21:11

Same problem here

Postby fabicz » 07. November 2008 17:31

- Xampp control returns: Apache service not started [-1]
- Nothing in windows event log
- 80 port free
- Service can be run using windows serices -> start
- Service can be run using apache_start.bat
- Xampp directory and control are in same place

See screenshot Image
What this xampp control is actually doing behind pressing the button?

Thanks in advance
fabicz
 
Posts: 2
Joined: 07. November 2008 17:14

You said IIS?

Postby EnglishRocker » 07. November 2008 18:36

I have and I cannot really find any good details all it says is the IIS sever didn't start, what does that mean? Isn't that a Microsoft product?


You're right, Internet Information Services or IIS is a Microsoft product and it's completely incompatible with Xampp.

Look in your Control Panel > Add/Remove Programs and click the Windows Components button on the left. Find IIS and destroy.

Good luck.
EnglishRocker
 
Posts: 25
Joined: 12. September 2008 11:07


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests