Page 1 of 1

Problem with port 80 or 443 on XP, SP3, Firewall Disabled

PostPosted: 16. September 2008 15:55
by vikkib
Hi all,

I have downloaded v 1.6.7 installer for windows and I am trying to install it on a machine running XP Home Edition with SP3, 2002 Version.

I get an error that ports 80 or 443 SSL are not available.

I have looked through the FAQ and have disabled the microsoft firewall (start, control panel, security centre). I have downloaded the installer again, uninstalled everything, removed the services and re-started the PC to have a fresh go after disbaling the firewall and I still get the same error. I have double checked and the firewall is still disabled.

Has anyone got any ideas? I have installed xampp on my home PC (vista) with no problems and after raving about J 1.5 I am dying to get to work on developing a new J 1.5 site for my Dad's business!

Many thanks for reading,

Vikki

PostPosted: 16. September 2008 16:06
by Wiedmann
Use a tool like xampp-portcheck or netstat and find the program which is using the ports 80/443. Stop this program and you can use XAMPP/Apache.

PostPosted: 16. September 2008 17:26
by vikkib
Many thanks for the info, Wiedmann.

I will try that when I am next at my parent's in a couple of days.

Vikki

PostPosted: 18. September 2008 10:03
by vikkib
Riiiight...

Port 443 is being used by aoltpspd.exe

I've located the file but I'm not sure how to change the port being used.

Is it possible to change the port that apache uses? IF so, could someone let me know how to go about it and what would be suitable alternative? (apologies - I have no experience with this!)

Many thanks for reading,

Vikki

PostPosted: 18. September 2008 15:40
by glitzi85
To disable SSL (=Port 443) just open the httpd.conf (xampp\apache\conf) and search for this Line:

Code: Select all
# Secure (SSL/TLS) connections
Include conf/extra/httpd-ssl.conf


Just put a # before the Include, save the file and start Apache. It will now use just Port 80.

glitzi

PostPosted: 18. September 2008 17:29
by vikkib
You are a star! :mrgreen:

Thank you very much!

Vikki

PostPosted: 28. September 2008 17:23
by paul1107
Hi,

I ytthoght I had the answer to my problem in this thread, but in checking ports 80 and 443 they are both taken up by C:\WINDOWS\system32\inetsrv\inetinfo.exe. as a result I can't start apache...

I'm guessing you would have to change ports?

wondered whether anyone can help me as I'm getting very frustrated

thanks

PostPosted: 28. September 2008 17:40
by Wiedmann
they are both taken up by C:\WINDOWS\system32\inetsrv\inetinfo.exe.

That's the IIS (Internet Information Service) webserver from Windows.