apache running but mysql won't

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache running but mysql won't

Postby asianmariposa » 14. September 2008 08:36

Hi! i just installed xampp today and after encountering many problems [which i really didn't know how i got through] i got it okay.... - meaning... i can run the xampp control panel

but when i tried to start mysql, an error occurs. it says that "ERROR: MySql service not started [-1]". how do i solve this? i tried to replace the original copy of httpd.conf under xampp/apache/conf but all it does is cause an error for apache... please help me... i need this to run for my project...
Newbie....
asianmariposa
 
Posts: 1
Joined: 14. September 2008 08:12
Location: Ph

Postby glitzi85 » 19. September 2008 09:48

Hi,

the httpd.conf is the configuration file for the Apache Webserver, it has absolutely nothing to do with MySQL.

Open the XAMPP folder and execute the mysql_start.bat, it will tell you what's the problem.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby pilothaz » 25. September 2008 14:38

I am having the same problem with my XAMPP now for some reason. It will start up but then automatically close on me. It was working fine before and had no problems with it.

Here is the end of the core dump from the mysql_start.bat

Code: Select all
                                              z ╞╨  ¬ ;InnoDB: End of page dump
080925  9:34:20  InnoDB: Page checksum 2396365974, prior-to-4.0.14-form checksum
 2047133392
InnoDB: stored checksum 2396365974, prior-to-4.0.14-form stored checksum 2047133
392
InnoDB: Page lsn 0 43649, low 4 bytes of lsn at page end 43649
InnoDB: Page number (if stored to page already) 0,
InnoDB: space id (if created with >= MySQL-4.1.1 and stored already) 0
080925  9:34:20 [ERROR] mysql\bin\mysqld: Got signal 11. Aborting!

080925  9:34:20 [ERROR] Aborting

080925  9:34:20 [Note] mysql\bin\mysqld: Shutdown complete


MySQL konnte nicht gestartet werden
MySQL could not be started


If there is something that can be done to get my mySQL up and running again it would be immensely appreciated.

Cheers.
Haz
pilothaz
 
Posts: 1
Joined: 25. September 2008 14:35

Postby JaCKo » 02. October 2008 09:24

Seems we have common problems.
Just installed Xampp yesterday (installer, running on XP), had some problems and am currently stuck with an InnoDB error (32).
Ran the .bat and found out that I supposedly have a program that is already using the InnoDB Engine and I therefore cannot use it for MySQL and so mysql doesn't start. Its telling me to shutdown the program using the innodb (says it may be an antivirus prog), but I haven't the faintest idea as to which prog it could be. Switched off ZoneAlarm (my firewall) to no avail, and I know NOD32 hasn't got any compatibilitiy issues, or does it?

Haven't found anything similar on the forums. Any ideas?

Here's another post with the same problem:
http://community.apachefriends.org/f/viewtopi ... ql+running

Thanks!
JaCKo
 
Posts: 7
Joined: 02. October 2008 09:07

Postby JaCKo » 02. October 2008 19:00

Have found out something, but not everything, because it still doesn't run!

So, I have an HP laptop with HP software that came with it. Among the software are also a Mobile protection system and protect tools security manager. I turn these off through msconfig/startup and I run the mysql bat. I don't get the error 32, but the thing just hangs forever. This is what comes up:
Mysql is starting with mysql/bin/my.cnf (console)
081002 19:45:14 InnoDB: started; log sequence number 0 43655
081002 19:45:14 [Note] mysql/bin/mysqld: ready for connections.
Version: '5.0.67-community' socket: ' 'port: 3306 Mysql Community edtition (GPL)


I know I'm supposed to wait a while the first time it starts up, but its been hanging for 15 minutes now, seems like a lot.
JaCKo
 
Posts: 7
Joined: 02. October 2008 09:07

Postby Wiedmann » 02. October 2008 20:24

081002 19:45:14 [Note] mysql/bin/mysqld: ready for connections.

That looks OK and you can use MySQL.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby JaCKo » 03. October 2008 07:35

No! Thats the thing - it hangs there, it never actually gets running!! I can't use a thing. Localhost gets running, but when I want to use say phpmyadmin, it say the server is not responding.
When I run the bat file, the start window opens but never goes away - I have to run the stop bat for the window to close and while its open there is no change in the control panel.

So it says its going to start, but never does. Apache runs fine though.

HELP!
JaCKo
 
Posts: 7
Joined: 02. October 2008 09:07

Postby JaCKo » 03. October 2008 08:47

Couldn't wait, so I decided to reinstall xampp with the installer - no change.
Then I downloaded the purist .zip version.

I had trouble at first because I cannot delete the existing xampp files (closed apache and mysql before I started) - access is denied for some reason. I (as a newbie would) fixed it by moving the files and folders about on my computer - didn't work at first, but I kept persisting and got most of them out of the folder, but could still not delete them on their new locations - no idea what happened and why access was denied for most of the time, then suddenly I could move the files ??!!
Had to move the files though because it wouldn't unpack otherwise - access was denied (of course) I had to overwrite the existing files.

Anyway, I unpacked the .zip version and installed the services and voila!! It just started to work!

I swear I think these computers of ours have their own mind sometimes!

Thanks for all the help in solving this problem, would very much appreciate any help concerning the problem/issue of deleting the old xampp files on my computer - I have them tucked away safely, but I hate having space taken up for no good reason.

Thank you!
JaCKo
 
Posts: 7
Joined: 02. October 2008 09:07

Postby Sharley » 03. October 2008 11:47

See if there is anything in this post that might help with your issues:
http://community.apachefriends.org/f/viewtopi ... 772#113772

Good luck.
Sharl
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests