Desperate For Help! Localhost problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Desperate For Help! Localhost problem

Postby vickiwatson » 03. September 2008 02:47

I am willing to pay anyone that can help me get Xampp working on my system.

I think I have tried everything I've seen suggested and am still not able to access localhost on my computer.

I installed this version: xampp-win32-1.6.7-installer.exe

My system is XP sp3

In httpd.conf I have:
ServerRoot "C:/xampp/apache"
Listen *:80

In my windows hosts file I have:
127.0.0.1 localhost

When I start the Xampp control panel and click Start on Apache, it shows the green text that says "Running" and says it is started on Port 80.

When I run xampp-portcheck.exe it shows Apache running on port 80

When I type either of the following into the browser, IE or Firefox, it continually shows the loading icon, but never loads anything. It does not display an error either, just nothing.

http://localhost
http://127.0.0.1

I do have an index.php file in the directory C:\xampp\htdocs

When I run netstat -ab I see 2 entries for apache.exe

Proto Local Address Foreign Address State PID
TCP vwdesktop:http vwdesktop:0 LISTENING 7536
TCP vwdesktop:https vwdesktop:0 LISTENING 7536

Should those say 80 instead of 0?

Also I have disabled firewall and it does not make any difference.

Any suggestions would be greatly appreciated!
vickiwatson
 
Posts: 2
Joined: 03. September 2008 02:30

Postby Wiedmann » 03. September 2008 09:58

When I type either of the following into the browser, IE or Firefox, it continually shows the loading icon, but never loads anything.

Add "Win32DisableAcceptEx" to your "httpd.conf".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Desperate For Help! Localhost problem

Postby glitzi85 » 03. September 2008 12:24

In addition to Wiedmann's Post:

vickiwatson wrote:ServerRoot "C:/xampp/apache"

vickiwatson wrote:I do have an index.php file in the directory C:\xampp\htdocs

:?:

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Wiedmann » 03. September 2008 12:33

In addition to Wiedmann's Post:

ServerRoot != DocumentRoot
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby glitzi85 » 03. September 2008 13:46

ich bräucht jetzt das *kopfgegendiewandschlag*-Smiley von deepsurfer...
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

It worked!

Postby vickiwatson » 03. September 2008 16:38

Awesome! adding the Win32DisableAcceptEx line to httpd.conf worked.

Okay, now who do I send the check to?? :D

Thanks!


Wiedmann wrote:
When I type either of the following into the browser, IE or Firefox, it continually shows the loading icon, but never loads anything.

Add "Win32DisableAcceptEx" to your "httpd.conf".
vickiwatson
 
Posts: 2
Joined: 03. September 2008 02:30


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests