little problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

little problem

Postby tetris » 02. September 2008 12:52

hello

i am using a Webuilder as my prog for editing html pages, webuilder is just an editor.

i have configured webuilder to preview php by pointing to the php.exe(a feature that webuilder has), it works fine but:
if i got this simple code(a url query)

first file(this one doesnt need php extension has there is no php in it)(excerpt):

Code: Select all
<body>
<p><a href="welcome1.php?name=Kevin">Hi, I'm Kevin!</a></p>
</body>


it calls this file wich needs the php extension(has there is php code in it)(excerpt):
Code: Select all
<body>
<p><?php $name = $_GET['name'];
echo "Welcome to our Web site, $name!";?></p>
</body>


the problem is i need to change the extension of the first file to php to make this link query work, it is strange as this file doesnt hold php code hence it wouldnt need a php extension,?.(all of this running in my preview php in webuilder editor).


my other question is: if i run this same query on firefox on my machine wich has xampp installed souldnt it work?? when i press the link i get a blank page...
tetris
 
Posts: 16
Joined: 06. January 2008 14:48

Postby Wiedmann » 02. September 2008 13:19

the problem is i need to change the extension of the first file to php to make this link query work, it is strange as this file doesnt hold php code hence it wouldnt need a php extension,?.(all of this running in my preview php in webuilder editor).

This question you must ask the WebBuilder support.

my other question is: if i run this same query on firefox on my machine wich has xampp installed souldnt it work?? when i press the link i get a blank page...

How did you load the first page in Firefox exactly?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tetris » 02. September 2008 13:27

I just double click the file to open it.
tetris
 
Posts: 16
Joined: 06. January 2008 14:48

Postby Wiedmann » 02. September 2008 13:43

I just double click the file to open it.

This does not work with .php-files.

You must open .php-files through the webserver: "http://localhost/..."
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tetris » 02. September 2008 13:57

ok, in wich directory do i need to put the file so they can be view by localhost?

this; http://localhost/xampp/welcome4.html doesnt work,

neither this; http://localhost/welcome4.html
assuming i put the welcome4.html file in the xampp directory
tetris
 
Posts: 16
Joined: 06. January 2008 14:48

Postby w4vy » 02. September 2008 14:22

xampp/htdocs/
Image
User avatar
w4vy
 
Posts: 153
Joined: 04. June 2008 09:58
Location: England

Postby tetris » 02. September 2008 17:29

hi
i've put this path:
http://localhost/xampp/htdocs/welcome1.php

and it does not work(error 404)
tetris
 
Posts: 16
Joined: 06. January 2008 14:48

Postby w4vy » 03. September 2008 00:47

is php running and do you have any htaccess files in that directory ?
Image
User avatar
w4vy
 
Posts: 153
Joined: 04. June 2008 09:58
Location: England

Postby tetris » 03. September 2008 06:37

the status of php says 'activated' and no there is no htaccess file in that folder.
tetris
 
Posts: 16
Joined: 06. January 2008 14:48

Postby tetris » 03. September 2008 06:47

ok i found out

you put file in htdocs directory

but you call them trhu: http://localhost/yourwebpage.*
tetris
 
Posts: 16
Joined: 06. January 2008 14:48


Return to XAMPP for Windows

Who is online

Users browsing this forum: ben.mansuk, JJ_Tagy and 58 guests