I dont think php is working. or mysql

Problems with the Windows version of XAMPP, questions, comments, and anything related.

I dont think php is working. or mysql

Postby 2words4uready » 30. August 2008 17:20

I dont think php is working. or mysql.
If i visit phpmyadmin i get
Code: Select all
Cannot load mysql extension. Please check your PHP configuration. - Documentation

If i type
Code: Select all
<?
echo "test";
?>

I get nothing but a blank page
if i visit some of the xampp pages i get code like this
Code: Select all
   get flash player

 

'; if($_REQUEST['showcode']!=1) { echo ''.$TEXT['global-showcode'].''; } else { if($file=="")$file=$_SERVER['PHP_SELF']; $f=htmlentities(file_get_contents(basename($file))); echo "
".$TEXT['global-sourcecode']."
"; echo "
"; echo $f; echo "
"; echo "

"; echo "

"; } ?>


Then the buttons have php code on them.
2words4uready
 
Posts: 2
Joined: 30. August 2008 17:10

Postby chili5 » 30. August 2008 17:48

I don't think you have your mysql enabled in php.ini

That's all I can think of for the first problem. Check your php.ini file in C:\xampp\php for this line:

[CODE];extension=php_mysql.dll[/CODE]

If you find that, remove the ;

As for the php error, I have no idea. Why don't you reinstall php? That would probably fix it. ?
chili5
 
Posts: 6
Joined: 01. January 2008 21:21

Postby 2words4uready » 30. August 2008 18:04

still not working
and the line you mentioned was already uncommented
2words4uready
 
Posts: 2
Joined: 30. August 2008 17:10

Postby Wiedmann » 30. August 2008 23:03

Cannot load mysql extension. Please check your PHP configuration. - Documentation

Your (XAMPP) PHP is using a wrong "php.ini".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby w4vy » 30. August 2008 23:55

The correct php.ini is inside xampp/apache/bin ok m8
Image
User avatar
w4vy
 
Posts: 153
Joined: 04. June 2008 09:58
Location: England

Re: I dont think php is working. or mysql

Postby Dave_L » 31. August 2008 21:01

2words4uready wrote:
Code: Select all
<?
echo "test";
?>


short_open_tag might not be enabled in php.ini.

Try:

Code: Select all
<?php echo "test" ?>
User avatar
Dave_L
 
Posts: 212
Joined: 23. October 2004 00:43


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests