Error log reports wrong path for starting Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error log reports wrong path for starting Apache

Postby aftecboy » 15. August 2008 15:29

I am unable to start apache. I used the installer (version win32-1.6.7), and when I attempt to start apache from the control console, It wont start. So I installed apache as a service, and went to services and manually tried to start apache. It wont start. So I checked the error logs and it tells me that it can't find the path to the apache.exe file to start apache. The path it lists is wrong.

Where can I change the path that is reported to start apache?

Also, how do I change the listening port to 8080 rather than 80?

Thanks.

aftecboy
aftecboy
 
Posts: 4
Joined: 15. August 2008 15:22

Postby glitzi85 » 15. August 2008 15:56

That should no happen, did you change anything?

Listen-Port you can change in httpd.conf, Directive is called Listen.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby aftecboy » 15. August 2008 16:14

glitzi85 wrote:That should no happen, did you change anything?

Listen-Port you can change in httpd.conf, Directive is called Listen.

glitzi



I tried to install xampp to a different directory than the default during an initial install. Apache would not start then either, saying it could not find the path to apache.exe. Thinking it was the directory path I asked it to install with, I decided to remove the installation and try again. So I uninstalled the first installation using the given tool. I shut down, restarted, and reinstalled using the default directory and settings. Now I get the old directory showing up as the path to apache.exe, but that directory doesn't exist anymore.

On the port issue, yes, I have updated the httpd.conf to listen to port 8080. But since I can't get apache to start, I can't confirm that this is working or not.

Thanks,

aftecboy
aftecboy
 
Posts: 4
Joined: 15. August 2008 15:22

Postby glitzi85 » 15. August 2008 16:22

OK, sounds like there something gone wrong. Try this:

Stop all Software in XAMPP-Control Panel
Uninstall the complete XAMPP-Package
Start regedit and go to the Folder HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

and remove all Folders named with the Service-Names for the Servers (like Apache, MySQL or FileZilla).

Restart your Computer and install XAMPP completely new.

Now everything should work.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby aftecboy » 15. August 2008 17:12

glitzi85 wrote:OK, sounds like there something gone wrong. Try this:

Stop all Software in XAMPP-Control Panel
Uninstall the complete XAMPP-Package
Start regedit and go to the Folder HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

and remove all Folders named with the Service-Names for the Servers (like Apache, MySQL or FileZilla).

Restart your Computer and install XAMPP completely new.

Now everything should work.

glitzi



Okay, I followed your instructions as you outlined above. I then installed Xampp for Windows 32 1.6.7 and used only defaults as they were given. The installation came back and said that it installed successfully, and it opened the Control Panel for me. I clicked on start to start apache. The green "Running" came on, and I got excited. Then, the green "Running" notice went out. I then got sad.

I clicked on status, and everything was marked with a 0. So, I clicked on start apache again, and this time nothing happened. The status window states that Apache started [Port 80], but it doesn't show in the Control Panel that it did so.

When I enter http://localhost/ in a browser, I get the IIS default start page. My guess is that IIS is stepping on things here. We use Sharepoint here at work, so I guess I need IIS, or don't I? If so, how do I get around this if IIS is indeed the culprit and causing my greef? If not, how do I disable it?

I am using Windows XP Pro SP2, 2GB Ram, Kaspersky Internet protection, and the Windows firewall is off. I have told Kaspersky to like and work with XAMPP, and not block it.

Thanks,

aftecboy
aftecboy
 
Posts: 4
Joined: 15. August 2008 15:22

Postby aftecboy » 15. August 2008 17:35

Okay, I went to services and stopped World Wide Web Publishing service and then Apache works. I it was a IIS issue fighting apache. I set the port to listen to 8080, and enter http://localhost:8080 and the default xampp page appeared. I guess I am on my way. Thanks for the help.

aftecboy
aftecboy
 
Posts: 4
Joined: 15. August 2008 15:22

Postby glitzi85 » 15. August 2008 17:52

Yes, IIS is using Port 80 by default. Just keep Listen on 8080 and be happy :-)
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 75 guests