CGI error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

CGI error

Postby us-22 » 14. August 2008 00:41

Hi

I had install the last version of xampp in my machin

and try to install a news publishing script

when i go to index page or dirctory of that script i have an error below:

-------------------------------------------------------------------------

Server error!
The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.

Error 500
localhost
08/14/08 02:29:37
Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6

------------------------------------------------------------

what's wrong?

and how to make this script working ?

:?: :?:
thank's for your help
Think about the sea
us-22
 
Posts: 3
Joined: 14. August 2008 00:28
Location: Saudi Arabia

Postby glitzi85 » 14. August 2008 13:00

Post access.log and error.log from xampp\apache\logs here. Which Script do you use?

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby us-22 » 15. August 2008 20:47

hi glitzi85

this is what access.log contains
-----------------------------------------------------------

127.0.0.1 - - [13/Aug/2008:16:49:00 +0300] "GET / HTTP/1.0" 302 -
127.0.0.1 - - [13/Aug/2008:16:49:02 +0300] "GET /xampp/ HTTP/1.0" 302 -
127.0.0.1 - - [13/Aug/2008:16:49:02 +0300] "GET /xampp/splash.php HTTP/1.0" 200 1325
127.0.0.1 - - [13/Aug/2008:16:49:03 +0300] "GET /xampp/xampp.css HTTP/1.0" 200 4178
127.0.0.1 - - [13/Aug/2008:16:49:03 +0300] "GET /xampp/img/blank.gif HTTP/1.0" 200 43
127.0.0.1 - - [13/Aug/2008:16:49:03 +0300] "GET /xampp/img/xampp-logo.jpg HTTP/1.0" 200 19738
127.0.0.1 - - [13/Aug/2008:16:49:07 +0300] "GET /xampp/lang.php?en HTTP/1.0" 302 -
127.0.0.1 - - [13/Aug/2008:16:49:07 +0300] "GET /xampp/index.php HTTP/1.0" 200 602
127.0.0.1 - - [13/Aug/2008:16:49:08 +0300] "GET /xampp/head.php HTTP/1.0" 200 1393
127.0.0.1 - - [13/Aug/2008:16:49:08 +0300] "GET /xampp/start.php HTTP/1.0" 200 1072
127.0.0.1 - - [13/Aug/2008:16:49:08 +0300] "GET /xampp/navi.php HTTP/1.0" 200 4070
127.0.0.1 - - [13/Aug/2008:16:49:09 +0300] "GET /xampp/img/head-for.gif HTTP/1.0" 200 791
127.0.0.1 - - [13/Aug/2008:16:49:09 +0300] "GET /xampp/img/xampp-logo-new.gif HTTP/1.0" 200 4878
127.0.0.1 - - [13/Aug/2008:16:49:09 +0300] "GET /xampp/img/head-windows.gif HTTP/1.0" 200 1370
127.0.0.1 - - [13/Aug/2008:16:49:09 +0300] "GET /xampp/xampp.js HTTP/1.0" 200 573
127.0.0.1 - - [13/Aug/2008:16:49:11 +0300] "GET /xampp/img/strichel.gif HTTP/1.0" 200 61
127.0.0.1 - - [13/Aug/2008:16:49:11 +0300] "GET /xampp/img/apachefriends.gif HTTP/1.0" 200 979
127.0.0.1 - - [13/Aug/2008:16:49:15 +0300] "GET /xampp/php.php HTTP/1.0" 200 2
127.0.0.1 - - [13/Aug/2008:16:49:15 +0300] "GET /xampp/mysql.php HTTP/1.0" 200 2
127.0.0.1 - - [13/Aug/2008:16:49:16 +0300] "GET /cgi-bin/cgi.cgi HTTP/1.0" 200 2
127.0.0.1 - - [13/Aug/2008:16:49:16 +0300] "GET /xampp/ssi.shtml HTTP/1.0" 200 6
127.0.0.1 - - [13/Aug/2008:16:49:14 +0300] "GET /xampp/status.php HTTP/1.0" 200 3827
127.0.0.1 - - [13/Aug/2008:16:49:18 +0300] "GET /xampp/ming.php HTTP/1.0" 200 1268
127.0.0.1 - - [13/Aug/2008:16:49:18 +0300] "GET /xampp/mingswf.php?text=ceci+n+est+pas+un+ami+d+apache HTTP/1.0" 200 24989
127.0.0.1 - - [13/Aug/2008:16:49:37 +0300] "GET /xampp/ming.php?text=Mohammad HTTP/1.0" 200 1202
127.0.0.1 - - [13/Aug/2008:16:49:37 +0300] "GET /xampp/mingswf.php?text=Mohammad HTTP/1.0" 200 24157
127.0.0.1 - - [13/Aug/2008:16:49:58 +0300] "GET /xampp/ming.php?text=Pirates HTTP/1.0" 200 1199
127.0.0.1 - - [13/Aug/2008:16:49:58 +0300] "GET /xampp/mingswf.php?text=Pirates HTTP/1.0" 200 24013
127.0.0.1 - - [14/Aug/2008:02:07:11 +0300] "GET /news HTTP/1.0" 500 1140
127.0.0.1 - - [14/Aug/2008:02:29:37 +0300] "GET /news HTTP/1.0" 500 1140


-----------------------------------------------------------------------


and this what error.log contains

--------------------------------------------------------------------

[Wed Aug 13 16:21:24 2008] [warn] pid file C:/Program Files/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed Aug 13 16:21:32 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Wed Aug 13 16:21:32 2008] [notice] Server built: Jun 14 2008 19:02:12
[Wed Aug 13 16:21:32 2008] [notice] Parent: Created child process 4416
[Wed Aug 13 16:21:35 2008] [notice] Child 4416: Child process is running
[Wed Aug 13 16:21:35 2008] [notice] Child 4416: Acquired the start mutex.
[Wed Aug 13 16:21:35 2008] [notice] Child 4416: Starting 250 worker threads.
[Wed Aug 13 16:21:35 2008] [notice] Child 4416: Starting thread to listen on port 443.
[Wed Aug 13 16:21:35 2008] [notice] Child 4416: Starting thread to listen on port 80.
[Wed Aug 13 16:21:37 2008] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Wed Aug 13 16:21:37 2008] [notice] Child 4416: Exit event signaled. Child process is ending.
[Wed Aug 13 16:21:38 2008] [notice] Child 4416: Released the start mutex
[Wed Aug 13 16:21:39 2008] [notice] Child 4416: All worker threads have exited.
[Wed Aug 13 16:21:39 2008] [notice] Child 4416: Child process is exiting
[Wed Aug 13 16:21:39 2008] [notice] Parent: Child process exited successfully.
[Wed Aug 13 16:21:48 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Wed Aug 13 16:21:48 2008] [notice] Server built: Jun 14 2008 19:02:12
[Wed Aug 13 16:21:48 2008] [notice] Parent: Created child process 5180
[Wed Aug 13 16:21:50 2008] [notice] Child 5180: Child process is running
[Wed Aug 13 16:21:50 2008] [notice] Child 5180: Acquired the start mutex.
[Wed Aug 13 16:21:50 2008] [notice] Child 5180: Starting 250 worker threads.
[Wed Aug 13 16:21:50 2008] [notice] Child 5180: Starting thread to listen on port 443.
[Wed Aug 13 16:21:50 2008] [notice] Child 5180: Starting thread to listen on port 80.
[Wed Aug 13 16:40:09 2008] [notice] Parent: child process exited with status 1073807364 -- Restarting.
Apache server shutdown initiated...
[Wed Aug 13 16:42:35 2008] [warn] pid file C:/Program Files/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Wed Aug 13 16:42:43 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Wed Aug 13 16:42:43 2008] [notice] Server built: Jun 14 2008 19:02:12
[Wed Aug 13 16:42:43 2008] [notice] Parent: Created child process 768
[Wed Aug 13 16:42:46 2008] [notice] Child 768: Child process is running
[Wed Aug 13 16:42:46 2008] [notice] Child 768: Acquired the start mutex.
[Wed Aug 13 16:42:46 2008] [notice] Child 768: Starting 250 worker threads.
[Wed Aug 13 16:42:46 2008] [notice] Child 768: Starting thread to listen on port 443.
[Wed Aug 13 16:42:46 2008] [notice] Child 768: Starting thread to listen on port 80.
[Thu Aug 14 02:07:13 2008] [alert] [client 127.0.0.1] C:/Program Files/xampp/htdocs/news/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration
[Thu Aug 14 02:29:37 2008] [alert] [client 127.0.0.1] C:/Program Files/xampp/htdocs/news/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration
[Thu Aug 14 12:36:39 2008] [warn] pid file C:/Program Files/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu Aug 14 12:36:45 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Thu Aug 14 12:36:45 2008] [notice] Server built: Jun 14 2008 19:02:12
[Thu Aug 14 12:36:45 2008] [notice] Parent: Created child process 1960
[Thu Aug 14 12:36:47 2008] [notice] Child 1960: Child process is running
[Thu Aug 14 12:36:47 2008] [notice] Child 1960: Acquired the start mutex.
[Thu Aug 14 12:36:47 2008] [notice] Child 1960: Starting 250 worker threads.
[Thu Aug 14 12:36:47 2008] [notice] Child 1960: Starting thread to listen on port 443.
[Thu Aug 14 12:36:47 2008] [notice] Child 1960: Starting thread to listen on port 80.
[Fri Aug 15 22:02:01 2008] [warn] pid file C:/Program Files/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Fri Aug 15 22:02:36 2008] [notice] Apache/2.2.9 (Win32) DAV/2 mod_ssl/2.2.9 OpenSSL/0.9.8h mod_autoindex_color PHP/5.2.6 configured -- resuming normal operations
[Fri Aug 15 22:02:36 2008] [notice] Server built: Jun 14 2008 19:02:12
[Fri Aug 15 22:02:36 2008] [notice] Parent: Created child process 3188
[Fri Aug 15 22:02:39 2008] [notice] Child 3188: Child process is running
[Fri Aug 15 22:02:39 2008] [notice] Child 3188: Acquired the start mutex.
[Fri Aug 15 22:02:39 2008] [notice] Child 3188: Starting 250 worker threads.
[Fri Aug 15 22:02:39 2008] [notice] Child 3188: Starting thread to listen on port 80.
[Fri Aug 15 22:02:39 2008] [notice] Child 3188: Starting thread to listen on port 443.


-----------------------------------------------------------------------------------





the script what i use is news publishing script

you can find more about it on this link http://network-13.com/thread/c45412a29e0f10fb


thank's for help
Think about the sea
us-22
 
Posts: 3
Joined: 14. August 2008 00:28
Location: Saudi Arabia

Postby glitzi85 » 15. August 2008 21:03

That's a simple PHP-Script, not a CGI.

The Problem is located here:

[Thu Aug 14 02:07:13 2008] [alert] [client 127.0.0.1] C:/Program Files/xampp/htdocs/news/.htaccess: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration


Just open your httpd.conf, look for this line:

Code: Select all
#LoadModule rewrite_module modules/mod_rewrite.so


and remove the # at the beginning of the Line. Restart your Apache and try it again.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby us-22 » 17. August 2008 12:19

thank you very much

it's working now

thank you for help
Think about the sea
us-22
 
Posts: 3
Joined: 14. August 2008 00:28
Location: Saudi Arabia


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests

cron