Domain works outside network but not inside

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Domain works outside network but not inside

Postby rayishu » 12. August 2008 05:21

Ok, so i have my webserver up and my static IP is configured, i have my domain set to the nameservers and i have my apache setup properly (or so i think)

I can't access my domain from inside my network, when i type in the domain or Ip adress on any computer in my network i get a timed out error

but outside my personal network it works fine,

localhost works but many of my applications like wordpress and such have a path setup that uses the domain of the website, so i cant access those through localhost

anybody know whats wrong?
Posts: 6
Joined: 26. February 2006 19:47

Postby Smackie » 12. August 2008 15:09

Do you have a router? if so forward port 80 same with your firewall forward port 80 as well ..

go into C:\WINDOWS\System32\drivers\etc and open host file up using notepad or wordpad or something simular. and under localhost
type out this (your url without www) (your url with www)

This way if users type your url with or without www it will still go to your site.
Posts: 27
Joined: 21. August 2007 03:13

Postby kevinduke » 12. August 2008 17:06

most home routers do not support loopback so you can not use a domain name within your LAN.

You can try editing the host file on the PC so your domain ( points to your internal ip address.

Posts: 13
Joined: 11. October 2006 16:34

Postby rayishu » 12. August 2008 19:31

Thank you, excellent help (i dont have to use a proxy in order to see my web files anymore lol)
Posts: 6
Joined: 26. February 2006 19:47

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests