Why i can'nt change port for Apache in XAMP ?.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Why i can'nt change port for Apache in XAMP ?.

Postby junzennt » 01. August 2008 04:07

Because i'm using windows XP, on my own OS i run IIS (in port 80). I need change port of apache as 8080. I've been change port for apache in httpd.conf (80 -> 8080), but when i run xampp-control.exe, start apache not run. Screen message:

Apache started [Port 80]

I don't understand :shock: ,when i've been change 8080, apache not change. :evil:
Help me !. :cry:
Posts: 1
Joined: 01. August 2008 03:54

Postby glitzi85 » 01. August 2008 15:44

I guess you changed ServerName xxx:80 to ServerName xxx:8080, correct? In this case you should change the correct setting, which is named Listen.

User avatar
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Why i can'nt change port for Apache in XAMP ?.

Postby onlyconnect » 01. August 2008 22:47

junzennt wrote:BUSY...
Apache started [Port 80]

Actually this is just a bug in the control applet.

I fixed this in the version here:


Set the Apache port in XAMPP.INI.

NB this doesn't change the port Apache listens on, but it does fix a few things in the control applet.

Posts: 7
Joined: 18. July 2008 10:31

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests