IIS and XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

IIS and XAMPP

Postby GerardoPG » 18. July 2008 17:55

Hi,
I have a Win XP Pro with IIS installed. I'm starting (I want) playing with all XAMPP's packages. I now IIS run by default in port 80.

I modified the Apache's config file "httpd.conf" in order to run in another port "95".

This is my "httpd.conf" file modified lines:
Listen 95
ServerName localhost:95

So, after doing this I continue trying to start MySQL and Apache (from "xampp-control.exe") and Apache doesn't start. I had tried from "apache_start.bat" and I get this errors:
" . . . . .
Apache 2 is starting ...
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs
. . . . . "

I now that if I shutdown IIS Apache runs OK (because port 80 will be free); hey! but wait: I configured Apache to listen in port 95!!... And "xampp-control.exe" still say that Apache is trying to listen in port 80. How this can happen?

What if I want to run both webservers in the same machine, Can I?

My big question is: Can I have IIS and Apache running at the same time? How can I do this?

Thanks!
Gerardo.
GerardoPG
 
Posts: 5
Joined: 18. July 2008 17:25
Location: México

Re: IIS and XAMPP

Postby GerardoPG » 18. July 2008 17:56

GerardoPG wrote:Hi,
I have a Win XP Pro with IIS installed. I'm starting (I want) playing with all XAMPP's packages. I now IIS run by default in port 80.

I modified the Apache's config file "httpd.conf" in order to run in another port "95".

This is my "httpd.conf" file modified lines:
Listen 95
ServerName localhost:95

So, after doing this I continue trying to start MySQL and Apache (from "xampp-control.exe") and Apache doesn't start. I had tried from "apache_start.bat" and I get this errors:
" . . . . .
Apache 2 is starting ...
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs
. . . . . "

I now that if I shutdown IIS Apache runs OK (because port 80 will be free); hey! but wait: I configured Apache to listen in port 95!!... And "xampp-control.exe" still say that Apache is trying to listen in port 80. How this can happen?

What if I want to run both webservers in the same machine, Can I?

My big question is: Can I have IIS and Apache running at the same time? How can I do this?

Thanks!


BTW: Today is my birthday, so help me to get this working just a gift!!!

Thanks!
Gerardo.
GerardoPG
 
Posts: 5
Joined: 18. July 2008 17:25
Location: México

Postby Wiedmann » 18. July 2008 18:02

(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:443

You must also change the port for HTTPS in "httpd-ssl.conf" (or disable SSL).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby GerardoPG » 18. July 2008 18:28

Wiedmann wrote:
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:443

You must also change the port for HTTPS in "httpd-ssl.conf" (or disable SSL).


Hi,
I don't have any application running in port 443. Anyway, I found 3 places in the "httpd-ssl.conf" where the port 443 (for ssl) appears:

1) Listen 443
2) <VirtualHost _default_:443>
3) ServerName localhost:443

what line Do I have to modify?
or
How can I disable SSL in my development machine?

Thanks in advance for your help !!!
Gerardo.
GerardoPG
 
Posts: 5
Joined: 18. July 2008 17:25
Location: México

Postby Wiedmann » 18. July 2008 18:31

I don't have any application running in port 443

IIS is using this port (like every webserver, port 80 for HTTP and 443 for HTTPS).

what line Do I have to modify?

All

How can I disable SSL in my development machine?

Don't load the mod_ssl module und don't include httpd-ssl.conf.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby GerardoPG » 18. July 2008 19:05

Wiedmann wrote:
I don't have any application running in port 443

IIS is using this port (like every webserver, port 80 for HTTP and 443 for HTTPS).

what line Do I have to modify?

All

How can I disable SSL in my development machine?

Don't load the mod_ssl module und don't include httpd-ssl.conf.


Great!! Many thanks Wiedmann!!

Now, my Apache & IIS exists and I can work in my webservices development!!!

You rocks dude!!

Thanks!!
Gerardo.
GerardoPG
 
Posts: 5
Joined: 18. July 2008 17:25
Location: México


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 41 guests