No-Ip.com Address Works For XAMPP Default Site But Not Other

Problems with the Windows version of XAMPP, questions, comments, and anything related.

No-Ip.com Address Works For XAMPP Default Site But Not Other

Postby vincentrich » 16. July 2008 16:35

My XAMPP welcome page can be accessed via my No-IP.com address through the internet.

Here's how the Apache httpd.conf looks like for the XAMPP default site:

Code: Select all
ServerRoot "C:/Program Files/xampp/apache"
Listen 8091
ServerAdmin admin@localhost
ServerName 192.168.0.2:8091
DocumentRoot "C:/Program Files/xampp/htdocs"

<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

<Directory "C:/Program Files/xampp/htdocs">
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>


This is how my other sites looks like:
Code: Select all
<VirtualHost 192.168.0.2:8888>
   ServerAdmin myemail@domain.com
   DocumentRoot "C:/web site directory/"
   ServerName 192.168.0.2:8888
   ErrorLog logs/wes-error_log
   CustomLog logs/wes-access_log common
   <Directory "C:/web site directory/">
   Options Indexes FollowSymLinks Includes ExecCGI
   AllowOverride All
   Order allow,deny
   Allow from all
   </Directory>
</VirtualHost>


I have no idea why the XAMPP welcome page can be seen from my friend's computer while the other site can't. My friend said he gets a "network timeout" error in Firefox. I can assure you my port forwarding is correct and my No-IP.com has my latest ISP IP address.
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore

Postby vincentrich » 16. July 2008 16:38

Just to clarify that all the sites work on my LAN without any problems. I can't really tell what is different from my XAMPP default site and my other sites. They seem the same to me and I wonder why I cannot get my other sites to work.

Any help would be greatly appreciated! Thanks in advance.
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore

Postby vincentrich » 04. August 2008 10:19

Could someone please help?
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore

Postby vincentrich » 27. August 2008 10:00

i just changed to a new D-Link router and it is still the same. Could anyone help?
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore

Postby Wiedmann » 27. August 2008 10:04

You need a "Listen"-directive for each port you are using.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby vincentrich » 27. August 2008 10:08

Wiedmann wrote:You need a "Listen"-directive for each port you are using.


Code: Select all
#MY HOME WEB SERVER IP ADDRESSES
NameVirtualHost 192.168.0.2:8101
NameVirtualHost 192.168.0.2:8102
NameVirtualHost 192.168.0.2:8103
NameVirtualHost 192.168.0.2:8104
NameVirtualHost 192.168.0.2:8105
#NameVirtualHost 192.168.0.2:8106
NameVirtualHost 192.168.0.2:8107
NameVirtualHost 192.168.0.2:8108
NameVirtualHost 192.168.0.2:8109
NameVirtualHost 192.168.0.2:8110
NameVirtualHost 192.168.0.2:8111
NameVirtualHost 192.168.0.2:8112
NameVirtualHost 192.168.0.2:8113
NameVirtualHost 192.168.0.2:8114
NameVirtualHost 192.168.0.2:8115
NameVirtualHost 192.168.0.2:8116
NameVirtualHost 192.168.0.2:8117

Listen 192.168.0.2:8101
Listen 192.168.0.2:8102
Listen 192.168.0.2:8103
Listen 192.168.0.2:8104
Listen 192.168.0.2:8105
#Listen 192.168.0.2:8106
Listen 192.168.0.2:8107
Listen 192.168.0.2:8108
Listen 192.168.0.2:8109
Listen 192.168.0.2:8110
Listen 192.168.0.2:8111
Listen 192.168.0.2:8112
Listen 192.168.0.2:8113
Listen 192.168.0.2:8114
Listen 192.168.0.2:8115
Listen 192.168.0.2:8116
Listen 192.168.0.2:8117


I have done that. 8888 was just an example. These are the port numbers I use.
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore

Postby vincentrich » 27. August 2008 10:14

I wonder if I should drop the "192.168.0.2" from my code.. That is the only difference between the site that works and the rest that don't.
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore

Postby vincentrich » 27. August 2008 10:32

vincentrich wrote:I wonder if I should drop the "192.168.0.2" from my code.. That is the only difference between the site that works and the rest that don't.


Did not make a difference if I omitted the "192.168.0.2" from Listen.
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore

Postby vincentrich » 27. August 2008 11:35

I erased all the default XAMPP server code and made it into a virtual host like the rest of my sites.

Code: Select all
NameVirtualHost 192.168.0.2:8091
Listen 192.168.0.2:8091

#XAMPP
<VirtualHost 192.168.0.2:8091>
   ServerAdmin admin@localhost
   ServerName 192.168.0.2:8091
   DocumentRoot "C:/Program Files/xampp/htdocs"
   ErrorLog logs/xampp-error_log
   CustomLog logs/xampp-access_log common
   <Directory "C:/Program Files/xampp/htdocs">
   Options Indexes FollowSymLinks Includes ExecCGI
   AllowOverride All
   Order allow,deny
   Allow from all
   </Directory>
</VirtualHost>


Strange thing is... This XAMPP site above works. While the other 2 WordPress sites don't. I asked my friend to try to connect to my sites from his computer.
vincentrich
 
Posts: 45
Joined: 19. January 2005 10:05
Location: Singapore


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 35 guests