Mediawiki Fatal Error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mediawiki Fatal Error

Postby monarchdodra » 10. July 2008 09:12

I installed xampp to run a local mediawiki. After installing xampp, and running the mediawiki install script, when I go to my website (localhost\w\), I get a page with these errors:
Warning: domdocument::domdocument() expects at least 1 parameter, 0 given in C:\xampp\htdocs\w\includes\Preprocessor_DOM.php on line 566

Fatal error: Call to undefined method domdocument::loadXML() in C:\xampp\htdocs\w\includes\Preprocessor_DOM.php on line 568

I haven't changed any configurations in the xampp package. That and I used the xampp zip archive.

Anybody have any ideas? I doubt I should be changing the mediawiki code.
monarchdodra
 
Posts: 2
Joined: 10. July 2008 08:59

Postby Milligan » 10. July 2008 10:14

Last edited by Milligan on 17. July 2008 04:32, edited 1 time in total.
Milligan
 
Posts: 136
Joined: 03. March 2008 06:23

Postby monarchdodra » 10. July 2008 11:53

Wow, thanks. You are my God.

On a side note, when I did open php.ini, I found that extension=php_domxml.dll was already uncommented, and my heart sank, thinking "That's not it". In a bold and desperate move, I did the contrary, and commented it, and It worked!

Thanks.
Milligan wrote:There is an extension in the \apache\bin\php.ini file that may need uncommenting:

My guess is that you just kinda typoed, but you still solved my problem.
monarchdodra
 
Posts: 2
Joined: 10. July 2008 08:59

Postby torgum » 22. July 2008 07:26

What a pity.
This would've been the solution for the problem and I can't find it elsewhere... so what's the action plan exactly? The solution post hast been edited ...
torgum
 
Posts: 1
Joined: 22. July 2008 07:23

Postby auroguy » 22. July 2008 15:12

Hi there

I managed to work around the error by commenting out the line

extension=php_domxml.dll

in the php.ini file (under apache\bin\)

Credit to the original poster, and discredit to the editor of the posting.

At least it put me on the right track to find the problem! :)
auroguy
 
Posts: 1
Joined: 22. July 2008 12:54

Postby kojo » 31. July 2008 16:03

Hello!

I have exactly the same problem. Commenting or not commenting that line doesnt help. Any suggestions?
kojo
 
Posts: 1
Joined: 31. July 2008 16:01

Postby raziel23x » 03. August 2008 14:45

I have tried
Commenting out
extension=php_domxml.dll
Renaming
php_domxml.dill

and nothing has worked. I tried switch to php4 to see if that would work and all that did was give me a blank page.

I am going to try and install it while in php 4 and see if that will work

Warning: domdocument::domdocument() expects at least 1 parameter, 0 given in C:\xampp\htdocs\wiki\includes\Preprocessor_DOM.php on line 566

Fatal error: Call to undefined method domdocument::loadXML() in C:\xampp\htdocs\wiki\includes\Preprocessor_DOM.php on line 568


Please include all of the lines below when reporting installation problems.

* PHP 5.2.6 installed
* Found database drivers for: MySQL PostgreSQL
* PHP server API is apache2handler; ok, using pretty URLs (index.php/Page_Title)
* Have XML / Latin1-UTF-8 conversion support.
* Session save path (C:\xampp\tmp) appears to be valid.
* PHP's memory_limit is 32M.
* Couldn't find Turck MMCache, eAccelerator, APC or XCache; cannot use these for object caching.
* GNU diff3 not found.
* Found GD graphics library built-in, image thumbnailing will be enabled if you enable uploads.
* Installation directory: C:\xampp\htdocs\wiki
* Script URI path: /wiki
* Installing MediaWiki with php file extensions
* Environment checked. You can install MediaWiki.
* Warning: $wgSecretKey key is insecure, generated with mt_rand(). Consider changing it manually.
*

Generating configuration file...
* Database type: MySQL
* Loading class: DatabaseMysql
* Attempting to connect to database server as root...success.
* Connected to 5.0.51b-community-nt
* Attempting to create database...
* Created database wikidb
* Creating tables... done.
* Initializing statistics...
* User e107 exists. Skipping grants.
* Created sysop account raziel23x.
*

Creating LocalSettings.php...

Installation successful! Move the config/LocalSettings.php file to the parent directory, then follow this link to your wiki.

You should change file permissions for LocalSettings.php as required to prevent other users on the server reading passwords and altering configuration data.
raziel23x
 
Posts: 2
Joined: 03. August 2008 14:39

Postby TapouT » 04. August 2008 04:14

I too tried it both ways. I got it to work after commenting the line out and then stopping and starting Apache in the XAMPP control panel.
TapouT
 
Posts: 1
Joined: 04. August 2008 04:11

Postby raziel23x » 04. August 2008 09:10

TapouT wrote:I too tried it both ways. I got it to work after commenting the line out and then stopping and starting Apache in the XAMPP control panel.


what line did you comment out and where
raziel23x
 
Posts: 2
Joined: 03. August 2008 14:39

Postby cstewz » 07. August 2008 07:20

I had this problem as well, but I dropped the database and recreated it, deleted the mediawiki file from htdocs and then re-installed it. Once I did this, it's working perfectly.

Maybe give that a try if all else fails?
cstewz
 
Posts: 1
Joined: 07. August 2008 07:18

Postby robinflow » 14. August 2008 10:32

I commented the line for domxml and had to restart apache to be able to run. So try that, restart apache, and it might work, it worked for me!
robinflow
 
Posts: 1
Joined: 14. August 2008 10:30


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests