apache does not start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache does not start

Postby scmittal » 09. July 2008 16:45

I just installed xampp on my XP PC. From the xampp control panel, when I press 'start' on 'apache service' it says 'service started'. However, the green 'running' indication does not show up. Here is what's in the error.log file:
(OS 5)Access is denied. : apache.exe: could not open error log file C:/Documents and Settings/Subhash Mittal/My Documents/local_sites/yttweb/logs.
Unable to open logs
(OS 5)Access is denied. : apache.exe: could not open error log file C:/Documents and Settings/Subhash Mittal/My Documents/local_sites/yttweb/logs.
Unable to open logs
(OS 5)Access is denied. : apache.exe: could not open error log file C:/Documents and Settings/Subhash Mittal/My Documents/local_sites/yttweb/logs.
Unable to open logs

Please help. Thanks.
Subhash
scmittal
 
Posts: 3
Joined: 09. July 2008 16:40

Postby Wiedmann » 09. July 2008 16:50

C:/Documents and Settings/Subhash Mittal/My Documents/local_sites/yttweb/logs

This file exists?

For me that looks like a directory and not a file.

BTW: Your Apache process have access rights to this file/directory?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

apache does not start

Postby scmittal » 09. July 2008 16:59

Yes, C:/Documents and Settings/Subhash Mittal/My Documents/local_sites/yttweb/logs is a directory, not a file. Do I need to have a file there? if so, any specific name?

Also, how to allow the apache process access rights to this file/directory? I am relatively new to all this. Thanks for your help.

Subhash
scmittal
 
Posts: 3
Joined: 09. July 2008 16:40

Postby Wiedmann » 09. July 2008 17:20

Do I need to have a file there? if so, any specific name?

Hmm, You have configured Apache to use the file "C:/Documents and Settings/Subhash Mittal/My Documents/local_sites/yttweb/logs" as logfile. But if this is an existing directory, you must configure your logfile to e.g. "C:/Documents and Settings/Subhash Mittal/My Documents/local_sites/yttweb/logs/access.log"

Also, how to allow the apache process access rights to this file/directory?

If your Apache is running as service, right click this directory in explorer, go to the security tab, and make sure that "SYSTEM" have enough rights.

(But first verify your logfile setting in the Apache config)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby scmittal » 09. July 2008 17:57

Adding access.log and error.log to the two logfile entries did the trick. Now the apache svc shows the green 'running' indicator.

As for "right click this directory in explorer, go to the security tab, and make sure that "SYSTEM" have enough rights" - when I right-click on the folder name and click on 'properties' for the folder/file, all I see are the 'general', 'sharing' and the 'customize' tabs, no 'security' tab!

I truly appreciate your prompt help.
Subhash[/quote]
scmittal
 
Posts: 3
Joined: 09. July 2008 16:40

Postby Wiedmann » 09. July 2008 18:47

when I right-click on the folder name and click on 'properties' for the folder/file, all I see are the 'general', 'sharing' and the 'customize' tabs, no 'security' tab!

You should find the answer in the Windows help/knowledge base/support...

(Maybe wrong XP version or wrong explorer settings, imho something with easy folder view/file sharing)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests