xampp - port 80..

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp - port 80..

Postby imliquid » 03. July 2008 22:52

hi,

so here's the thing

im running xampp, and its running fine
the problem is, i can only access it remotely via port 8080, typing http://myipaddress:8080/

i want to be able to access it remotely via port 80, wich is the default for Web..i really need to somehow enable incoming connections through this port, so i wont need to type :8080 at the end

BUT i cant do port forwarding, because i'm not behind a router, i'm behind a surfboard (motorola SB5100) , and it's configuration doesn't include port forwarding...in fact, it doesn't need any, because it doesn't block the port...

i really dont know whats blocking it, but its not my firewall or any other protection software, cause i deactivated all of them..

need help
thx
- "Hi, I'm French sorry for my English."
- "Hi, I'm American sorry for my president..."
;)
imliquid
 
Posts: 3
Joined: 02. July 2008 18:48

Postby Danodemano » 05. July 2008 02:45

Last I checked, the only reason that you need to port forward is if you ARE behind a router. I'm assuming that you have a 192.168.1.x IP address, and this is a private IP. You MUST forward port 80 through the router, and make sure that the firewall is disabled. I can't speak for the SB5100 specifically, but in almost all cases, you have to forward ports through the router.

Also, check to ensure that you can access the server using http://localhost/ from the machine running xampp. If you are able to access it here, yet unable from the outside, then it is most likely the router blocking the connection. If it's not the router, then it's the OS. A xampp version and OS version would be helpful. :)

The last thing I would check, is are you actually running Apache on port 80?
Dan

Image
Danodemano
 
Posts: 31
Joined: 21. September 2007 00:16
Location: Dublin, OH

Postby imliquid » 05. July 2008 05:59

so Danodemano,

im running apache on port 80, i can access localhost, but the thing is, i'm really NOT behind a router, for that i'm sure...

it just seems that the port is blocked, although i can access anything from outside using it...so maybe just incoming connections are blocked...

well, thx for the help, but i really think it's my ISP blocking port 80 because of 'security' reasons...by the way, i'm from Brazil, the isp's here aren't that...sofisticated =D

thx anyway
- "Hi, I'm French sorry for my English."
- "Hi, I'm American sorry for my president..."
;)
imliquid
 
Posts: 3
Joined: 02. July 2008 18:48


Return to XAMPP for Windows

Who is online

Users browsing this forum: hthnightwolf and 65 guests