Questions regarding Mod_Deflate on Apache 2

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Questions regarding Mod_Deflate on Apache 2

Postby w4vy » 28. June 2008 16:30

Hey there I was wondering if someone could help me out with the Mod_Deflate on Apache server 2.8 as I am not sure if I have it set up correctly. I tried following the instructions at This Site but when it came to the Testing part I don't see the log file so does it work ? I don't know.

This is from my httpd.conf file does anyone know if I have it right please ?

Code: Select all
<Directory "#:/######/######">
   Options -Indexes FollowSymLinks Includes ExecCGI
   AllowOverride All
   Order allow,deny
        Allow from all
   
   SetOutputFilter DEFLATE
   SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ \
   no-gzip dont-vary
   SetEnvIfNoCase Request_URI \
   \.(?:exe|t?gz|zip|bz2|sit|rar)$ \
   no-gzip dont-vary
   SetEnvIfNoCase Request_URI \.pdf$ no-gzip dont-vary
   BrowserMatch ^Mozilla/4 gzip-only-text/html
   BrowserMatch ^Mozilla/4\.0[678] no-gzip
   BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
</Directory>


And I added this bit as I thought that is what the instructions meant when it said "either open your Apache2's global server configuration section now or just the vhost configuration section where you want to enable mod_deflate."

Code: Select all
<IfModule mod_deflate_module>
   DeflateFilterNote Input input_info
   DeflateFilterNote Output output_info
   DeflateFilterNote Ratio ratio_info
   LogFormat '"%r" %{output_info}n/%{input_info}n (%{ratio_info}n%%)' deflate
   CustomLog logs/mod_deflate.log deflate
</IfModule>


Any help would be great thankyou. :)
Image
User avatar
w4vy
 
Posts: 153
Joined: 04. June 2008 09:58
Location: England

Postby w4vy » 23. August 2008 19:25

bump.

Could someone here who uses Mod_Deflate please help me to get it working on my server thankyou.

Regards, w4vy
Image
User avatar
w4vy
 
Posts: 153
Joined: 04. June 2008 09:58
Location: England

Re: Questions regarding Mod_Deflate on Apache 2

Postby marcooo » 15. January 2009 19:34

Hi there,

yes - your code works. I copied the first part (coming to directory settings) into my config and it worked right away.

You can test it by taking the code out of your config, restarting apache, checking the size of the page with Firefox - reverse the process and see that the size is smaller than before.

Marco
marcooo
 
Posts: 1
Joined: 15. January 2009 19:32


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests